<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head >
<meta charset="UTF-8" />
<title>Meet the Queens Competing On &#039;RuPaul&#039;s Drag Race All Stars&#039; Season 3 - Towleroad</title>
<!-- This site is optimized with the Yoast SEO plugin v5.6 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Start your engines and get ready for another wig-shaking season of RuPaul’s Drag Race All Stars. On a special Mama Ru revealed nine of the queens"/>
<script src="/cdn-cgi/apps/head/A3bNKYP2epbsPGoBj9HE4gWaycc.js"></script><link rel="canonical" href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" />
<link rel="publisher" href="https://plus.google.com/+Towleroad"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Meet the Queens Competing On &#039;RuPaul&#039;s Drag Race All Stars&#039; Season 3 - Towleroad" />
<meta property="og:description" content="Start your engines and get ready for another wig-shaking season of RuPaul’s Drag Race All Stars. On a special Mama Ru revealed nine of the queens" />
<meta property="og:url" content="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" />
<meta property="og:site_name" content="Towleroad" />
<meta property="article:publisher" content="https://www.facebook.com/towleroad.page" />
<meta property="article:tag" content="rupaul" />
<meta property="article:tag" content="rupaul&#039;s drag race" />
<meta property="article:tag" content="RuPaul&#039;s Drag Race All Stars" />
<meta property="article:tag" content="television" />
<meta property="article:published_time" content="2017-10-20T23:23:47-04:00" />
<meta property="fb:app_id" content="180651805330333" />
<meta property="og:image" content="http://www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Start your engines and get ready for another wig-shaking season of RuPaul’s Drag Race All Stars. On a special Mama Ru revealed nine of the queens" />
<meta name="twitter:title" content="Meet the Queens Competing On &#039;RuPaul&#039;s Drag Race All Stars&#039; Season 3 - Towleroad" />
<meta name="twitter:site" content="@tlrd" />
<meta name="twitter:image" content="http://www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif" />
<meta name="twitter:creator" content="@tlrd" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.towleroad.com\/","name":"Towleroad","alternateName":"Towleroad Gay News","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.towleroad.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.towleroad.com\/2017\/10\/drag-race-all-stars-3-2\/","sameAs":["https:\/\/www.facebook.com\/towleroad.page","https:\/\/instagram.com\/tlrd\/","https:\/\/www.linkedin.com\/company\/towleroad","https:\/\/plus.google.com\/+Towleroad","https:\/\/www.youtube.com\/user\/TowleroadTV","https:\/\/www.pinterest.com\/towleroad\/","https:\/\/twitter.com\/tlrd"],"@id":"#organization","name":"Towleroad","logo":"http:\/\/towleroad.com\/wp-content\/uploads\/2015\/06\/600x600_T.jpg"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//www.towleroad.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Feed" href="http://www.towleroad.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Comments Feed" href="http://www.towleroad.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3 Comments Feed" href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.towleroad.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='child-theme-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/style.css?ver=1498864291' type='text/css' media='all' />
<link rel='stylesheet' id='glaser-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/webfonts/webfonts.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='be-icons-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/icons/styles.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='ea-jquery-ui-css'  href='//code.jquery.com/ui/1.10.4/themes/dot-luv/jquery-ui.min.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='ea-flexslider-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/flexslider/flexslider.css?ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='be-fonts-css'  href='http://fonts.googleapis.com/css?family=Noto+Sans%3A400%2C700&#038;ver=4.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.towleroad.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.4' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='http://www.towleroad.com/wp-json/' />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.towleroad.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='http://www.towleroad.com/?p=356532' />
<link rel="alternate" type="application/json+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2017%2F10%2Fdrag-race-all-stars-3-2%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2017%2F10%2Fdrag-race-all-stars-3-2%2F&#038;format=xml" />
<meta name='pubexchange:image' content='https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif?fit=300%2C153'>
<meta name='pubexchange:title' content='Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3'>

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript">

    	jQuery(".newsletter-optin").click(function() {
			jQuery(this).find("input").click();
    	});

		function setCookie(cname, cvalue, exdays) {
		    var d = new Date();
		    d.setTime(d.getTime() + (exdays*24*60*60*1000));
		    var expires = "expires="+d.toUTCString();
		    document.cookie = cname + "=" + cvalue + "; " + expires;
		}

		function subscribe_to_newsletter(comment_id) {

			jQuery.ajax({
			  type: "POST",
			  url: "http://staging.towleroad.com/disqus.php",
			  data: { comment_id: comment_id },
			beforeSend: function() {
				var loader = jQuery( "<img/>", {
				    src: "http://staging.towleroad.com/wp-admin/images/wpspin_light-2x.gif ", width: "32", height: "32",
				    "class": "loader-image"
				});		
				jQuery(".newsletter-optin").html(loader);
			},			  
			  success: function(data) {
			  		setCookie("newsletter-opted-in", "true", 365);
				jQuery(".newsletter-optin").html("Please check your email inbox to confirm the newsletter registration.");			      	

			    }
			});		
		}

		function disqus_config() {
		    this.callbacks.onNewComment = [function(comment) { 
		      var comment_id = comment.id;
		      var user_opted_for_newsletter_subscription = jQuery(".newsletter-optin input:checkbox:checked").length > 0;
		      if (user_opted_for_newsletter_subscription) {
		      	subscribe_to_newsletter(comment_id);			      	
		  	  }
		    }];
		}
    	var disqus_url ="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/";
	    var disqus_identifier = "356532 http://www.towleroad.com/?p=356532";
	    var disqus_title = "Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3";
    </script><!-- HEADER CODE START -->
<meta name="google-site-verification" content="aWVVHBSTDagAYi2h1c0bTxrpJO8OQ82AHU_iEUSByuE" />

<!-- Pingdom Site Monitoring added by ReadyMadeWeb in August -->
<script>

var _prum = [['id', '55c15d41abe53dd432e0057c'],
             ['mark', 'firstbyte', (new Date()).getTime()]];
(function() {
    var s = document.getElementsByTagName('script')[0]
      , p = document.createElement('script');
    p.async = 'async';
    p.src = '//rum-static.pingdom.net/prum.min.js';
    s.parentNode.insertBefore(p, s);
})();
</script>

<!-- Start: GPT Async -->

<!-- Criteo ad de blocker -->
<script type="text/javascript" src="//static.criteo.net/js/ld/publishertag.js"></script>
<!-- Criteo ad de blocker -->

<!-- AdSense Page Level Ads -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4162187998603810",
    enable_page_level_ads: true
  });
</script>
<!-- AdSense Page Level Ads -->

<!-- Header Bidding Code Start -->
  <!-- Prebid Config Section START -->
  <script>
    var PREBID_TIMEOUT = 1200;

    var adUnits = [
      {
        code: 'ad-rec1',
        sizes: [300, 250],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333810}}
        ]
      },{
        code: 'ad-rec2',
        sizes: [300, 250],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333848}}
        ]
      },{
        code: 'ad-rec3',
        sizes: [[300, 250],[300, 600],[160, 600]],
        sizeMapping: [
          { minWidth : 767, sizes : [[300, 250],[160, 600],[300, 600]] }, //if device screen width is > 767, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 499364}}
             ,{"bidder": "sovrn","params": {"tagid": 333850}}
             ,{"bidder": "sovrn","params": {"tagid": 333854}}
        ]
    },{
        code: 'ad-rec4',
        sizes: [[300, 250],[300, 600],[160, 600]],
        sizeMapping: [
          { minWidth : 767, sizes : [[300, 250],[160, 600],[300, 600]] }, //if device screen width is > 767, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333870}}
             ,{"bidder": "sovrn","params": {"tagid": 333851}}
             ,{"bidder": "sovrn","params": {"tagid": 335709}}
        ]
    },{
        code: 'ad-leader1',
        sizes: [728, 90],
        sizeMapping: [
          { minWidth : 767, sizes : [728,90] }, //if device screen width is > 767, use these sizes
          { minWidth : 0, sizes : [320,50] } //if device screen width is < 767 && > 0, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333807}}
             ,{"bidder": "sovrn","params": {"tagid": 420896}} //320x50
        ]
    },{
        code: 'ad-leader2',
        sizes: [728, 90],
        sizeMapping: [
          { minWidth : 767, sizes : [728,90] }, //if device screen width is > 767, use these sizes
          { minWidth : 0, sizes : [320,50] } //if device screen width is < 767 && > 0, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 335712}}
             ,{"bidder": "sovrn","params": {"tagid": 420897}} //320x50
        ]
    }];

    var pbjs = pbjs || {};
    pbjs.que = pbjs.que || [];

    pbjs.que.push(function() {
        pbjs.enableSendAllBids();
    });

pbjs.bidderSettings = {
   standard: {
      alwaysUseBid: false,
      adserverTargeting: [{
         key: "hb_bidder",
         val: function(bidResponse) {
            return bidResponse.bidderCode;
         }
      }, {
         key: "hb_adid",
         val: function(bidResponse) {
            return bidResponse.adId;
         }
      }, {
         key: "hb_pb",
         val: function(bidResponse) {
            return bidResponse.pbMg;
         }
      }, {
         key: "hb_size",
         val: function(bidResponse) {
            return bidResponse.size;
         }
      }]
   }
}
  </script>
  <!-- Prebid Config Section END -->

  <!-- Prebid Boilerplate Section START. No Need to Edit. -->
  <script type="text/javascript" src="//www.yourbow.com/pb/tlrdprebid.js" async></script>
  <script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    googletag.cmd.push(function() {
        googletag.pubads().disableInitialLoad();
    });

    pbjs.que.push(function() {
        pbjs.addAdUnits(adUnits);
        pbjs.requestBids({
            bidsBackHandler: sendAdserverRequest
        });
    });

    function sendAdserverRequest() {
        if (pbjs.adserverRequestSent) return;
        pbjs.adserverRequestSent = true;
        googletag.cmd.push(function() {
            pbjs.que.push(function() {
                pbjs.setTargetingForGPTAsync();
                googletag.pubads().refresh();
            });
        });
    }

    setTimeout(function() {
        sendAdserverRequest();
    }, PREBID_TIMEOUT);

  </script>
  <!-- Prebid Boilerplate Section END -->
<!-- Header Bidding Code END -->

<!-- DFP setup START -->
 <script type='text/javascript'>
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
 var gads = document.createElement("script");
 gads.async = true;
 gads.type = "text/javascript";
 var useSSL = "https:" == document.location.protocol;
 gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
 var node =document.getElementsByTagName("script")[0];
 node.parentNode.insertBefore(gads, node);
 })();
 </script>

<script>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</script>
<!-- HEADER CODE END -->


<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />
<link rel="pingback" href="http://www.towleroad.com/xmlrpc.php" />
<meta property="fb:pages" content="13794040506" />

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1699882000230257');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1699882000230257&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->


<script src="//load.sumome.com/" data-sumo-site-id="9ed9404ba9695df8b4b4aefc60ff8292dd425098853a4fcbf574bbd39845eec2" async="async"></script>

<meta name="pocket-site-verification" content="a63e5a37c49bc22a353dad335452bd" />



<!--[if lt IE 9]><script src="http://www.towleroad.com/wp-content/themes/genesis/lib/js/html5shiv.min.js"></script><![endif]-->
<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=270%2C270" />
</head>
<body class="post-template-default single single-post postid-356532 single-format-standard nolayout" itemscope itemtype="http://schema.org/WebPage">	<div id='interstitial'>
		<script type='text/javascript'>
			googletag.cmd.push(function() { googletag.display('interstitial'); });
		</script>
	</div>
<div class="site-container"><header class="site-header" itemscope itemtype="http://schema.org/WPHeader"><div class="wrap"><div class="header-sharing"><a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="site"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a> <a href="http://www.twitter.com/share?url=http://www.towleroad.com/"><i class="icon-twitter"></i></a></div><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.towleroad.com/">Towleroad</a></p></div><nav class="nav-header" itemscope itemtype="http://schema.org/SiteNavigationElement"><ul id="menu-primary" class="menu genesis-nav-menu menu-header"><li id="menu-item-337715" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-337715"><a href="http://www.towleroad.com/tag/daily-resist/" itemprop="url"><span itemprop="name">Daily Resist</span></a></li>
<li id="menu-item-227804" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227804"><a href="http://www.towleroad.com/tag/politics/" itemprop="url"><span itemprop="name">POLITICS</span></a></li>
<li id="menu-item-227806" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227806"><a href="http://www.towleroad.com/tag/travel/" itemprop="url"><span itemprop="name">Travel</span></a></li>
<li id="menu-item-227809" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227809"><a href="http://www.towleroad.com/tag/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
<li id="menu-item-227807" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227807"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url"><span itemprop="name">Theatre</span></a></li>
<li id="menu-item-227721" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227721"><a href="http://www.towleroad.com/tag/film/" itemprop="url"><span itemprop="name">Film</span></a></li>
<li id="menu-item-227808" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227808"><a href="http://www.towleroad.com/tag/television/" itemprop="url"><span itemprop="name">TV</span></a></li>
<li id="menu-item-270521" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-270521"><a href="http://www.towleroad.com/tag/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-227812" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227812"><a href="http://www.towleroad.com/tag/nature/" itemprop="url"><span itemprop="name">Nature</span></a></li>
<li class="menu-item search"><i class="icon-search"></i><form class="search-form" itemprop="potentialAction" itemscope itemtype="http://schema.org/SearchAction" method="get" action="http://www.towleroad.com/" role="search"><meta itemprop="target" content="http://www.towleroad.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="" /><input type="submit" value=""  /></form></li></ul></nav><nav class="nav-secondary" itemscope itemtype="http://schema.org/SiteNavigationElement"><ul id="menu-secondary" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-303865" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-303865"><a href="http://www.towleroad.com/tag/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
<li id="menu-item-276395" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-276395"><a href="http://www.towleroad.com/tag/men/" itemprop="url"><span itemprop="name">Men</span></a></li>
<li id="menu-item-227801" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227801"><a href="http://www.towleroad.com/tag/gay-marriage/" itemprop="url"><span itemprop="name">Marriage Equality</span></a></li>
<li id="menu-item-275223" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-275223"><a href="http://www.towleroad.com/tag/space/" itemprop="url"><span itemprop="name">Space</span></a></li>
<li id="menu-item-227820" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227820"><a href="http://www.towleroad.com/tag/transgender/" itemprop="url"><span itemprop="name">Trans Rights</span></a></li>
<li id="menu-item-227817" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227817"><a href="http://www.towleroad.com/tag/books/" itemprop="url"><span itemprop="name">Books</span></a></li>
<li id="menu-item-241504" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-241504"><a href="http://www.towleroad.com/tag/science/" itemprop="url"><span itemprop="name">Science</span></a></li>
<li id="menu-item-227819" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227819"><a href="http://www.towleroad.com/tag/gay-iconography/" itemprop="url"><span itemprop="name">Gay Iconography</span></a></li>
<li id="menu-item-227863" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227863"><a href="http://www.towleroad.com/tag/towleread/" itemprop="url"><span itemprop="name">TowleREAD</span></a></li>
</ul></nav><p class="breaking-news"><span class="red">BREAKING:</span> <a href="http://www.towleroad.com/2017/10/wilson-cruz-haters/">Wilson Cruz Blasts Haters of Star Trek&#8217;s Gay Relationship: &#8216;We Won&#8217;t Be Invisible Anymore&#8217;</a></p></div></header><div class="header-leaderboard tr-widget-area"><div class="wrap"><section id="text-3" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader1-->
<div class='responsive-ad'>
<div id='ad-leader1' style="margin-bottom:10px">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader1'); });
</script>
</div>
</div></div>
		</div></section>
</div></div><div class="site-inner"><div class="wrap"><div class="content-sidebar-wrap"><main class="content"><article class="post-356532 post type-post status-publish format-standard has-post-thumbnail tag-rupaul tag-rupauls-drag-race tag-rupauls-drag-race-all-stars tag-television entry" itemscope itemtype="http://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3</h1> 
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2017/10/ines-rau/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2017/10/ines-rau/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356522" alt="Trevor Bell" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS</span></a></div></div></div><div class="entry-meta"><p class="byline">by <a href="http://www.towleroad.com/author/bobby-hankinson/"> Bobby Hankinson</a><br />October 20, 2017 | 11:23pm</p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">6</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/&text=Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="356532 http://www.towleroad.com/?p=356532">Comments</span></a></div></div></header><div class="entry-content" itemprop="text"><p><img class="aligncenter size-full wp-image-356535" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif?resize=607%2C310" alt="RuPaul's Drag Race All Stars Season 3" data-recalc-dims="1" /></p>
<p>Start your engines and get ready for another wig-shaking season of <em>RuPaul’s Drag Race All Stars</em>. On a special Mama Ru revealed nine of the queens set to compete in a pre-taped special tonight on VH1.</p>
<p>Get to know nine of the returning queens competing this winter on VH1.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/jinDrtN9QEA?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Aja (Season Nine)</p>
<p>Best remembered for her legendary takedown of fan-favorite turned villainess Valentina, Aja is back with a vengeance. Sure, her first spin on the <em>Drag Race</em> merry-go-round wasn’t completely stellar, but with so much more world experience under this young queen’s belt, we’re excited to see what she’s got.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/d6ss9MhI3w4?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>BenDeLaCreme (Season Six)</p>
<p>Let’s be clear: The season six crown may have always been Bianca Del Rio’s to lose, but, honey, it is a damn CRIME that BenDeLaCreme wasn’t in the final three. BenDeLa brings an oversized personality and fully-realized character to every performance, and, if you’ve seen any of her solo shows, you know just how terminally delightful she can be.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/iJe5tUFa_7w?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Chi Chi DeVayne (Season Eight)</p>
<p>Chi Chi won admirers with high-energy performances that triumphed over her lack of high-priced drag. Proudly a budget queen, Chi Chi is coming into <em>All Stars</em> with a bit more in the bank, thanks to her legions of fans the worldover.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/DEO9nruP9Jo?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Kennedy Davenport (Season Seven)</p>
<p>Although season seven is not often remembered for being a favorite among fans, looking back at Kennedy Davenport’s performances is still thrilling. Of course, this high-kicking dancing diva stunned in a lip sync, but her Snatch Game-winning Little Richard impersonation was one of the most pleasantly surprising in herstory. Her lip sync against Katya still gives us chills (and bless her for inspiring Violet Chachki’s “Come through!” which we still use as a reaction GIF in text messages to this day).</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/wG47trEJqPc?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Milk (Season Six)</p>
<p>Known for avant garde drag (and dashing good looks that drive Tumblr wild), Milk’s outside-the-carton creativity led to big swings on the runway. Some were sickening (like when she got dressed as workroom Ru), while others sagged (the sadly safety-pinned crazy, sexy, cool getup.) Since the show, Milk’s done some modeling for Marc Jacobs, so hopefully that lends a bit more couture to all her kookiness.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/OflaDcmLSpg?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Morgan McMichaels (Season Two)</p>
<p>It was a whole different ballgame the last time Morgan McMichaels competed on <em>RuPaul’s Drag Race</em>. On season two, Morgan’s outfits ranged from simply pedestrian to <em>Rock of Love Bus</em> runner-up. Let’s see how she steps it up in competition to these cutting-edge queens.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/-OBOwY73Eoc?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Shangela (Seasons Two &amp; Three)</p>
<p>The queen so nice, she had to be eliminated twice. When we first met Shangela, she was fresh to the drag game. When she famously sprang from a box for a return in season three, she was still pretty green. But there’s a reason Ru brought her back: Shangela is a star. Now that she’s had the time to polish her natural charisma and show-womanship, she’s ready to snatch the crown.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/U1U1vgJ7cNA?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Thorgy Thor (Season Eight)</p>
<p>Yes, we know this is not <em>RuPaul’s Best Friend Race</em>, but we’d love to kiki with this charming queen. A clever (though sometimes too clever) comedienne, Thorgy could give BenDeLaCreme a run for her money in the delightful category. If Thorgy can stay out of her own head this time around, she’ll go far.</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/zTUgSBjOOa0?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Trixie Mattel (Season Seven)</p>
<p>Trixie is already an All-Star. She’s got a rabid fan base, a successful album and beloved webseries-turned-TV program with fellow season seven queen Katya. Hopefully that’s boosted her confidence so she can really show off everything’s she capable of.</p>
<p>??? (Season ???)</p>
<p>RuPaul certainly made it seem like there’s (at least) one more queen joining the fray. Leave your guesses for whom it may be in the comments!</p>
<p>&nbsp;</p>
<div class="pubexchange_module" id="pubexchange_below_content_1" data-pubexchange-module-id="1851"></div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/"
    dc:identifier="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/"
    dc:title="Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3"
    trackback:ping="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/trackback/" />
</rdf:RDF>-->
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2017/10/ines-rau/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2017/10/ines-rau/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356522" alt="Trevor Bell" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS</span></a></div></div></div><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">6</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/&text=Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">6</span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="356532 http://www.towleroad.com/?p=356532">Comments</span></a> <span class="st_email_hcount" st_url="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" displayText="Email"></span></div></div><footer class="entry-footer"><p>Posted October 20, 2017 at 11:23pm ETC by <a href="http://www.towleroad.com/author/bobby-hankinson/">Bobby Hankinson</a><br />in <a href="http://www.towleroad.com/tag/rupaul/">rupaul</a>, <a href="http://www.towleroad.com/tag/rupauls-drag-race/">rupaul's drag race</a>, <a href="http://www.towleroad.com/tag/rupauls-drag-race-all-stars/">RuPaul's Drag Race All Stars</a>, <a href="http://www.towleroad.com/tag/television/">television</a></p><div class="archive-post-info tr-widget-area"><section id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec1-->
<div class='responsive-ad'>
<div id='ad-rec1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec1'); });
</script>
</div>
</div>
</div>
		</div></section>
</div></footer></article><div class="before-comments tr-widget-area"><section id="text-30" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></br></br><iframe id="widgetPreview" style="width: 100%; background-color: transparent;" src="https://widget.icopyright.net/widgets/-Kf1VHiaUe9KeOHNbprO#-Kf1VHiaUe9KeOHNbprO" width="300" height="574" frameborder="0"></iframe></div>
		</div></section>
</div>
<div id="disqus_thread">
    </div>

</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="be-social-widget-3" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com/tlrd"><i class="icon-instagram"></i></a></p></div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec3-->
<div class='responsive-ad'>
<div id='ad-rec3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec3'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="text-17" class="widget widget_text"><div class="widget-wrap"><h4 class="widget-title widgettitle">Like Towleroad</h4>
			<div class="textwidget"><div class="fb-page" data-href="https://www.facebook.com/towleroad.page/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="true"><blockquote cite="https://www.facebook.com/towleroad.page/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/towleroad.page/">Towleroad</a></blockquote></div></div>
		</div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec4-->
<div class='responsive-ad'>
<div id='ad-rec4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec4'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="text-47" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec5-->
<div class='responsive-ad'>
<div id='ad-rec5'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec5'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="be-video-widget-2" class="widget be-video-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Video</h4>
<div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/"><img width="300" height="153" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif?fit=300%2C153" class="block wp-image-356535" alt="RuPaul&#039;s Drag Race All Stars Season 3" /></a><a class="play" href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/">Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">6</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/&text=Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356532"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">6</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/10/ines-rau/"><img width="255" height="300" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?fit=255%2C300" class="block wp-image-356522" alt="Trevor Bell" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?w=1200 1200w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=255%2C300 255w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=768%2C904 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=870%2C1024 870w" sizes="(max-width: 255px) 100vw, 255px" /></a><a class="play" href="http://www.towleroad.com/2017/10/ines-rau/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2017/10/ines-rau/">Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/ines-rau/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356521"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">14</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/ines-rau/&text=Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356521"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/ines-rau/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356521"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">14</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/"><img width="300" height="235" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?fit=300%2C235" class="block wp-image-356474" alt="Nylea VanHoutan" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?w=480 480w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?resize=300%2C235 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?resize=477%2C376 477w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/">Gay Missouri Teen Attacked By Gang of 20-30 Boys Because She is Gay: VIDEO</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356473"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">90</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/&text=Gay Missouri Teen Attacked By Gang of 20-30 Boys Because She is Gay: VIDEO" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356473"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356473"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">90</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/"><img width="300" height="169" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?fit=300%2C169" class="block wp-image-356503" alt="shirtless violinist stranger things" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?w=1280 1280w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=300%2C169 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=768%2C432 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=1024%2C576 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=150%2C84 150w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/">The Shirtless Violinist Finds His Upside Down in a Brilliant Take on the &#8216;Stranger Things&#8217; Theme — WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356502"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">75</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/&text=The Shirtless Violinist Finds His Upside Down in a Brilliant Take on the &#8216;Stranger Things&#8217; Theme — WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356502"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356502"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">75</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/10/eastsiders-season-3/"><img width="300" height="148" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?fit=300%2C148" class="block wp-image-356499" alt="eastsiders season 3" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?w=1092 1092w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=300%2C148 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=768%2C378 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=1024%2C504 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2017/10/eastsiders-season-3/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2017/10/eastsiders-season-3/">&#8216;EastSiders&#8217; Season 3 Takes Off on a Sexy Road Trip Across America in Its New Trailer: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/eastsiders-season-3/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356497"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">109</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/eastsiders-season-3/&text=&#8216;EastSiders&#8217; Season 3 Takes Off on a Sexy Road Trip Across America in Its New Trailer: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356497"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/eastsiders-season-3/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356497"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">109</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/10/conversion-therapy-camp/"><img width="300" height="60" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?fit=300%2C60" class="block wp-image-356489" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?resize=300%2C60 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?resize=768%2C154 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?resize=1024%2C205 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2017/10/conversion-therapy-camp/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2017/10/conversion-therapy-camp/">Will&#8217;s Confrontation with a Gay Conversion Therapy Camp Counselor is Sealed with a Kiss on &#8216;Will &#038; Grace: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/10/conversion-therapy-camp/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="356486"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">296</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/10/conversion-therapy-camp/&text=Will&#8217;s Confrontation with a Gay Conversion Therapy Camp Counselor is Sealed with a Kiss on &#8216;Will &#038; Grace: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="356486"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/10/conversion-therapy-camp/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="356486"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">296</span></a></div></div></div></section>
<section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec2-->
<div class='responsive-ad'>
<div id='ad-rec2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec2'); });
</script>
</div>
</div></div>
		</div></section>
<section id="be-eye-candy-2" class="widget be-eye-candy"><div class="widget-wrap"><h4 class="widget-title widgettitle">Hunk of the Day</h4>
<div class="eye-candy-post"><p class="featured-image"><a href="http://www.towleroad.com/2017/09/rugby-players/"><img width="300" height="215" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/09/rugby.jpg?fit=300%2C215" class="block wp-image-355324" alt="naked rugby" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/09/rugby.jpg?w=986 986w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/09/rugby.jpg?resize=300%2C215 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/09/rugby.jpg?resize=768%2C551 768w" sizes="(max-width: 300px) 100vw, 300px" /></a></p><p><a href="http://www.towleroad.com/2017/09/rugby-players/">52 Rugby Players from 6 Teams Got Naked for a New 2018 Charity Calendar to Fight Male Cancer: LOOK</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/09/rugby-players/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="355323"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">124</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/09/rugby-players/&text=52 Rugby Players from 6 Teams Got Naked for a New 2018 Charity Calendar to Fight Male Cancer: LOOK" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="355323"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/09/rugby-players/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="355323"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">124</span></a></div></div></div></section>
<section id="be-columns-widget-2" class="widget be-columns-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Columns</h4>
<ul><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/">Transcendent ‘Torch Song’ Starring Michael Urie and Mercedes Ruehl Is Required Gay Viewing: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/new-music/" class="column">New Music</a> <a href="http://www.towleroad.com/2017/10/new-music-10/">NEW MUSIC: St. Vincent, Courtney Barnett and Kurt Vile, Haim, The Smiths</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2017/10/time-conways/">‘Downton Abbey’s Elizabeth McGovern Opens in Puzzling ‘Time and the Conways’: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/film-review/" class="column">Film Review</a> <a href="http://www.towleroad.com/2017/09/battle-of-the-sexes-review/">&#8216;Battle of the Sexes&#8217; Pays Poignant Homage to Billie Jean King: Weekend Movie Review</a></li><li><a href="http://www.towleroad.com/tag/new-music/" class="column">New Music</a> <a href="http://www.towleroad.com/2017/09/new-music-glen-hansard-yusufcat-stevens-hurts-camille/">NEW MUSIC: Glen Hansard, Yusuf/Cat Stevens, Hurts, Camille</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2017/09/clockwork-orange-shirtless/">‘A Clockwork Orange’ Shows Plenty of Skin, Skimps on Danger Off-Broadway: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/towleread/" class="column">TowleREAD</a> <a href="http://www.towleroad.com/2017/09/spoiler-alert-the-hero-dies/">Michael Ausiello&#8217;s 14-Year Love Affair Laid Bare in the Funny, Heart-wrenching &#8216;Spoiler Alert: The Hero Dies&#8217;</a></li><li><a href="http://www.towleroad.com/tag/towleread/" class="column">TowleREAD</a> <a href="http://www.towleroad.com/2017/09/parvez-sharma/">A Sinner in Mecca: This Gay Muslim Risked His Life to Reveal a Side of Islam Most Have Never Seen</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2017/09/broadway-charm/">No Tea, No Shade — Off-Broadway&#8217;s &#8216;Charm&#8217; Wants You to Behave: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/film-review/" class="column">Film Review</a> <a href="http://www.towleroad.com/2017/09/movie-review-mother/">Movie Review: Darren Aronofsky&#8217;s Insane &#8216;mother!&#8217;</a></li></ul></div></section>
</aside></div><aside class="sidebar sidebar-secondary widget-area" role="complementary" aria-label="Secondary Sidebar" itemscope itemtype="http://schema.org/WPSideBar"><section id="text-50" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
<section id="be-latest-news-2" class="widget be-latest-news"><div class="widget-wrap"><h4 class="widget-title widgettitle">Latest Posts</h4>
<ul><li><a href="http://www.towleroad.com/2017/10/ines-rau/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356522" alt="Trevor Bell" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/ines-rau/">Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS</a><span class="post-time">9 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/wilson-cruz-haters/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356195" alt="star trek discovery gay" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/wilson-cruz-haters/">Wilson Cruz Blasts Haters of Star Trek&#8217;s Gay Relationship: &#8216;We Won&#8217;t Be Invisible Anymore&#8217;</a><span class="post-time">10 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/duane-greaton/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356516" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/duane-greaton/">HS Football Coach Told Team to Taunt Opposing Player with Gay Moms: &#8216;Who&#8217;s Your Daddy?&#8217;</a><span class="post-time">12 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/gay-israel-2/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356507" alt="Israel winter" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/gay-israel-2/">Gay Travelers, Escape the Winter Blahs In Stunning, Sunny Israel</a><span class="post-time">12 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356474" alt="Nylea VanHoutan" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/">Gay Missouri Teen Attacked By Gang of 20-30 Boys Because She is Gay: VIDEO</a><span class="post-time">13 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356503" alt="shirtless violinist stranger things" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?w=1280 1280w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=300%2C169 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=768%2C432 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=1024%2C576 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/">The Shirtless Violinist Finds His Upside Down in a Brilliant Take on the &#8216;Stranger Things&#8217; Theme — WATCH</a><span class="post-time">14 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/eastsiders-season-3/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356499" alt="eastsiders season 3" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/eastsiders-season-3/">&#8216;EastSiders&#8217; Season 3 Takes Off on a Sexy Road Trip Across America in Its New Trailer: WATCH</a><span class="post-time">14 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/oral-hpv-cancer/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356495" alt="male neck" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/oral-hpv-cancer/">Oral Sex and Smoking Increase Oral HPV Cancer Risk</a><span class="post-time">15 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356471" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/">Transcendent ‘Torch Song’ Starring Michael Urie and Mercedes Ruehl Is Required Gay Viewing: REVIEW</a><span class="post-time">16 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/conversion-therapy-camp/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356489" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/wg2.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/conversion-therapy-camp/">Will&#8217;s Confrontation with a Gay Conversion Therapy Camp Counselor is Sealed with a Kiss on &#8216;Will &#038; Grace: WATCH</a><span class="post-time">16 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/campaign-trail/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/obama.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356484" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/obama.jpg?w=1376 1376w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/obama.jpg?resize=300%2C169 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/obama.jpg?resize=768%2C431 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/obama.jpg?resize=1024%2C575 1024w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/obama.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/campaign-trail/">Back on Campaign Trail, Obama Urges Voters to Reject (Trumpian) Politics of &#8216;Division&#8217; &#8211; WATCH</a><span class="post-time">16 hours ago</span></li><li><a href="http://www.towleroad.com/2017/10/russia-eyes-criminalizing-gay-propaganda/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/04/putin.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-343706" alt="Putin drag" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/04/putin.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/04/putin.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/04/putin.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/russia-eyes-criminalizing-gay-propaganda/">Russia Eyes Criminalizing &#8216;Gay Propaganda&#8217;</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2017/10/thad-cochran/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/lee.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356459" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/lee.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/lee.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/lee.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/thad-cochran/">Russian Trolls, Kelly Clarkson, Fire Tornado, Chelsea Handler, Thad Cochran, Billy Joel, Puerto Rico: HOT LINKS</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2017/10/cassils-urine/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/cassils.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356455" alt="Cassils urine" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/cassils.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/cassils.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/cassils.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/cassils-urine/">Transgender Artist Saved 200 Gallons of Urine to Protest Trump: WATCH</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2017/10/george-w-bush-trump/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/george-w-bush.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356451" alt="George w Bush Trump" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/george-w-bush.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/george-w-bush.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/george-w-bush.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/george-w-bush-trump/">George W. Bush Blasts Unmentioned Trump in Speech Decrying &#8216;Bigotry, White Supremacy, Casual Cruelty&#8217; &#8211; WATCH</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2017/10/frank-ocean-defamation/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/ocean.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-325021" alt="Kanye West Frank Ocean" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/ocean.jpeg?w=950 950w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/ocean.jpeg?resize=300%2C169 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/ocean.jpeg?resize=768%2C432 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/ocean.jpeg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/frank-ocean-defamation/">Frank Ocean Wins $14.5 Million Defamation Suit Brought Against Him by His Father</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2017/10/rami-malek-freddie-mercury-3/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/11/malek.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-332205" alt="Rami Malek" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/11/malek.jpeg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/11/malek.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/11/malek.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/rami-malek-freddie-mercury-3/">Rami Malek Strikes a Convincing Pose as Freddie Mercury in New Tease from &#8216;Bohemian Rhapsody&#8217;</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2017/10/gay-couple-divorce-adopt/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/barreto.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-356439" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/barreto.jpg?resize=300%2C165 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/barreto.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/barreto.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2017/10/gay-couple-divorce-adopt/">Government Tells Gay Couple To (Fraudulently) Divorce If They Want To Keep Legal Rights To Their Son</a><span class="post-time">2 days ago</span></li></ul></div></section>
</aside></div></div><div class="related-post-carousel"><div class="wrap"><h4>You Might Also Like</h4><ul><li><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356535" alt="RuPaul&#039;s Drag Race All Stars Season 3" /></a><span class="category">television</span> <a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/" class="entry-title">Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3</a></li><li><a href="http://www.towleroad.com/2017/10/356254/" class="thumbnail"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/1280_rpdr_vh1_10037769_ver1.0.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356255" alt="RuPaul&#039;s Drag Race All Stars season 3 reveal and more TV this week" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/1280_rpdr_vh1_10037769_ver1.0.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/1280_rpdr_vh1_10037769_ver1.0.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/1280_rpdr_vh1_10037769_ver1.0.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">television</span> <a href="http://www.towleroad.com/2017/10/356254/" class="entry-title">&#8216;Drag Race All Stars&#8221; Ruvealed, &#8216;George Michael&#8217; Doc, &#8216;Walking Dead&#8217;, and More TV This Week</a></li><li><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2016/06/rupaul.jpeg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-318710" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2016/06/rupaul.jpeg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2016/06/rupaul.jpeg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2016/06/rupaul.jpeg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Entertainment</span> <a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3/" class="entry-title">The First Episode of RuPaul&#8217;s Drag Race All Stars 3 is Coming Sooner Than You Think: Next Week!</a></li><li><a href="http://www.towleroad.com/2017/10/tv-this-week-36/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/eff5d4b9dac42dfd0288390d68e0b72d.gif?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-355868" alt="" /></a><span class="category">television</span> <a href="http://www.towleroad.com/2017/10/tv-this-week-36/" class="entry-title">&#8216;Riverdale&#8217; Returns, Scandal on the &#8216;Runway&#8217; and More TV This Week&#8230;</a></li><li><a href="http://www.towleroad.com/2017/10/tv-this-week-35/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shade-drag-queens-of-new-york-city-fusion-tv-670x351-e1506992395374.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-355521" alt="Shade: Queens of NYC and more TV this week" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shade-drag-queens-of-new-york-city-fusion-tv-670x351-e1506992395374.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shade-drag-queens-of-new-york-city-fusion-tv-670x351-e1506992395374.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">television</span> <a href="http://www.towleroad.com/2017/10/tv-this-week-35/" class="entry-title">&#8216;Shade,&#8217; &#8216;Scandal,&#8217; Sam Smith Does &#8216;SNL&#8217; and More TV this Week</a></li><li><a href="http://www.towleroad.com/2017/09/transgender-couple-military/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/Logan_and_Laila_Ireland_trans_soldiers_Ellen.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-355285" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/Logan_and_Laila_Ireland_trans_soldiers_Ellen.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/Logan_and_Laila_Ireland_trans_soldiers_Ellen.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/Logan_and_Laila_Ireland_trans_soldiers_Ellen.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Transgender</span> <a href="http://www.towleroad.com/2017/09/transgender-couple-military/" class="entry-title">This Transgender Couple Met in the Military and Ellen is Celebrating Their Unique Story: WATCH</a></li></ul></div></div><footer class="site-footer" itemscope itemtype="http://schema.org/WPFooter"><div class="footer-popularity"><div class="wrap"><div class="offset"><h4>Latest Posts</h4><ul class="postfeed"><li><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/mgid-uma-image-logotv.com-10682693-2.gif?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356535 wp-post-image" alt="RuPaul&#039;s Drag Race All Stars Season 3" /></a><h3><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/">Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3</a></h3><p>Start your engines and get ready for another wig-shaking season of RuPaul’s Drag Race All Stars. On a special Mama Ru revealed nine of the queens set to compete in a pre-taped special tonight on VH1. Get to know nine of the returning queens competing&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/ines-rau/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356522 wp-post-image" alt="Trevor Bell" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/bell.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/ines-rau/">Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS</a></h3><p>GLOBAL. Rising tide of crackdowns on LGBT people: &#8220;A purge — likely in the form of mass incarcerations — is exactly what human rights organizations are afraid will happen. But the phenomenon would not be unique to Tajikistan: Over the past few&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/ines-rau/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/wilson-cruz-haters/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356195 wp-post-image" alt="star trek discovery gay" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/discovery.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/wilson-cruz-haters/">Wilson Cruz Blasts Haters of Star Trek&#8217;s Gay Relationship: &#8216;We Won&#8217;t Be Invisible Anymore&#8217;</a></h3><p>Wilson Cruz came after homophobic Star Trek fans who are upset that there&#8217;s a gay relationship in the new TV series Star Trek: Discovery. RELATED: ‘Star Trek: Discovery’ Made Gay Love Explicit Last Night, in Matching Red Pajamas Wrote Cruz in a&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/wilson-cruz-haters/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/duane-greaton/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356516 wp-post-image" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/2_greaton.jpg?zoom=2&amp;resize=195%2C195 390w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/duane-greaton/">HS Football Coach Told Team to Taunt Opposing Player with Gay Moms: &#8216;Who&#8217;s Your Daddy?&#8217;</a></h3><p>Duane Greaton, a high school football coach at Gray-New Gloucester High School in Maine, instructed his team to taunt an opposing player with gay moms, using the chant &#8220;who&#8217;s your daddy&#8221; when the player was tackled. The Press Herald&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/duane-greaton/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/gay-israel-2/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356507 wp-post-image" alt="Israel winter" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/09/israel.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/gay-israel-2/">Gay Travelers, Escape the Winter Blahs In Stunning, Sunny Israel</a></h3><p>With autumn’s official arrival, it’s easy to watch the days get shorter and let that Seasonal Affective Disorder wash over you. Instead of giving in to American Horror Story: Stir Crazy, overdose on vitamin D with a winter getaway heavy on outdoor ad&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/gay-israel-2/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356474 wp-post-image" alt="Nylea VanHoutan" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Nylea-VanHoutan.jpg?zoom=2&amp;resize=195%2C195 390w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/">Gay Missouri Teen Attacked By Gang of 20-30 Boys Because She is Gay: VIDEO</a></h3><p>A Missouri teenager has alleged that a group of between 20 and 30 boys beat her up because she is gay. 16-year-old Nylea VanHoutan the attack happened after she and three friends left a festival in St. Joseph. VanHoutan told Fox43: &#8220;It was like&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356503 wp-post-image" alt="shirtless violinist stranger things" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/10/shirtlessthings.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/">The Shirtless Violinist Finds His Upside Down in a Brilliant Take on the &#8216;Stranger Things&#8217; Theme — WATCH</a></h3><p>Be transported to the Upside Down with a new brilliant version of the Stranger Things theme from our friend the Shirtless Violinist, who layers 12 different violin tracks in this phantasmagoric clip. Writes the violinist: SHIRTLESS Things? Stranger S&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/eastsiders-season-3/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356499 wp-post-image" alt="eastsiders season 3" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/3_eastsiders.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/eastsiders-season-3/">&#8216;EastSiders&#8217; Season 3 Takes Off on a Sexy Road Trip Across America in Its New Trailer: WATCH</a></h3><p>Cal (creator Kit Williamson) and Thom (Van Hansis) are back for another season of the sexy, funny web series EastSiders, and this season sends the couple on a colorful coast-to-coast road trip from New York to California. The series synopsis: &#8220;&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/eastsiders-season-3/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/oral-hpv-cancer/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356495 wp-post-image" alt="male neck" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/10/Male_neck.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/oral-hpv-cancer/">Oral Sex and Smoking Increase Oral HPV Cancer Risk</a></h3><p>Smoking cigarettes, along with having five or more oral sex partners, increases men’s risk for the most common type of head and neck cancer. A study published Friday in Annals of Oncology finds these patterns of behavior are associated with oral and&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/oral-hpv-cancer/">Read</a></p></li><li><a href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-356471 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/10/torch-song.jpg?zoom=2&amp;resize=195%2C195 390w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/">Transcendent ‘Torch Song’ Starring Michael Urie and Mercedes Ruehl Is Required Gay Viewing: REVIEW</a></h3><p>Some stories both define and transcend a generation. When Harvey Fierstein’s Torch Song Trilogy premiered more than 35 years ago, first in scrappy downtown theatres and then on Broadway in 1982, some audiences were shocked; others saw their lives ref&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/">Read</a></p></li></ul></div><div class="above-footer tr-widget-area"><div class="wrap"><section id="text-10" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader2 -->
<div id='ad-leader2' style="text-align:center;">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader2'); });
</script>
</div></div>
		</div></section>
</div></div><aside id="dpp_widget-2" class="widget box desktop widget_dpp_widget"><h3 class="widget-title">Most Commented</h3><span class="dpp_render_area" id="dpp_render_area-2"></span></aside><div class="box hot-reads"><h4>Hot Reads</h4><div class="menu-popular-posts-container"><ul id="menu-popular-posts" class="menu"><li id="menu-item-351483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351483"><a href="http://www.towleroad.com/2017/07/trump-family-2/" itemprop="url">America’s Top Crime Family: The Trumps</a></li>
<li id="menu-item-349563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-349563"><a href="http://www.towleroad.com/2017/06/anti-gay-baker-case/" itemprop="url">High Stakes for LGBTQ Equality in the Anti-Gay Baker Case at the Supreme Court</a></li>
<li id="menu-item-344169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344169"><a href="http://www.towleroad.com/2017/04/state-department-chechnya/" itemprop="url">State Department ‘Deeply Disturbed’ by Reports of Detention, Torture, and Murder of Gay Men in Chechnya</a></li>
<li id="menu-item-344168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344168"><a href="http://www.towleroad.com/2017/04/kenneth-adkins-2/" itemprop="url">Anti-Gay Pastor Who Said Orlando Victims ‘Got What They Deserved’ Guilty of Sexually Molesting Boy and Girl</a></li>
<li id="menu-item-339222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-339222"><a href="http://www.towleroad.com/2017/01/neil-gorsuch/" itemprop="url">Neil Gorsuch is Trump’s Terrible, No Good Nominee for the Supreme Court: An Analysis</a></li>
<li id="menu-item-336834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336834"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/" itemprop="url">2017 Resolutions All Gay Men Should Consider</a></li>
<li id="menu-item-323766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323766"><a href="http://www.towleroad.com/2016/08/eric-andre-bisexual/" itemprop="url">Comedian Eric Andre: The Gay Interview</a></li>
</ul></div></div></div></div><div class="footer-today"><div class="wrap"><div class="today-header"><h4>Today's News</h4><div class="jump-to-day">Jump To Day: <a href="#">Choose <i class="icon-arrow-down"></i></a></div></div><ul class="one-fourth first"><li><a href="http://www.towleroad.com/2017/10/drag-race-all-stars-3-2/">Meet the Queens Competing On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; Season 3</a></li><li><a href="http://www.towleroad.com/2017/10/ines-rau/">Madonna&#8217;s Erotica, Betsy DeVos, P!nk, Ines Rau, Taylor Swift, Tonya Harding, Playboy, Niall Horan: HOT LINKS</a></li><li><a href="http://www.towleroad.com/2017/10/wilson-cruz-haters/">Wilson Cruz Blasts Haters of Star Trek&#8217;s Gay Relationship: &#8216;We Won&#8217;t Be Invisible Anymore&#8217;</a></li><li><a href="http://www.towleroad.com/2017/10/duane-greaton/">HS Football Coach Told Team to Taunt Opposing Player with Gay Moms: &#8216;Who&#8217;s Your Daddy?&#8217;</a></li><li><a href="http://www.towleroad.com/2017/10/gay-israel-2/">Gay Travelers, Escape the Winter Blahs In Stunning, Sunny Israel</a></li><li><a href="http://www.towleroad.com/2017/10/gay-missouri-teen-attacked/">Gay Missouri Teen Attacked By Gang of 20-30 Boys Because She is Gay: VIDEO</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2017/10/shirtless-violinist-stranger-things/">The Shirtless Violinist Finds His Upside Down in a Brilliant Take on the &#8216;Stranger Things&#8217; Theme — WATCH</a></li><li><a href="http://www.towleroad.com/2017/10/eastsiders-season-3/">&#8216;EastSiders&#8217; Season 3 Takes Off on a Sexy Road Trip Across America in Its New Trailer: WATCH</a></li><li><a href="http://www.towleroad.com/2017/10/oral-hpv-cancer/">Oral Sex and Smoking Increase Oral HPV Cancer Risk</a></li><li><a href="http://www.towleroad.com/2017/10/torch-song-trilogy-review/">Transcendent ‘Torch Song’ Starring Michael Urie and Mercedes Ruehl Is Required Gay Viewing: REVIEW</a></li><li><a href="http://www.towleroad.com/2017/10/conversion-therapy-camp/">Will&#8217;s Confrontation with a Gay Conversion Therapy Camp Counselor is Sealed with a Kiss on &#8216;Will &#038; Grace: WATCH</a></li><li><a href="http://www.towleroad.com/2017/10/campaign-trail/">Back on Campaign Trail, Obama Urges Voters to Reject (Trumpian) Politics of &#8216;Division&#8217; &#8211; WATCH</a></li></ul></div></div><aside id="text-12" class="widget box desktop widget_text">			<div class="textwidget">
</div>
		</aside><div class="lower-footer"><div class="wrap"><div class="one-half first"><section id="be-andy-banner-2" class="widget be-andy-banner"><div class="widget-wrap"><h4 class="widget-title widgettitle">Share This</h4>
<p class="featured-image"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/"><img width="477" height="409" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/12/2017RESOLUTIONSImageLowerRes.jpg?resize=477%2C409" class="block wp-image-336420" alt="" /></a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/01/2017-gay-resolutions/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">3.3k</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/01/2017-gay-resolutions/&text=2017 Resolutions All Gay Men Should Consider" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/01/2017-gay-resolutions/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">3.3k</span></a></div></div></section>
</div><div class="one-half"><div class="one-half first"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Read</h4>
<div class="menu-footer-read-container"><ul id="menu-footer-read" class="menu"><li id="menu-item-219178" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219178"><a href="http://www.towleroad.com/tag/politics/" itemprop="url">Politics</a></li>
<li id="menu-item-219476" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219476"><a href="http://www.towleroad.com/tag/travel/" itemprop="url">Travel</a></li>
<li id="menu-item-219478" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219478"><a href="http://www.towleroad.com/tag/film/" itemprop="url">Film</a></li>
<li id="menu-item-219477" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219477"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url">Theatre</a></li>
<li id="menu-item-219479" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219479"><a href="http://www.towleroad.com/tag/television-2/" itemprop="url">Television</a></li>
<li id="menu-item-219480" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219480"><a href="http://www.towleroad.com/tag/science-2/" itemprop="url">Science</a></li>
<li id="menu-item-219481" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219481"><a href="http://www.towleroad.com/tag/law-gay-lgbt/" itemprop="url">Law &#8211; LGBT Rights</a></li>
<li id="menu-item-219183" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219183"><a href="#" itemprop="url">Columns</a></li>
<li id="menu-item-219184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219184"><a href="#" itemprop="url">Specials</a></li>
</ul></div></div></section>
</div><div class="one-half"><section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">About</h4>
<div class="menu-footer-about-container"><ul id="menu-footer-about" class="menu"><li id="menu-item-219388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="http://www.towleroad.com/contact/" itemprop="url">Advertise</a></li>
<li id="menu-item-219196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="http://www.towleroad.com/contact/" itemprop="url">Contact Us</a></li>
<li id="menu-item-219193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="http://www.towleroad.com/about-us/" itemprop="url">About Towleroad</a></li>
<li id="menu-item-219233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219233"><a href="http://www.towleroad.com/authors/" itemprop="url">Contributors</a></li>
<li id="menu-item-219443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="http://www.towleroad.com/towleroad-social-media/" itemprop="url">Towleroad on Social Media</a></li>
<li id="menu-item-219194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="http://www.towleroad.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
<section id="be-social-widget-2" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com"><i class="icon-instagram"></i></a></p></div></section>
</div><p class="copyright">&copy; 2014 Towleroad. All Rights Reserved.</p></div></div></div></footer></div><script type="text/javascript">
 /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
 var disqus_shortname = 'towleroad'; // required: replace example with your blog short name
/* * * DON'T EDIT BELOW THIS LINE * * */
 (function () {
 var s = document.createElement('script'); s.async = true;
 s.type = 'text/javascript';
 s.src = '//' + disqus_shortname + '.disqus.com/count.js';
 (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
 }());
 </script>
<script type="text/javascript">var switchTo5x=true;</script>
<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">stLight.options({publisher: "25ce3796-0f6f-43b9-a36c-78c2238b9f95", doNotHash: true, doNotCopy: true, hashAddressBar: false});</script>	
	<script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><!-- Chartbeat Tag, part 1 --> 
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-283150-1']);
  _gaq.push(['_setDomainName', '.towleroad.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

<!-- Begin comScore Tag -->
<script>
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
</script>

<script>
  COMSCORE.beacon({
    c1:2,
    c2:7584020,
    c3:"",
    c4:"",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=7584020&c3=&c4=&c5=&c6=&c15=&cj=1" />
</noscript>

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"NCUJh1awVK000u", domain:"towleroad.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=NCUJh1awVK000u" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<!-- Quantcast Tag, part 1 --> 
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
   var elem = document.createElement('script');

   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);  
  })();
</script>

<!-- Facebook APP tag -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '1774199316148150',
      xfbml      : true,
      version    : 'v2.6'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- Facebook APP tag end -->


<!-- Quantcast Tag, part 2 -->
<script type="text/javascript">
_qevents.push( { 
qacct:"p-93b6WeVYdHXoc",
labels:"AskTell.Towleroad,Towleroad,TRFront"
} );
</script>
<noscript>
<div style="display: none;"><img src="//pixel.quantserve.com/pixel/p-93b6WeVYdHXoc.gif?labels=AskTell%20Towleroad%2CTowleroad" height="1" width="1" alt="Quantcast"/></div>
</noscript>

<script type="text/javascript">
var _sf_async_config={uid:551,domain:"towleroad.com",useCanonical:true};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script>

<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />

<script async="" defer="" src="//survey.g.doubleclick.net/async_survey?site=lcfgvapu5adkw"></script>

<script type="text/javascript" src="http://www.lijit.com/blog_wijits?json=0&amp;id=trakr&amp;uri=http%3A%2F%2Fwww.lijit.com%2Fusers%2Ftowleroad&amp;js=1"></script>

<script type="text/javascript" src="//s.skimresources.com/js/92217X1546135.skimlinks.js"></script>

<script>(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><link rel='stylesheet' id='ea-share-count-css'  href='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/css/share-count.css?ver=1.8.0' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201742'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/lib/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.fitvids.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.matchHeight-min.js?ver=0.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ea_theme_details = {"home_url":"http:\/\/www.towleroad.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/global.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.flexslider-min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8.2","language":""},"disqusIdentifier":"356532 http:\/\/www.towleroad.com\/?p=356532","disqusShortname":"towleroad","disqusTitle":"Meet the Queens Competing On \u2018RuPaul\u2019s Drag Race All Stars\u2019 Season 3","disqusUrl":"http:\/\/www.towleroad.com\/2017\/10\/drag-race-all-stars-3-2\/","options":{"manualSync":"1"},"postId":"356532"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/modules/shortcodes/js/instagram.js?ver=4.8.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dpp_ajax = {"ajaxurl":"http:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-popular-posts/dpp.js?ver=4.8.2'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/js/share-count.js?ver=1.8.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"towleroad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201742.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.4',blog:'93805103',post:'356532',tz:'-4',srv:'www.towleroad.com'} ]);
	_stq.push([ 'clickTrackerInit', '93805103', '356532' ]);
</script>
</body>
</html>
