<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head >
<meta charset="UTF-8" />
<title>&#039;Butterscotch Goddam&#039; is Fischerspooner&#039;s Fresh, Sticky, Sexy Love Affair: WATCH - Towleroad</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v5.9.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Fischerspooner sexy video: “This album is a document of a turbulent, wild transformation full of love, loss, lust and redemption.&quot;"/>
<meta name="news_keywords" content="casey spooner, entertainment, fischerspooner, music, music video, gay, lgbt, queer" />
<meta name="original-source" content="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" />
<script src="/cdn-cgi/apps/head/A3bNKYP2epbsPGoBj9HE4gWaycc.js"></script><link rel="canonical" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" />
<link rel="publisher" href="https://plus.google.com/+Towleroad"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;Butterscotch Goddam&#039; is Fischerspooner&#039;s Fresh, Sticky, Sexy Love Affair: WATCH - Towleroad" />
<meta property="og:description" content="Fischerspooner sexy video: “This album is a document of a turbulent, wild transformation full of love, loss, lust and redemption.&quot;" />
<meta property="og:url" content="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" />
<meta property="og:site_name" content="Towleroad" />
<meta property="article:publisher" content="https://www.facebook.com/towleroad.page" />
<meta property="article:author" content="https://www.facebook.com/andytowle" />
<meta property="article:tag" content="Casey Spooner" />
<meta property="article:tag" content="Entertainment" />
<meta property="article:tag" content="Fischerspooner" />
<meta property="article:tag" content="music" />
<meta property="article:tag" content="music video" />
<meta property="article:published_time" content="2018-02-16T11:43:24-05:00" />
<meta property="fb:app_id" content="180651805330333" />
<meta property="og:image" content="http://www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Fischerspooner sexy video: “This album is a document of a turbulent, wild transformation full of love, loss, lust and redemption.&quot;" />
<meta name="twitter:title" content="&#039;Butterscotch Goddam&#039; is Fischerspooner&#039;s Fresh, Sticky, Sexy Love Affair: WATCH - Towleroad" />
<meta name="twitter:site" content="@tlrd" />
<meta name="twitter:image" content="http://www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg" />
<meta name="twitter:creator" content="@andytowle" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.towleroad.com\/","name":"Towleroad","alternateName":"Towleroad Gay News","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.towleroad.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.towleroad.com\/2018\/02\/fischerspooner-sexy-video\/","sameAs":["https:\/\/www.facebook.com\/towleroad.page","https:\/\/instagram.com\/tlrd\/","https:\/\/www.linkedin.com\/company\/towleroad","https:\/\/plus.google.com\/+Towleroad","https:\/\/www.youtube.com\/user\/TowleroadTV","https:\/\/www.pinterest.com\/towleroad\/","https:\/\/twitter.com\/tlrd"],"@id":"#organization","name":"Towleroad","logo":"http:\/\/towleroad.com\/wp-content\/uploads\/2015\/06\/600x600_T.jpg"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.towleroad.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Feed" href="http://www.towleroad.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Comments Feed" href="http://www.towleroad.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; &#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH Comments Feed" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.towleroad.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='child-theme-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/style.css?ver=1498864291' type='text/css' media='all' />
<link rel='stylesheet' id='glaser-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/webfonts/webfonts.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='be-icons-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/icons/styles.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ea-jquery-ui-css'  href='//code.jquery.com/ui/1.10.4/themes/dot-luv/jquery-ui.min.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ea-flexslider-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/flexslider/flexslider.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='be-fonts-css'  href='http://fonts.googleapis.com/css?family=Noto+Sans%3A400%2C700&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.towleroad.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://www.towleroad.com/wp-json/' />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.towleroad.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='http://www.towleroad.com/?p=364394' />
<link rel="alternate" type="application/json+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2018%2F02%2Ffischerspooner-sexy-video%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2018%2F02%2Ffischerspooner-sexy-video%2F&#038;format=xml" />
<meta name='pubexchange:image' content='https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?fit=300%2C174'>
<meta name='pubexchange:title' content='&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH'>

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript">

    	jQuery(".newsletter-optin").click(function() {
			jQuery(this).find("input").click();
    	});

		function setCookie(cname, cvalue, exdays) {
		    var d = new Date();
		    d.setTime(d.getTime() + (exdays*24*60*60*1000));
		    var expires = "expires="+d.toUTCString();
		    document.cookie = cname + "=" + cvalue + "; " + expires;
		}

		function subscribe_to_newsletter(comment_id) {

			jQuery.ajax({
			  type: "POST",
			  url: "http://staging.towleroad.com/disqus.php",
			  data: { comment_id: comment_id },
			beforeSend: function() {
				var loader = jQuery( "<img/>", {
				    src: "http://staging.towleroad.com/wp-admin/images/wpspin_light-2x.gif ", width: "32", height: "32",
				    "class": "loader-image"
				});		
				jQuery(".newsletter-optin").html(loader);
			},			  
			  success: function(data) {
			  		setCookie("newsletter-opted-in", "true", 365);
				jQuery(".newsletter-optin").html("Please check your email inbox to confirm the newsletter registration.");			      	

			    }
			});		
		}

		function disqus_config() {
		    this.callbacks.onNewComment = [function(comment) { 
		      var comment_id = comment.id;
		      var user_opted_for_newsletter_subscription = jQuery(".newsletter-optin input:checkbox:checked").length > 0;
		      if (user_opted_for_newsletter_subscription) {
		      	subscribe_to_newsletter(comment_id);			      	
		  	  }
		    }];
		}
    	var disqus_url ="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/";
	    var disqus_identifier = "364394 http://www.towleroad.com/?p=364394";
	    var disqus_title = "&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH";
    </script><!-- HEADER CODE START -->
<meta name="google-site-verification" content="aWVVHBSTDagAYi2h1c0bTxrpJO8OQ82AHU_iEUSByuE" />
<meta name="google-site-verification" content="p31FkTwhP2MO0Dy6yv6jB4qZGy0XFROHGJdeUMMMQgE" />
<!-- Pingdom Site Monitoring added by ReadyMadeWeb in August -->
<script>

var _prum = [['id', '55c15d41abe53dd432e0057c'],
             ['mark', 'firstbyte', (new Date()).getTime()]];
(function() {
    var s = document.getElementsByTagName('script')[0]
      , p = document.createElement('script');
    p.async = 'async';
    p.src = '//rum-static.pingdom.net/prum.min.js';
    s.parentNode.insertBefore(p, s);
})();
</script>

<!-- Start: GPT Async -->

<!-- Sovrn VET tag -->
<script src='//get.s-onetag.com/db709e9d-146a-46e7-a845-b71079bb8a68/tag.min.js' async defer></script>
<!-- Sovrn VET tag -->

<!-- Criteo ad de blocker -->
<script type="text/javascript" src="//static.criteo.net/js/ld/publishertag.js"></script>
<!-- Criteo ad de blocker -->

<!-- AdSense Page Level Ads -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4162187998603810",
    enable_page_level_ads: true
  });
</script>
<!-- AdSense Page Level Ads -->

<!-- Header Bidding Code Start -->
  <!-- Prebid Config Section START -->
  <script>
    var PREBID_TIMEOUT = 1200;

    var adUnits = [
      {
        code: 'ad-rec1',
        sizes: [300, 250],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333810}}
        ]
      },{
        code: 'ad-rec2',
        sizes: [300, 250],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333848}}
        ]
      },{
        code: 'ad-rec3',
        sizes: [[300, 250],[300, 600],[160, 600]],
        sizeMapping: [
          { minWidth : 767, sizes : [[300, 250],[160, 600],[300, 600]] }, //if device screen width is > 767, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 499364}}
             ,{"bidder": "sovrn","params": {"tagid": 333850}}
             ,{"bidder": "sovrn","params": {"tagid": 333854}}
        ]
    },{
        code: 'ad-rec4',
        sizes: [[300, 250],[300, 600],[160, 600]],
        sizeMapping: [
          { minWidth : 767, sizes : [[300, 250],[160, 600],[300, 600]] }, //if device screen width is > 767, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333870}}
             ,{"bidder": "sovrn","params": {"tagid": 333851}}
             ,{"bidder": "sovrn","params": {"tagid": 335709}}
        ]
    },{
        code: 'ad-leader1',
        sizes: [728, 90],
        sizeMapping: [
          { minWidth : 767, sizes : [728,90] }, //if device screen width is > 767, use these sizes
          { minWidth : 0, sizes : [320,50] } //if device screen width is < 767 && > 0, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333807}}
             ,{"bidder": "sovrn","params": {"tagid": 420896}} //320x50
        ]
    },{
        code: 'ad-leader2',
        sizes: [728, 90],
        sizeMapping: [
          { minWidth : 767, sizes : [728,90] }, //if device screen width is > 767, use these sizes
          { minWidth : 0, sizes : [320,50] } //if device screen width is < 767 && > 0, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 335712}}
             ,{"bidder": "sovrn","params": {"tagid": 420897}} //sovrn 320x50
        ]
    }];

    var pbjs = pbjs || {};
    pbjs.que = pbjs.que || [];

    pbjs.que.push(function() {
        pbjs.enableSendAllBids();
    });

pbjs.bidderSettings = {
   standard: {
      alwaysUseBid: false,
      adserverTargeting: [{
         key: "hb_bidder",
         val: function(bidResponse) {
            return bidResponse.bidderCode;
         }
      }, {
         key: "hb_adid",
         val: function(bidResponse) {
            return bidResponse.adId;
         }
      }, {
         key: "hb_pb",
         val: function(bidResponse) {
            return bidResponse.pbMg;
         }
      }, {
         key: "hb_size",
         val: function(bidResponse) {
            return bidResponse.size;
         }
      }]
   }
}
  </script>
  <!-- Prebid Config Section END -->

  <!-- Prebid Boilerplate Section START. No Need to Edit. -->
  <script type="text/javascript" src="//www.yourbow.com/pb/tlrdprebid.js" async></script>
  <script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    googletag.cmd.push(function() {
        googletag.pubads().disableInitialLoad();
    });

    pbjs.que.push(function() {
        pbjs.addAdUnits(adUnits);
        pbjs.requestBids({
            bidsBackHandler: sendAdserverRequest
        });
    });

    function sendAdserverRequest() {
        if (pbjs.adserverRequestSent) return;
        pbjs.adserverRequestSent = true;
        googletag.cmd.push(function() {
            pbjs.que.push(function() {
                pbjs.setTargetingForGPTAsync();
                googletag.pubads().refresh();
            });
        });
    }

    setTimeout(function() {
        sendAdserverRequest();
    }, PREBID_TIMEOUT);

  </script>
  <!-- Prebid Boilerplate Section END -->
<!-- Header Bidding Code END -->

<!-- DFP setup START -->
 <script type='text/javascript'>
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
 var gads = document.createElement("script");
 gads.async = true;
 gads.type = "text/javascript";
 var useSSL = "https:" == document.location.protocol;
 gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
 var node =document.getElementsByTagName("script")[0];
 node.parentNode.insertBefore(gads, node);
 })();
 </script>

<script>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</script>
<!-- HEADER CODE END -->


<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />
<link rel="pingback" href="http://www.towleroad.com/xmlrpc.php" />
<meta property="fb:pages" content="13794040506" />


<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "7584020" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7584020&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1699882000230257');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1699882000230257&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->


<script src="//load.sumome.com/" data-sumo-site-id="9ed9404ba9695df8b4b4aefc60ff8292dd425098853a4fcbf574bbd39845eec2" async="async"></script>

<meta name="pocket-site-verification" content="a63e5a37c49bc22a353dad335452bd" />



<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=270%2C270" />
		<style type="text/css" id="wp-custom-css">
			blockquote {
    font-family: Georgia, serif;
    font-size: 18px;
    font-style: italic;
    width: 400px;
    margin: .25em 0;
    padding: 0.45em 30px;
    line-height: 1.45;
    position: relative;
    color: #383838;
    background:#ececec;

}
 
blockquote:before {
    display: block;
    content: "\201C";
    font-size: 70px;
    position: absolute;
    left: 0px;
    top: -10px;
    color: #7a7a7a;
}
 
blockquote cite {
    color: #999999;
    font-size: 14px;
    display: block;
    margin-top: 5px;
}
  
blockquote cite:before {
    content: "\2014 \2009";
}		</style>
	</head>
<body class="post-template-default single single-post postid-364394 single-format-standard sidebar-content-sidebar" itemscope itemtype="https://schema.org/WebPage">	<div id='interstitial'>
		<script type='text/javascript'>
			googletag.cmd.push(function() { googletag.display('interstitial'); });
		</script>
	</div>
<div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="header-sharing"><a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="site"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a> <a href="http://www.twitter.com/share?url=http://www.towleroad.com/"><i class="icon-twitter"></i></a></div><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.towleroad.com/">Towleroad</a></p></div><nav class="nav-header" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-primary" class="menu genesis-nav-menu menu-header"><li id="menu-item-337715" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-337715"><a href="http://www.towleroad.com/tag/daily-resist/" itemprop="url"><span itemprop="name">Daily Resist</span></a></li>
<li id="menu-item-227804" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227804"><a href="http://www.towleroad.com/tag/politics/" itemprop="url"><span itemprop="name">POLITICS</span></a></li>
<li id="menu-item-227806" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227806"><a href="http://www.towleroad.com/tag/travel/" itemprop="url"><span itemprop="name">Travel</span></a></li>
<li id="menu-item-227809" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227809"><a href="http://www.towleroad.com/tag/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
<li id="menu-item-227807" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227807"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url"><span itemprop="name">Theatre</span></a></li>
<li id="menu-item-227721" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227721"><a href="http://www.towleroad.com/tag/film/" itemprop="url"><span itemprop="name">Film</span></a></li>
<li id="menu-item-227808" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227808"><a href="http://www.towleroad.com/tag/television/" itemprop="url"><span itemprop="name">TV</span></a></li>
<li id="menu-item-270521" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-270521"><a href="http://www.towleroad.com/tag/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li id="menu-item-227812" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227812"><a href="http://www.towleroad.com/tag/nature/" itemprop="url"><span itemprop="name">Nature</span></a></li>
<li class="menu-item search"><i class="icon-search"></i><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.towleroad.com/" role="search"><meta itemprop="target" content="http://www.towleroad.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="" /><input type="submit" value=""  /></form></li></ul></nav><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-secondary" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-303865" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-303865"><a href="http://www.towleroad.com/tag/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
<li id="menu-item-276395" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-276395"><a href="http://www.towleroad.com/tag/men/" itemprop="url"><span itemprop="name">Men</span></a></li>
<li id="menu-item-227801" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227801"><a href="http://www.towleroad.com/tag/gay-marriage/" itemprop="url"><span itemprop="name">Marriage Equality</span></a></li>
<li id="menu-item-275223" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-275223"><a href="http://www.towleroad.com/tag/space/" itemprop="url"><span itemprop="name">Space</span></a></li>
<li id="menu-item-227820" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227820"><a href="http://www.towleroad.com/tag/transgender/" itemprop="url"><span itemprop="name">Trans Rights</span></a></li>
<li id="menu-item-227817" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227817"><a href="http://www.towleroad.com/tag/books/" itemprop="url"><span itemprop="name">Books</span></a></li>
<li id="menu-item-241504" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-241504"><a href="http://www.towleroad.com/tag/science/" itemprop="url"><span itemprop="name">Science</span></a></li>
<li id="menu-item-227819" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227819"><a href="http://www.towleroad.com/tag/gay-iconography/" itemprop="url"><span itemprop="name">Gay Iconography</span></a></li>
<li id="menu-item-227863" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227863"><a href="http://www.towleroad.com/tag/towleread/" itemprop="url"><span itemprop="name">TowleREAD</span></a></li>
</ul></nav><p class="breaking-news"><span class="red">BREAKING:</span> <a href="http://www.towleroad.com/2018/02/karen-mcdougal/">New Report Details Playboy Model Karen McDougal&#8217;s Affair with Trump and Efforts to Cover It Up</a></p></div></header><div class="header-leaderboard tr-widget-area"><div class="wrap"><section id="text-3" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader1-->
<div class='responsive-ad'>
<div id='ad-leader1' style="margin-bottom:10px">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader1'); });
</script>
</div>
</div></div>
		</div></section>
</div></div><div class="site-inner"><div class="wrap"><div class="content-sidebar-wrap"><main class="content"><article class="post-364394 post type-post status-publish format-standard has-post-thumbnail tag-casey-spooner tag-entertainment tag-fischerspooner tag-music tag-music-video entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</h1>
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364386" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?w=600 600w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=300%2C170 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]</span></a></div><div class="next"><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/" class="arrow icon-arrow-right"><span>Next</span></a><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/" class="hover"><span class="label">Next Story</span><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364391" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?w=600 600w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=300%2C166 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT</span></a></div></div></div><div class="entry-meta"><p class="byline">by <a href="http://www.towleroad.com/author/andy-towle/"> Andy Towle</a><br />February 16, 2018 | 11:43am</p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">27</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/&text=&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="364394 http://www.towleroad.com/?p=364394">Comments</span></a></div></div></header><div class="entry-content" itemprop="text"><p><img class="alignnone size-full wp-image-364395" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=740%2C429" alt="" width="740" height="429" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?w=1376 1376w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=300%2C174 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=768%2C445 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=1024%2C594 1024w" sizes="(max-width: 740px) 100vw, 740px" data-recalc-dims="1" /></p>
<p>Fischerspooner today released the video for &#8220;Butterscotch Goddam&#8221;, the follow-up to<a href="http://www.towleroad.com/2018/01/fischerspooner-hot-new-video/" target="_blank" rel="noopener"> its sexual deep dive &#8220;Top Brazil&#8221; which took viewers into the depths of a sex club</a>. Both come from the group&#8217;s new LP <em>Sir, </em>released today.</p>
<p>&#8220;Butterscotch&#8221; is &#8220;about a tumultuous love affair,&#8221;<a href="http://www.nme.com/news/music/fischerspooner-share-new-butterscotch-goddam-video-2243532" target="_blank" rel="noopener"> its director Carlo Van de Roer told NME</a>.</p>
<p>Fischerspooner&#8217;s Casey Spooner took it a bit further: “This album is a document of a turbulent, wild transformation full of love, loss, lust and redemption. This album is a queer treatise against political conservatism and oppression. This album saved my life. Some days it was all I had.&#8221;</p>
<p>Watch &#8220;Butterscotch Goddam&#8221;:</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/uhU_aFuS_Bs?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<div class="pubexchange_module" id="pubexchange_below_content_1" data-pubexchange-module-id="1851"></div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"
    dc:identifier="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"
    dc:title="&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH"
    trackback:ping="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/trackback/" />
</rdf:RDF>-->
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364386" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?w=600 600w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=300%2C170 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]</span></a></div><div class="next"><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/" class="arrow icon-arrow-right"><span>Next</span></a><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/" class="hover"><span class="label">Next Story</span><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364391" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?w=600 600w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=300%2C166 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT</span></a></div></div></div><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">27</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/&text=&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">27</span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="364394 http://www.towleroad.com/?p=364394">Comments</span></a> <span class="st_email_hcount" st_url="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" displayText="Email"></span></div></div><footer class="entry-footer"><p>Posted February 16, 2018 at 11:43am ETC by <a href="http://www.towleroad.com/author/andy-towle/">Andy Towle</a><br />in <a href="http://www.towleroad.com/tag/casey-spooner/">Casey Spooner</a>, <a href="http://www.towleroad.com/tag/entertainment/">Entertainment</a>, <a href="http://www.towleroad.com/tag/fischerspooner/">Fischerspooner</a>, <a href="http://www.towleroad.com/tag/music/">music</a>, <a href="http://www.towleroad.com/tag/music-video/">music video</a></p><div class="archive-post-info tr-widget-area"><section id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec1-->
<div class='responsive-ad'>
<div id='ad-rec1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec1'); });
</script>
</div>
</div>
</div>
		</div></section>
</div></footer></article><div class="before-comments tr-widget-area"><section id="text-30" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><span data-sumome-listbuilder-embed-id="72378c5e8c42f98f626f7c8ec68df01394029895dae00415eb0caf21cf35af7f"></span>

</br></br><iframe id="widgetPreview" style="width: 100%; height:574px;background-color: transparent;" src="https://widget.icopyright.net/widgets/-Kf1VHiaUe9KeOHNbprO#-Kf1VHiaUe9KeOHNbprO" frameborder="0"></iframe></div>
		</div></section>
</div>
<div id="disqus_thread">
    </div>

</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="be-social-widget-3" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com/tlrd"><i class="icon-instagram"></i></a></p></div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec3-->
<div class='responsive-ad'>
<div id='ad-rec3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec3'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec4-->
<div class='responsive-ad'>
<div id='ad-rec4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec4'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><h4 class="widget-title widgettitle">Like Towleroad</h4>
<div class="textwidget custom-html-widget"><div class="fb-page" data-href="https://www.facebook.com/towleroad.page/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="true"><blockquote cite="https://www.facebook.com/towleroad.page/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/towleroad.page/">Towleroad</a></blockquote></div></div></div></section>
<section id="text-47" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec5-->
<div class='responsive-ad'>
<div id='ad-rec5'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec5'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="be-video-widget-2" class="widget be-video-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Video</h4>
<div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/janelle-monae/"><img width="241" height="300" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?fit=241%2C300" class="block wp-image-364399" alt="Jorik Hendrickx" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?w=1276 1276w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=241%2C300 241w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=768%2C956 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=823%2C1024 823w" sizes="(max-width: 241px) 100vw, 241px" /></a><a class="play" href="http://www.towleroad.com/2018/02/janelle-monae/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/02/janelle-monae/">Janelle Monae, Rick Gates, Rob Porter, James Comey, Call Me By Your Name, Justin Theroux: HOT LINKS</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/janelle-monae/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364350"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">22</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/janelle-monae/&text=Janelle Monae, Rick Gates, Rob Porter, James Comey, Call Me By Your Name, Justin Theroux: HOT LINKS" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364350"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/janelle-monae/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364350"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">22</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/mueller-indictments-2/"><img width="300" height="186" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?fit=300%2C186" class="block wp-image-346799" alt="Robert Mueller" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?w=1370 1370w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=300%2C186 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=768%2C475 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=1024%2C634 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/02/mueller-indictments-2/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/02/mueller-indictments-2/">Robert Mueller Indicts 13 Russian Nationals for U.S. Election Meddling</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/mueller-indictments-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364412"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">104</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/mueller-indictments-2/&text=Robert Mueller Indicts 13 Russian Nationals for U.S. Election Meddling" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364412"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/mueller-indictments-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364412"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">104</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/"><img width="300" height="166" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?fit=300%2C166" class="block wp-image-364391" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?w=600 600w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=300%2C166 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84 150w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364389"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">51</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/&text=&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364389"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364389"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">51</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="300" height="174" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?fit=300%2C174" class="block wp-image-364395" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?w=1376 1376w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=300%2C174 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=768%2C445 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=1024%2C594 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">27</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/&text=&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364394"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">27</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/"><img width="300" height="170" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?fit=300%2C170" class="block wp-image-364386" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?w=600 600w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=300%2C170 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84 150w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/">It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364370"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">16</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/&text=It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364370"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364370"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">16</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/mitt-romney-senate/"><img width="300" height="143" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?fit=300%2C143" class="block wp-image-364364" alt="Mitt Romney" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?resize=300%2C143 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?resize=768%2C366 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?resize=1024%2C488 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/02/mitt-romney-senate/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/02/mitt-romney-senate/">Mitt Romney Announces Run for U.S. Senate in Utah</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/mitt-romney-senate/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="364362"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">49</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/mitt-romney-senate/&text=Mitt Romney Announces Run for U.S. Senate in Utah" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="364362"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/mitt-romney-senate/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="364362"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">49</span></a></div></div></div></section>
<section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec2-->
<div class='responsive-ad'>
<div id='ad-rec2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec2'); });
</script>
</div>
</div></div>
		</div></section>
<section id="be-eye-candy-2" class="widget be-eye-candy"><div class="widget-wrap"><h4 class="widget-title widgettitle">Hunk of the Day</h4>
<div class="eye-candy-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/boxers-or-briefs-2/"><img width="300" height="189" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?fit=300%2C189" class="block wp-image-363721" alt="guys in underwear" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?resize=300%2C189 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?resize=768%2C484 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?resize=1024%2C646 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a></p><p><a href="http://www.towleroad.com/2018/02/boxers-or-briefs-2/">Underwear Expert Daniel Miller Previews What Guys are Packing in Boxers or Briefs: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/boxers-or-briefs-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="363720"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">50</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/boxers-or-briefs-2/&text=Underwear Expert Daniel Miller Previews What Guys are Packing in Boxers or Briefs: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="363720"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/boxers-or-briefs-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="363720"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">50</span></a></div></div></div></section>
<section id="be-columns-widget-2" class="widget be-columns-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Columns</h4>
<ul><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/">It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]</a></li><li><a href="http://www.towleroad.com/tag/new-music/" class="column">New Music</a> <a href="http://www.towleroad.com/2018/02/new-music-14/">New Music: Erasure, Francis and the Lights, Mount Eerie, Mark Kozelek</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/02/drag-race-recap-4/">&#8216;Drag Race All Stars&#8217; Woo &#8216;The Bitchelor&#8217; and Get a SHOCKING Elimination [RECAP and Ranking]</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/02/drag-race-recap-3/">Tops and Bottoms: &#8216;All Stars&#8217; Do VH1 Divas On &#8216;Drag Race&#8217; [RECAP and Ranking]</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/02/terrence-mcnally-fire-and-air/">Terrence McNally’s ‘Fire and Air’ Presents a Dizzying History of Modern Ballet: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/02/judith-light-3/">Judith Light Was the Best Part of Last Night&#8217;s &#8216;American Crime Story&#8217; [RECAP]</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/01/drag-race-all-stars-premiere-recap/">Tops And Bottoms: Nice Girls Finish First On &#8216;RuPaul&#8217;s Drag Race All Stars&#8217; [PREMIERE RECAP]</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/01/versace-recap-2/">&#8216;Versace: ACS&#8217; Continues To Weave A Designer Tale of Men and Murder [RECAP]</a></li><li><a href="http://www.towleroad.com/tag/new-music/" class="column">New Music</a> <a href="http://www.towleroad.com/2018/01/new-music-13/">NEW MUSIC: Johnny Marr and Maxine Peake, First Aid Kit, The Tallest Man On Earth, CupcakKe</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/01/versace-recap/">The Beautiful, Bloody World of &#8216;The Assassination of Gianni Versace: ACS&#8217; &#8211; Premiere RECAP</a></li></ul></div></section>
</aside></div><aside class="sidebar sidebar-secondary widget-area" role="complementary" aria-label="Secondary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-50" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
<section id="be-latest-news-2" class="widget be-latest-news"><div class="widget-wrap"><h4 class="widget-title widgettitle">Latest Posts</h4>
<ul><li><a href="http://www.towleroad.com/2018/02/janelle-monae/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364399" alt="Jorik Hendrickx" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/janelle-monae/">Janelle Monae, Rick Gates, Rob Porter, James Comey, Call Me By Your Name, Justin Theroux: HOT LINKS</a><span class="post-time">3 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/mueller-indictments-2/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-346799" alt="Robert Mueller" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/mueller-indictments-2/">Robert Mueller Indicts 13 Russian Nationals for U.S. Election Meddling</a><span class="post-time">4 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/fbi-tip/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/06/wray.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-348149" alt="Christopher Wray" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/06/wray.jpeg?w=732 732w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/06/wray.jpeg?resize=300%2C168 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/06/wray.jpeg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/fbi-tip/">In Shock Admission, FBI Says it Received Tip About Florida School Shooter&#8217;s Plans, Failed to Pursue</a><span class="post-time">4 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364391" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?w=600 600w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=300%2C166 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT</a><span class="post-time">4 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364386" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?w=600 600w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=300%2C170 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/tumblr_p486reDfO81s9s3nto1_1280-1.png?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/">It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]</a><span class="post-time">6 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/viral-valentine-video/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/valentine.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364381" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/valentine.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/valentine.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/valentine.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/viral-valentine-video/">Valentine Video of Two South African Schoolboys Kissing Goes Viral</a><span class="post-time">6 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/jeffrey-tambor-blasts-amazon-jill-soloway/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-323151" alt="Trans[parent" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/jeffrey-tambor-blasts-amazon-jill-soloway/">Jeffrey Tambor Blasts Amazon and Jill Soloway After Official Exit from &#8216;Transparent&#8217;</a><span class="post-time">7 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/mitt-romney-senate/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364364" alt="Mitt Romney" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/romney.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/mitt-romney-senate/">Mitt Romney Announces Run for U.S. Senate in Utah</a><span class="post-time">7 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/karen-mcdougal/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364359" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/karen-mcdougal/">New Report Details Playboy Model Karen McDougal&#8217;s Affair with Trump and Efforts to Cover It Up</a><span class="post-time">8 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/adam-rippon-skating-music/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/ar.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364390" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/ar.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/ar.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/ar.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/adam-rippon-skating-music/">Adam Rippon Reveals the &#8216;Sassy, Flirty&#8217; Music Which Drives Figure Skaters Wild: WATCH</a><span class="post-time">8 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/prep-insurance-denials/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/12/32514377531_3583dbc34b_z.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-359794" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/12/32514377531_3583dbc34b_z.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/12/32514377531_3583dbc34b_z.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/12/32514377531_3583dbc34b_z.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/prep-insurance-denials/">New York To Investigate Reports of Gay Men Denied Insurance For Taking PrEP</a><span class="post-time">8 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/epa-chief-scott-pruitt-heckled/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/02/pruitt.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-339356" alt="Scott PRuitt" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/02/pruitt.jpeg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/02/pruitt.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/02/pruitt.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/epa-chief-scott-pruitt-heckled/">EPA Chief Scott Pruitt Says He Needs to Fly First Class Because He Gets Heckled Flying Coach</a><span class="post-time">9 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/kimmel-guns/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/2guns_kimmel.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364340" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/2guns_kimmel.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/2guns_kimmel.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/2guns_kimmel.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/kimmel-guns/">Choked Up Jimmy Kimmel Rages at Trump&#8217;s Gun Inaction: &#8216;You are Obviously Mentally Ill&#8217; &#8211; WATCH</a><span class="post-time">9 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/florida-school-shooting-victims/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/victims.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364336" alt="florida school shooting victims" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/victims.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/victims.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/victims.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/florida-school-shooting-victims/">Anderson Cooper Honors the 17 Florida School Shooting Victims: WATCH</a><span class="post-time">10 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/kenworthy-thumb/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/thumb_kenworthy.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364333" alt="kenworthy thumb" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/thumb_kenworthy.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/thumb_kenworthy.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/thumb_kenworthy.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/kenworthy-thumb/">Gus Kenworthy Takes Jab at Mike Pence with Broken Thumb Announcement</a><span class="post-time">10 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/alzheimers/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/PET_Alzheimer.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-364325" alt="alzheimers" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/PET_Alzheimer.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/PET_Alzheimer.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/PET_Alzheimer.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/alzheimers/">Alzheimer&#8217;s Disease Completely Reversed in Mice by Removing One Enzyme</a><span class="post-time">10 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/gays-against-guns-2/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/06/gag.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-318620" alt="Gays Against Guns GAG" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/06/gag.jpeg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/06/gag.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/06/gag.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/gays-against-guns-2/">&#8216;Gays Against Guns&#8217; to Hold NYC Rally Tonight in Response to Florida HS Shooting</a><span class="post-time">24 hours ago</span></li><li><a href="http://www.towleroad.com/2018/02/gay-panic-2/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2015/10/cuomo.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-287713" alt="Andrew Cuomo" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2015/10/cuomo.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2015/10/cuomo.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2015/10/cuomo.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/02/gay-panic-2/">New York Governor Andrew Cuomo Moves to Ban &#8216;Gay Panic&#8217; and &#8216;Trans Panic&#8217; Defenses</a><span class="post-time">24 hours ago</span></li></ul></div></section>
</aside></div></div><div class="related-post-carousel"><div class="wrap"><h4>You Might Also Like</h4><ul><li><a href="http://www.towleroad.com/2018/02/janelle-monae/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364399" alt="Jorik Hendrickx" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/hendrickx.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">POLITICS</span> <a href="http://www.towleroad.com/2018/02/janelle-monae/" class="entry-title">Janelle Monae, Rick Gates, Rob Porter, James Comey, Call Me By Your Name, Justin Theroux: HOT LINKS</a></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">music</span> <a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/" class="entry-title">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></li><li><a href="http://www.towleroad.com/2018/02/jeffrey-tambor-blasts-amazon-jill-soloway/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-323151" alt="Trans[parent" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/2_transparent.jpeg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Entertainment</span> <a href="http://www.towleroad.com/2018/02/jeffrey-tambor-blasts-amazon-jill-soloway/" class="entry-title">Jeffrey Tambor Blasts Amazon and Jill Soloway After Official Exit from &#8216;Transparent&#8217;</a></li><li><a href="http://www.towleroad.com/2018/02/new-music-14/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2009/02/erasure_3.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-185258" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2009/02/erasure_3.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2009/02/erasure_3.jpg?resize=144%2C144 144w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2009/02/erasure_3.jpg?zoom=2&amp;resize=195%2C195 390w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">music</span> <a href="http://www.towleroad.com/2018/02/new-music-14/" class="entry-title">New Music: Erasure, Francis and the Lights, Mount Eerie, Mark Kozelek</a></li><li><a href="http://www.towleroad.com/2018/02/gay-bathhouse-2/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/madden.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364313" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/madden.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/madden.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/madden.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">POLITICS</span> <a href="http://www.towleroad.com/2018/02/gay-bathhouse-2/" class="entry-title">Adam Schiff, Bichon Frise, Stormy Daniels, Quinn Norton, Gay Bathhouse, Oprah, Richard Madden: HOT LINKS</a></li><li><a href="http://www.towleroad.com/2018/02/will-grace-madonna/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/mccormack_messing.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364292" alt="eric mccormack debra messing" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/mccormack_messing.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/mccormack_messing.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/mccormack_messing.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Entertainment</span> <a href="http://www.towleroad.com/2018/02/will-grace-madonna/" class="entry-title">&#8216;Will&#8217; and &#8216;Grace&#8217; Give Graham Norton Hilarious Rundown on Return to Air, Madonna Memories: WATCH</a></li></ul></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="footer-popularity"><div class="wrap"><div class="offset"><h4>Latest Posts</h4><ul class="postfeed"><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>PLEA DEAL? Former Trump campaign adviser Rick Gates is nearing plea deal with Robert Mueller: &#8216;Gates has already spoken to Mueller&#8217;s team about his case and has been in plea negotiations for about a month. He&#8217;s had what criminal law&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/mueller-indictments-2/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-346799 wp-post-image" alt="Robert Mueller" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/05/mueller.jpeg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/mueller-indictments-2/">Robert Mueller Indicts 13 Russian Nationals for U.S. Election Meddling</a></h3><p>Special counsel Robert Mueller has indicted 13 Russian nationals and three Russian entities in the investigation into interference in the 2016 election. The NY Times reports: The indictment charges that the foreigners falsely posed as American citize&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/mueller-indictments-2/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>The FBI has released a statement admitting that it failed to follow up on a tip to its Public Access Line about Florida shooter Nikolas Cruz, who slaughtered 17 innocent people at a high school in Parkland, Florida on Wednesday. The FBI said &#8220;a&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364391 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/X_Ru-Paul_Stage_Main-4-Simplified_CROP_3000px_LOGO.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT</a></h3><p>Fans of RuPaul&#8217;s Drag Race, which is pretty much everyone who has ever seen an episode, have a lot to celebrate today. Not only will the beloved reality competition be returning for a 10th season on March 22 on VH1, but there will be so much mo&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>Fischerspooner today released the video for &#8220;Butterscotch Goddam&#8221;, the follow-up to its sexual deep dive &#8220;Top Brazil&#8221; which took viewers into the depths of a sex club. Both come from the group&#8217;s new LP Sir, released toda&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>With all the shady mirror messages and getting “cracked” going on, you’d think all these queens would be heading toward seven years bad luck. That certainly seems to be the case for a few of the girls coming out of this RuPaul’s Drag Race All Stars e&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>A video shared by queer South African TV and radio host Bujy Bikwa on Valentine&#8217;s Day has gone viral. It&#8217;s unclear exactly where the video took place, but that&#8217;s less important than its sentiment. The video, presumably filmed on Val&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>Actor Jeffrey Tambor released a statement on Thursday after he was officially ousted from the Amazon hit TV show Transparent following sexual harassment accusations by a former assistant and by one of the show’s guest stars, Trace Lysette. Tambor bla&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364395 wp-post-image" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/02/fischerspooner.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></h3><p>Former Massachusetts Governor and failed Republican presidential candidate Mitt Romney has announced his run for U.S. Senator in Utah. Says Romney in the ad: &#8220;I have decided to run for United States Senate because I believe I can help bring Uta&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/02/karen-mcdougal/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-364359 wp-post-image" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/02/Karen_McDougal_2011.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/02/karen-mcdougal/">New Report Details Playboy Model Karen McDougal&#8217;s Affair with Trump and Efforts to Cover It Up</a></h3><p>Donald Trump had an affair with Playboy Playmate Karen McDougal that started in 2006 shortly after the birth of his son Barron, according to a new report in The New Yorker, which obtained a handwritten document by the model detailing the affair: The&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/02/karen-mcdougal/">Read</a></p></li></ul></div><div class="above-footer tr-widget-area"><div class="wrap"><section id="text-10" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader2 -->
<div id='ad-leader2' style="text-align:center;">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader2'); });
</script>
</div></div>
		</div></section>
</div></div><aside id="dpp_widget-2" class="widget box desktop widget_dpp_widget"><h3 class="widget-title">Most Commented</h3><span class="dpp_render_area" id="dpp_render_area-2"></span></aside><div class="box hot-reads"><h4>Hot Reads</h4><div class="menu-popular-posts-container"><ul id="menu-popular-posts" class="menu"><li id="menu-item-351483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351483"><a href="http://www.towleroad.com/2017/07/trump-family-2/" itemprop="url">America’s Top Crime Family: The Trumps</a></li>
<li id="menu-item-349563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-349563"><a href="http://www.towleroad.com/2017/06/anti-gay-baker-case/" itemprop="url">High Stakes for LGBTQ Equality in the Anti-Gay Baker Case at the Supreme Court</a></li>
<li id="menu-item-344169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344169"><a href="http://www.towleroad.com/2017/04/state-department-chechnya/" itemprop="url">State Department ‘Deeply Disturbed’ by Reports of Detention, Torture, and Murder of Gay Men in Chechnya</a></li>
<li id="menu-item-344168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344168"><a href="http://www.towleroad.com/2017/04/kenneth-adkins-2/" itemprop="url">Anti-Gay Pastor Who Said Orlando Victims ‘Got What They Deserved’ Guilty of Sexually Molesting Boy and Girl</a></li>
<li id="menu-item-339222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-339222"><a href="http://www.towleroad.com/2017/01/neil-gorsuch/" itemprop="url">Neil Gorsuch is Trump’s Terrible, No Good Nominee for the Supreme Court: An Analysis</a></li>
<li id="menu-item-336834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336834"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/" itemprop="url">2017 Resolutions All Gay Men Should Consider</a></li>
<li id="menu-item-323766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323766"><a href="http://www.towleroad.com/2016/08/eric-andre-bisexual/" itemprop="url">Comedian Eric Andre: The Gay Interview</a></li>
</ul></div></div></div></div><div class="footer-today"><div class="wrap"><div class="today-header"><h4>Today's News</h4><div class="jump-to-day">Jump To Day: <a href="#">Choose <i class="icon-arrow-down"></i></a></div></div><ul class="one-fourth first"><li><a href="http://www.towleroad.com/2018/02/janelle-monae/">Janelle Monae, Rick Gates, Rob Porter, James Comey, Call Me By Your Name, Justin Theroux: HOT LINKS</a></li><li><a href="http://www.towleroad.com/2018/02/mueller-indictments-2/">Robert Mueller Indicts 13 Russian Nationals for U.S. Election Meddling</a></li><li><a href="http://www.towleroad.com/2018/02/fbi-tip/">In Shock Admission, FBI Says it Received Tip About Florida School Shooter&#8217;s Plans, Failed to Pursue</a></li><li><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-season-10/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Will Feature 2 Draglicious Hours Every Week: ANNOUNCEMENT</a></li><li><a href="http://www.towleroad.com/2018/02/fischerspooner-sexy-video/">&#8216;Butterscotch Goddam&#8217; is Fischerspooner&#8217;s Fresh, Sticky, Sexy Love Affair: WATCH</a></li><li><a href="http://www.towleroad.com/2018/02/rupauls-drag-race-recap-2/">It&#8217;s a &#8216;Snatch Game&#8217; of Thrones on &#8216;RuPaul&#8217;s Drag Race All Stars 3&#8217; [RECAP and RANKINGS]</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2018/02/viral-valentine-video/">Valentine Video of Two South African Schoolboys Kissing Goes Viral</a></li><li><a href="http://www.towleroad.com/2018/02/jeffrey-tambor-blasts-amazon-jill-soloway/">Jeffrey Tambor Blasts Amazon and Jill Soloway After Official Exit from &#8216;Transparent&#8217;</a></li><li><a href="http://www.towleroad.com/2018/02/mitt-romney-senate/">Mitt Romney Announces Run for U.S. Senate in Utah</a></li><li><a href="http://www.towleroad.com/2018/02/karen-mcdougal/">New Report Details Playboy Model Karen McDougal&#8217;s Affair with Trump and Efforts to Cover It Up</a></li><li><a href="http://www.towleroad.com/2018/02/adam-rippon-skating-music/">Adam Rippon Reveals the &#8216;Sassy, Flirty&#8217; Music Which Drives Figure Skaters Wild: WATCH</a></li><li><a href="http://www.towleroad.com/2018/02/prep-insurance-denials/">New York To Investigate Reports of Gay Men Denied Insurance For Taking PrEP</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2018/02/epa-chief-scott-pruitt-heckled/">EPA Chief Scott Pruitt Says He Needs to Fly First Class Because He Gets Heckled Flying Coach</a></li><li><a href="http://www.towleroad.com/2018/02/kimmel-guns/">Choked Up Jimmy Kimmel Rages at Trump&#8217;s Gun Inaction: &#8216;You are Obviously Mentally Ill&#8217; &#8211; WATCH</a></li><li><a href="http://www.towleroad.com/2018/02/florida-school-shooting-victims/">Anderson Cooper Honors the 17 Florida School Shooting Victims: WATCH</a></li><li><a href="http://www.towleroad.com/2018/02/kenworthy-thumb/">Gus Kenworthy Takes Jab at Mike Pence with Broken Thumb Announcement</a></li><li><a href="http://www.towleroad.com/2018/02/alzheimers/">Alzheimer&#8217;s Disease Completely Reversed in Mice by Removing One Enzyme</a></li><li><a href="http://www.towleroad.com/2018/02/gays-against-guns-2/">&#8216;Gays Against Guns&#8217; to Hold NYC Rally Tonight in Response to Florida HS Shooting</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2018/02/gay-panic-2/">New York Governor Andrew Cuomo Moves to Ban &#8216;Gay Panic&#8217; and &#8216;Trans Panic&#8217; Defenses</a></li><li><a href="http://www.towleroad.com/2018/02/new-music-14/">New Music: Erasure, Francis and the Lights, Mount Eerie, Mark Kozelek</a></li><li><a href="http://www.towleroad.com/2018/02/gay-bathhouse-2/">Adam Schiff, Bichon Frise, Stormy Daniels, Quinn Norton, Gay Bathhouse, Oprah, Richard Madden: HOT LINKS</a></li><li><a href="http://www.towleroad.com/2018/02/gay-vacation/">If a Flawless Gay Vacation of Beach, Boys, Bars, and Brunch is Your Wish, Here&#8217;s the Perfect Destination</a></li><li><a href="http://www.towleroad.com/2018/02/uber-driver/">Uber Driver Appeals to Public to Find Drunk Homophobe Who Smashed His Phone: WATCH</a></li></ul></div></div><aside id="text-12" class="widget box desktop widget_text">			<div class="textwidget">
</div>
		</aside><div class="lower-footer"><div class="wrap"><div class="one-half first"><section id="be-andy-banner-2" class="widget be-andy-banner"><div class="widget-wrap"><h4 class="widget-title widgettitle">Share This</h4>
<p class="featured-image"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/"><img width="477" height="409" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/12/2017RESOLUTIONSImageLowerRes.jpg?resize=477%2C409" class="block wp-image-336420" alt="" /></a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/01/2017-gay-resolutions/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">3.3k</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/01/2017-gay-resolutions/&text=2017 Resolutions All Gay Men Should Consider" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/01/2017-gay-resolutions/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">3.3k</span></a></div></div></section>
</div><div class="one-half"><div class="one-half first"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Read</h4>
<div class="menu-footer-read-container"><ul id="menu-footer-read" class="menu"><li id="menu-item-219178" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219178"><a href="http://www.towleroad.com/tag/politics/" itemprop="url">Politics</a></li>
<li id="menu-item-219476" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219476"><a href="http://www.towleroad.com/tag/travel/" itemprop="url">Travel</a></li>
<li id="menu-item-219478" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219478"><a href="http://www.towleroad.com/tag/film/" itemprop="url">Film</a></li>
<li id="menu-item-219477" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219477"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url">Theatre</a></li>
<li id="menu-item-219479" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219479"><a href="http://www.towleroad.com/tag/television-2/" itemprop="url">Television</a></li>
<li id="menu-item-219480" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219480"><a href="http://www.towleroad.com/tag/science-2/" itemprop="url">Science</a></li>
<li id="menu-item-219481" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219481"><a href="http://www.towleroad.com/tag/law-gay-lgbt/" itemprop="url">Law &#8211; LGBT Rights</a></li>
<li id="menu-item-219183" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219183"><a href="#" itemprop="url">Columns</a></li>
<li id="menu-item-219184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219184"><a href="#" itemprop="url">Specials</a></li>
</ul></div></div></section>
</div><div class="one-half"><section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">About</h4>
<div class="menu-footer-about-container"><ul id="menu-footer-about" class="menu"><li id="menu-item-219388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="http://www.towleroad.com/contact/" itemprop="url">Advertise</a></li>
<li id="menu-item-219196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="http://www.towleroad.com/contact/" itemprop="url">Contact Us</a></li>
<li id="menu-item-219193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="http://www.towleroad.com/about-us/" itemprop="url">About Towleroad</a></li>
<li id="menu-item-219233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219233"><a href="http://www.towleroad.com/authors/" itemprop="url">Contributors</a></li>
<li id="menu-item-219443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="http://www.towleroad.com/towleroad-social-media/" itemprop="url">Towleroad on Social Media</a></li>
<li id="menu-item-219194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="http://www.towleroad.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
<section id="be-social-widget-2" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com"><i class="icon-instagram"></i></a></p></div></section>
</div><p class="copyright">&copy; 2014 Towleroad. All Rights Reserved.</p></div></div></div></footer></div><script type="text/javascript">
 /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
 var disqus_shortname = 'towleroad'; // required: replace example with your blog short name
/* * * DON'T EDIT BELOW THIS LINE * * */
 (function () {
 var s = document.createElement('script'); s.async = true;
 s.type = 'text/javascript';
 s.src = '//' + disqus_shortname + '.disqus.com/count.js';
 (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
 }());
 </script>
<script type="text/javascript">var switchTo5x=true;</script>
<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">stLight.options({publisher: "25ce3796-0f6f-43b9-a36c-78c2238b9f95", doNotHash: true, doNotCopy: true, hashAddressBar: false});</script>	
	<script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><!-- Chartbeat Tag, part 1 --> 
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-283150-1']);
  _gaq.push(['_setDomainName', '.towleroad.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

<!-- Begin comScore Tag -->
<script>
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
</script>

<script>
  COMSCORE.beacon({
    c1:2,
    c2:7584020,
    c3:"",
    c4:"",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=7584020&c3=&c4=&c5=&c6=&c15=&cj=1" />
</noscript>

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"NCUJh1awVK000u", domain:"towleroad.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=NCUJh1awVK000u" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<!-- Quantcast Tag, part 1 --> 
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
   var elem = document.createElement('script');

   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);  
  })();
</script>

<!-- Facebook APP tag -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '1774199316148150',
      xfbml      : true,
      version    : 'v2.6'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- Facebook APP tag end -->


<!-- Quantcast Tag, part 2 -->
<script type="text/javascript">
_qevents.push( { 
qacct:"p-93b6WeVYdHXoc",
labels:"AskTell.Towleroad,Towleroad,TRFront"
} );
</script>
<noscript>
<div style="display: none;"><img src="//pixel.quantserve.com/pixel/p-93b6WeVYdHXoc.gif?labels=AskTell%20Towleroad%2CTowleroad" height="1" width="1" alt="Quantcast"/></div>
</noscript>

<script type="text/javascript">
var _sf_async_config={uid:551,domain:"towleroad.com",useCanonical:true};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script>

<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />

<script async="" defer="" src="//survey.g.doubleclick.net/async_survey?site=lcfgvapu5adkw"></script>

<script type="text/javascript" src="http://www.lijit.com/blog_wijits?json=0&amp;id=trakr&amp;uri=http%3A%2F%2Fwww.lijit.com%2Fusers%2Ftowleroad&amp;js=1"></script>

<script type="text/javascript" src="//s.skimresources.com/js/92217X1546135.skimlinks.js"></script>

<script>(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><link rel='stylesheet' id='ea-share-count-css'  href='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/css/share-count.css?ver=1.8.0' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201807'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/lib/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.fitvids.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.matchHeight-min.js?ver=0.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ea_theme_details = {"home_url":"http:\/\/www.towleroad.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/global.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.flexslider-min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.9.4","language":""},"disqusIdentifier":"364394 http:\/\/www.towleroad.com\/?p=364394","disqusShortname":"towleroad","disqusTitle":"\u2018Butterscotch Goddam\u2019 is Fischerspooner\u2019s Fresh, Sticky, Sexy Love Affair: WATCH","disqusUrl":"http:\/\/www.towleroad.com\/2018\/02\/fischerspooner-sexy-video\/","options":{"manualSync":"1"},"postId":"364394"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/_inc/build/shortcodes/js/instagram.min.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dpp_ajax = {"ajaxurl":"http:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-popular-posts/dpp.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/js/share-count.js?ver=1.8.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"towleroad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201807.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.6.1',blog:'93805103',post:'364394',tz:'-5',srv:'www.towleroad.com'} ]);
	_stq.push([ 'clickTrackerInit', '93805103', '364394' ]);
</script>
</body></html>
