<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb#">
<head >
<meta charset="UTF-8" />
<title>&#039;RuPaul&#039;s Drag Race&#039; Season 10 Contestants Review Famous Movie Drag Queens: WATCH - Towleroad</title>
<!-- This site is optimized with the Yoast SEO Premium plugin v5.9.4 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="Six RuPaul&#039;s Drag Race Season 10 contestants sat down with Vanity Fair to take a look at Hollywood&#039;s past movie drag queens."/>
<meta name="news_keywords" content="drag queens, entertainment, film, movies, rupaul's drag race, tv, gay, lgbt, queer" />
<meta name="original-source" content="http://www.towleroad.com/2018/03/movie-drag-queens/" />
<script src="/cdn-cgi/apps/head/A3bNKYP2epbsPGoBj9HE4gWaycc.js"></script><link rel="canonical" href="http://www.towleroad.com/2018/03/movie-drag-queens/" />
<link rel="publisher" href="https://plus.google.com/+Towleroad"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;RuPaul&#039;s Drag Race&#039; Season 10 Contestants Review Famous Movie Drag Queens: WATCH - Towleroad" />
<meta property="og:description" content="Six RuPaul&#039;s Drag Race Season 10 contestants sat down with Vanity Fair to take a look at Hollywood&#039;s past movie drag queens." />
<meta property="og:url" content="http://www.towleroad.com/2018/03/movie-drag-queens/" />
<meta property="og:site_name" content="Towleroad" />
<meta property="article:publisher" content="https://www.facebook.com/towleroad.page" />
<meta property="article:author" content="https://www.facebook.com/andytowle" />
<meta property="article:tag" content="drag queens" />
<meta property="article:tag" content="Entertainment" />
<meta property="article:tag" content="Film" />
<meta property="article:tag" content="movies" />
<meta property="article:tag" content="rupaul&#039;s drag race" />
<meta property="article:tag" content="tv" />
<meta property="article:published_time" content="2018-03-27T11:12:53-04:00" />
<meta property="fb:app_id" content="180651805330333" />
<meta property="og:image" content="http://www.towleroad.com/wp-content/uploads/2018/03/queens.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Six RuPaul&#039;s Drag Race Season 10 contestants sat down with Vanity Fair to take a look at Hollywood&#039;s past movie drag queens." />
<meta name="twitter:title" content="&#039;RuPaul&#039;s Drag Race&#039; Season 10 Contestants Review Famous Movie Drag Queens: WATCH - Towleroad" />
<meta name="twitter:site" content="@tlrd" />
<meta name="twitter:image" content="http://www.towleroad.com/wp-content/uploads/2018/03/queens.jpg" />
<meta name="twitter:creator" content="@andytowle" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"http:\/\/www.towleroad.com\/","name":"Towleroad","alternateName":"Towleroad Gay News","potentialAction":{"@type":"SearchAction","target":"http:\/\/www.towleroad.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"http:\/\/www.towleroad.com\/2018\/03\/movie-drag-queens\/","sameAs":["https:\/\/www.facebook.com\/towleroad.page","https:\/\/instagram.com\/tlrd\/","https:\/\/www.linkedin.com\/company\/towleroad","https:\/\/plus.google.com\/+Towleroad","https:\/\/www.youtube.com\/user\/TowleroadTV","https:\/\/www.pinterest.com\/towleroad\/","https:\/\/twitter.com\/tlrd"],"@id":"#organization","name":"Towleroad","logo":"http:\/\/towleroad.com\/wp-content\/uploads\/2015\/06\/600x600_T.jpg"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.towleroad.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Feed" href="http://www.towleroad.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Comments Feed" href="http://www.towleroad.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; &#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH Comments Feed" href="http://www.towleroad.com/2018/03/movie-drag-queens/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.towleroad.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.4"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='child-theme-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/style.css?ver=1498864291' type='text/css' media='all' />
<link rel='stylesheet' id='glaser-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/webfonts/webfonts.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='be-icons-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/icons/styles.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ea-jquery-ui-css'  href='//code.jquery.com/ui/1.10.4/themes/dot-luv/jquery-ui.min.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='ea-flexslider-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/flexslider/flexslider.css?ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='be-fonts-css'  href='http://fonts.googleapis.com/css?family=Noto+Sans%3A400%2C700&#038;ver=4.9.4' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.towleroad.com/wp-content/plugins/jetpack/css/jetpack.css?ver=5.6.1' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis/lib/js/html5shiv.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://www.towleroad.com/wp-json/' />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.towleroad.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.4" />
<link rel='shortlink' href='http://www.towleroad.com/?p=366902' />
<link rel="alternate" type="application/json+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2018%2F03%2Fmovie-drag-queens%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2018%2F03%2Fmovie-drag-queens%2F&#038;format=xml" />
<meta name='pubexchange:image' content='https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?fit=300%2C168'>
<meta name='pubexchange:title' content='&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH'>

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript">

    	jQuery(".newsletter-optin").click(function() {
			jQuery(this).find("input").click();
    	});

		function setCookie(cname, cvalue, exdays) {
		    var d = new Date();
		    d.setTime(d.getTime() + (exdays*24*60*60*1000));
		    var expires = "expires="+d.toUTCString();
		    document.cookie = cname + "=" + cvalue + "; " + expires;
		}

		function subscribe_to_newsletter(comment_id) {

			jQuery.ajax({
			  type: "POST",
			  url: "http://staging.towleroad.com/disqus.php",
			  data: { comment_id: comment_id },
			beforeSend: function() {
				var loader = jQuery( "<img/>", {
				    src: "http://staging.towleroad.com/wp-admin/images/wpspin_light-2x.gif ", width: "32", height: "32",
				    "class": "loader-image"
				});		
				jQuery(".newsletter-optin").html(loader);
			},			  
			  success: function(data) {
			  		setCookie("newsletter-opted-in", "true", 365);
				jQuery(".newsletter-optin").html("Please check your email inbox to confirm the newsletter registration.");			      	

			    }
			});		
		}

		function disqus_config() {
		    this.callbacks.onNewComment = [function(comment) { 
		      var comment_id = comment.id;
		      var user_opted_for_newsletter_subscription = jQuery(".newsletter-optin input:checkbox:checked").length > 0;
		      if (user_opted_for_newsletter_subscription) {
		      	subscribe_to_newsletter(comment_id);			      	
		  	  }
		    }];
		}
    	var disqus_url ="http://www.towleroad.com/2018/03/movie-drag-queens/";
	    var disqus_identifier = "366902 http://www.towleroad.com/?p=366902";
	    var disqus_title = "&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH";
    </script><!-- HEADER CODE START -->
<meta name="google-site-verification" content="aWVVHBSTDagAYi2h1c0bTxrpJO8OQ82AHU_iEUSByuE" />
<meta name="google-site-verification" content="p31FkTwhP2MO0Dy6yv6jB4qZGy0XFROHGJdeUMMMQgE" />
<!-- Pingdom Site Monitoring added by ReadyMadeWeb in August -->
<script>

var _prum = [['id', '55c15d41abe53dd432e0057c'],
             ['mark', 'firstbyte', (new Date()).getTime()]];
(function() {
    var s = document.getElementsByTagName('script')[0]
      , p = document.createElement('script');
    p.async = 'async';
    p.src = '//rum-static.pingdom.net/prum.min.js';
    s.parentNode.insertBefore(p, s);
})();
</script>

<!-- Start: GPT Async -->

<!-- Sovrn VET tag -->
<script src='//get.s-onetag.com/db709e9d-146a-46e7-a845-b71079bb8a68/tag.min.js' async defer></script>
<!-- Sovrn VET tag -->

<!-- Criteo ad de blocker -->
<script type="text/javascript" src="//static.criteo.net/js/ld/publishertag.js"></script>
<!-- Criteo ad de blocker -->

<!-- AdSense Page Level Ads -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4162187998603810",
    enable_page_level_ads: true
  });
</script>
<!-- AdSense Page Level Ads -->

<!-- Header Bidding Code Start -->
  <!-- Prebid Config Section START -->
  <script>
    var PREBID_TIMEOUT = 1200;

    var adUnits = [
      {
        code: 'ad-rec1',
        sizes: [300, 250],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333810}}
        ]
      },{
        code: 'ad-rec2',
        sizes: [300, 250],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333848}}
        ]
      },{
        code: 'ad-rec3',
        sizes: [[300, 250],[300, 600],[160, 600]],
        sizeMapping: [
          { minWidth : 767, sizes : [[300, 250],[160, 600],[300, 600]] }, //if device screen width is > 767, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 499364}}
        //     ,{"bidder": "sovrn","params": {"tagid": 333850}}
             ,{"bidder": "sovrn","params": {"tagid": 333854}}
        ]
    },{
        code: 'ad-rec4',
        sizes: [[300, 250],[300, 600],[160, 600]],
        sizeMapping: [
          { minWidth : 767, sizes : [[300, 250],[160, 600],[300, 600]] }, //if device screen width is > 767, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333870}}
        //     ,{"bidder": "sovrn","params": {"tagid": 333851}}
             ,{"bidder": "sovrn","params": {"tagid": 335709}}
        ]
    },{
        code: 'ad-leader1',
        sizes: [728, 90],
        sizeMapping: [
          { minWidth : 767, sizes : [728,90] }, //if device screen width is > 767, use these sizes
          { minWidth : 0, sizes : [320,50] } //if device screen width is < 767 && > 0, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 333807}}
        //     ,{"bidder": "sovrn","params": {"tagid": 420896}} //320x50
        ]
    },{
        code: 'ad-leader2',
        sizes: [728, 90],
        sizeMapping: [
          { minWidth : 767, sizes : [728,90] }, //if device screen width is > 767, use these sizes
          { minWidth : 0, sizes : [320,50] } //if device screen width is < 767 && > 0, use these sizes
        ],
        bids: [
              {"bidder": "sovrn","params": {"tagid": 335712}}
         //    ,{"bidder": "sovrn","params": {"tagid": 420897}} //sovrn 320x50
        ]
    }];

    var pbjs = pbjs || {};
    pbjs.que = pbjs.que || [];

    pbjs.que.push(function() {
        pbjs.enableSendAllBids();
    });

pbjs.bidderSettings = {
   standard: {
      alwaysUseBid: false,
      adserverTargeting: [{
         key: "hb_bidder",
         val: function(bidResponse) {
            return bidResponse.bidderCode;
         }
      }, {
         key: "hb_adid",
         val: function(bidResponse) {
            return bidResponse.adId;
         }
      }, {
         key: "hb_pb",
         val: function(bidResponse) {
            return bidResponse.pbMg;
         }
      }, {
         key: "hb_size",
         val: function(bidResponse) {
            return bidResponse.size;
         }
      }]
   }
}
  </script>
  <!-- Prebid Config Section END -->

  <!-- Prebid Boilerplate Section START. No Need to Edit. -->
  <script type="text/javascript" src="//www.yourbow.com/pb/tlrdprebid.js" async></script>
  <script>
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    googletag.cmd.push(function() {
        googletag.pubads().disableInitialLoad();
    });

    pbjs.que.push(function() {
        pbjs.addAdUnits(adUnits);
        pbjs.requestBids({
            bidsBackHandler: sendAdserverRequest
        });
    });

    function sendAdserverRequest() {
        if (pbjs.adserverRequestSent) return;
        pbjs.adserverRequestSent = true;
        googletag.cmd.push(function() {
            pbjs.que.push(function() {
                pbjs.setTargetingForGPTAsync();
                googletag.pubads().refresh();
            });
        });
    }

    setTimeout(function() {
        sendAdserverRequest();
    }, PREBID_TIMEOUT);

  </script>
  <!-- Prebid Boilerplate Section END -->
<!-- Header Bidding Code END -->

<!-- DFP setup START -->
 <script type='text/javascript'>
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
 var gads = document.createElement("script");
 gads.async = true;
 gads.type = "text/javascript";
 var useSSL = "https:" == document.location.protocol;
 gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
 var node =document.getElementsByTagName("script")[0];
 node.parentNode.insertBefore(gads, node);
 })();
 </script>

<script>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</script>
<!-- HEADER CODE END -->


<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />
<link rel="pingback" href="http://www.towleroad.com/xmlrpc.php" />
<meta property="fb:pages" content="13794040506" />


<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "7584020" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7584020&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version='2.0';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,'script','//connect.facebook.net/en_US/fbevents.js');

fbq('init', '1699882000230257');
fbq('track', "PageView");</script>
<noscript><img height="1" width="1" style="display:none"
src="https://www.facebook.com/tr?id=1699882000230257&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->


<script src="//load.sumome.com/" data-sumo-site-id="9ed9404ba9695df8b4b4aefc60ff8292dd425098853a4fcbf574bbd39845eec2" async="async"></script>

<meta name="pocket-site-verification" content="a63e5a37c49bc22a353dad335452bd" />



<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=270%2C270" />
		<style type="text/css" id="wp-custom-css">
			blockquote {
    font-family: Georgia, serif;
    font-size: 18px;
    font-style: italic;
    width: 400px;
    margin: .25em 0;
    padding: 0.45em 30px;
    line-height: 1.45;
    position: relative;
    color: #383838;
    background:#ececec;

}
 
blockquote:before {
    display: block;
    content: "\201C";
    font-size: 70px;
    position: absolute;
    left: 0px;
    top: -10px;
    color: #7a7a7a;
}
 
blockquote cite {
    color: #999999;
    font-size: 14px;
    display: block;
    margin-top: 5px;
}
  
blockquote cite:before {
    content: "\2014 \2009";
}		</style>
	</head>
<body class="post-template-default single single-post postid-366902 single-format-standard sidebar-content-sidebar" itemscope itemtype="https://schema.org/WebPage">	<div id='interstitial'>
		<script type='text/javascript'>
			googletag.cmd.push(function() { googletag.display('interstitial'); });
		</script>
	</div>
<div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="header-sharing"><a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="site"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a> <a href="http://www.twitter.com/share?url=http://www.towleroad.com/"><i class="icon-twitter"></i></a></div><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.towleroad.com/">Towleroad</a></p></div><nav class="nav-header" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-primary" class="menu genesis-nav-menu menu-header"><li id="menu-item-364955" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-364955"><a href="http://www.towleroad.com/tag/body-conscious/" itemprop="url"><span itemprop="name">Body</span></a></li>
<li id="menu-item-337715" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-337715"><a href="http://www.towleroad.com/tag/daily-resist/" itemprop="url"><span itemprop="name">Daily Resist</span></a></li>
<li id="menu-item-227804" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227804"><a href="http://www.towleroad.com/tag/politics/" itemprop="url"><span itemprop="name">POLITICS</span></a></li>
<li id="menu-item-227806" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227806"><a href="http://www.towleroad.com/tag/travel/" itemprop="url"><span itemprop="name">Travel</span></a></li>
<li id="menu-item-227809" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227809"><a href="http://www.towleroad.com/tag/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
<li id="menu-item-227807" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227807"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url"><span itemprop="name">Theatre</span></a></li>
<li id="menu-item-227721" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227721"><a href="http://www.towleroad.com/tag/film/" itemprop="url"><span itemprop="name">Film</span></a></li>
<li id="menu-item-227808" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227808"><a href="http://www.towleroad.com/tag/television/" itemprop="url"><span itemprop="name">TV</span></a></li>
<li id="menu-item-270521" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-270521"><a href="http://www.towleroad.com/tag/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li class="menu-item search"><i class="icon-search"></i><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.towleroad.com/" role="search"><meta itemprop="target" content="http://www.towleroad.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="" /><input type="submit" value=""  /></form></li></ul></nav><nav class="nav-secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-secondary" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-303865" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-303865"><a href="http://www.towleroad.com/tag/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
<li id="menu-item-276395" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-276395"><a href="http://www.towleroad.com/tag/men/" itemprop="url"><span itemprop="name">Men</span></a></li>
<li id="menu-item-227801" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227801"><a href="http://www.towleroad.com/tag/gay-marriage/" itemprop="url"><span itemprop="name">Marriage Equality</span></a></li>
<li id="menu-item-275223" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-275223"><a href="http://www.towleroad.com/tag/space/" itemprop="url"><span itemprop="name">Space</span></a></li>
<li id="menu-item-227820" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227820"><a href="http://www.towleroad.com/tag/transgender/" itemprop="url"><span itemprop="name">Trans Rights</span></a></li>
<li id="menu-item-227817" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227817"><a href="http://www.towleroad.com/tag/books/" itemprop="url"><span itemprop="name">Books</span></a></li>
<li id="menu-item-241504" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-241504"><a href="http://www.towleroad.com/tag/science/" itemprop="url"><span itemprop="name">Science</span></a></li>
<li id="menu-item-227819" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227819"><a href="http://www.towleroad.com/tag/gay-iconography/" itemprop="url"><span itemprop="name">Gay Iconography</span></a></li>
<li id="menu-item-227863" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227863"><a href="http://www.towleroad.com/tag/towleread/" itemprop="url"><span itemprop="name">TowleREAD</span></a></li>
</ul></nav><p class="breaking-news"><span class="red">BREAKING:</span> <a href="http://www.towleroad.com/2018/03/angels-in-america-review/">Andrew Garfield and Nathan Lane Star in Electrifying ‘Angels in America’: REVIEW</a></p></div></header><div class="header-leaderboard tr-widget-area"><div class="wrap"><section id="text-3" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader1-->
<div class='responsive-ad'>
<div id='ad-leader1' style="margin-bottom:10px">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader1'); });
</script>
</div>
</div></div>
		</div></section>
</div></div><div class="site-inner"><div class="wrap"><div class="content-sidebar-wrap"><main class="content"><article class="post-366902 post type-post status-publish format-standard has-post-thumbnail tag-drag-queens tag-entertainment tag-film tag-movies tag-rupauls-drag-race tag-tv entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</h1>
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2018/03/romania-same-sex/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2018/03/romania-same-sex/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366898" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">Romania&#8217;s Ruling Party Leader Considering Same-Sex Civil Partnership Legislation</span></a></div></div></div><div class="entry-meta"><p class="byline">by <a href="http://www.towleroad.com/author/andy-towle/"> Andy Towle</a><br />March 27, 2018 | 11:12am</p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/movie-drag-queens/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_shares" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/movie-drag-queens/&text=&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="366902 http://www.towleroad.com/?p=366902">Comments</span></a></div></div></header><div class="entry-content" itemprop="text"><p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/-p3IuaAlvGY?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<p>Six <em>RuPaul&#8217;s Drag Race</em> Season 10 contestants —Blair St. Clair, Monique Heart, Monét X Change, Yuhua Hamasaki, Eureka O’Hara, and The Vixen — sat down with <em>Vanity Fair</em> to take a look at Hollywood&#8217;s past movie drag queens.</p>
<h2>RELATED: <em><a href="http://www.towleroad.com/2018/03/rupauls-drag-race-premiere-recap-5/" rel="bookmark">10s Across the Board For A ‘RuPaul’s Drag Race’ Strong Start [RECAP]</a></em></h2>
<p>Watch as they lay some expert analysis on Tony Curtis and Jack Lemmon in <em>Some Like It Hot</em> (&#8220;these are wholesome women&#8221;), Divine in <em>Pink Flamingos </em>(&#8220;this legendary bitch&#8221;), Dustin Hoffman in <em>Tootsie </em>(&#8220;she looks like she has those goldfish in her bag&#8221;), Robin Williams in<em> Mrs. Doubtfire</em> (&#8220;this is what you call a female impersonator&#8221;),<em> Priscilla Queen of the Desert</em> (&#8220;high old school drag glamour&#8221;), Shawn and Marlon Wayans in <em>White Chicks</em> (&#8220;they giving you everyday lady&#8221;), Chiwetel Ejiofor in <em>Kinky Boots</em> (&#8220;this is what we do&#8221;),and  John Travolta in <em>Hairspray</em> (&#8220;she is doing the age old drag queen trick of a reveal&#8221;).</p><div class="1m8dWGTx" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- rec1-->
<div class='responsive-ad'>
<div id='ad-rec1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec1'); });
</script>
</div>
</div></div>
<!-- 01_tlrd_block_mid -->
<div class='responsive-ad'>
<div id='ad-block-spon'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-block-spon'); });
</script>
</div>
</div></p><div class="pubexchange_module" id="pubexchange_below_content_1" data-pubexchange-module-id="1851"></div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.towleroad.com/2018/03/movie-drag-queens/"
    dc:identifier="http://www.towleroad.com/2018/03/movie-drag-queens/"
    dc:title="&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH"
    trackback:ping="http://www.towleroad.com/2018/03/movie-drag-queens/trackback/" />
</rdf:RDF>-->
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2018/03/romania-same-sex/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2018/03/romania-same-sex/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366898" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">Romania&#8217;s Ruling Party Leader Considering Same-Sex Civil Partnership Legislation</span></a></div></div></div><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/movie-drag-queens/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_shares" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/movie-drag-queens/&text=&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/movie-drag-queens/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="366902 http://www.towleroad.com/?p=366902">Comments</span></a> <span class="st_email_hcount" st_url="http://www.towleroad.com/2018/03/movie-drag-queens/" displayText="Email"></span></div></div><footer class="entry-footer"><p>Posted March 27, 2018 at 11:12am ETC by <a href="http://www.towleroad.com/author/andy-towle/">Andy Towle</a><br />in <a href="http://www.towleroad.com/tag/drag-queens/">drag queens</a>, <a href="http://www.towleroad.com/tag/entertainment/">Entertainment</a>, <a href="http://www.towleroad.com/tag/film/">Film</a>, <a href="http://www.towleroad.com/tag/movies/">movies</a>, <a href="http://www.towleroad.com/tag/rupauls-drag-race/">rupaul's drag race</a>, <a href="http://www.towleroad.com/tag/tv/">tv</a></p><div class="archive-post-info tr-widget-area"><section id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec1-->
<div class='responsive-ad'>
<div id='ad-rec1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec1'); });
</script>
</div>
</div>
</div>
		</div></section>
</div></footer></article><div class="before-comments tr-widget-area"><section id="text-30" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><span data-sumome-listbuilder-embed-id="72378c5e8c42f98f626f7c8ec68df01394029895dae00415eb0caf21cf35af7f"></span>

</br></br><iframe id="widgetPreview" style="width: 100%; height:574px;background-color: transparent;" src="https://widget.icopyright.net/widgets/-Kf1VHiaUe9KeOHNbprO#-Kf1VHiaUe9KeOHNbprO" frameborder="0"></iframe></div>
		</div></section>
</div>
<div id="disqus_thread">
    </div>

</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="be-social-widget-3" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com/tlrd"><i class="icon-instagram"></i></a></p></div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec3-->
<div class='responsive-ad'>
<div id='ad-rec3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec3'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec4-->
<div class='responsive-ad'>
<div id='ad-rec4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec4'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><h4 class="widget-title widgettitle">Like Towleroad</h4>
<div class="textwidget custom-html-widget"><div class="fb-page" data-href="https://www.facebook.com/towleroad.page/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="true"><blockquote cite="https://www.facebook.com/towleroad.page/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/towleroad.page/">Towleroad</a></blockquote></div></div></div></section>
<section id="text-47" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec5-->
<div class='responsive-ad'>
<div id='ad-rec5'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec5'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="be-video-widget-2" class="widget be-video-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Video</h4>
<div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="300" height="168" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?fit=300%2C168" class="block wp-image-366903" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?w=1376 1376w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=300%2C168 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=768%2C429 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=1024%2C572 1024w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=150%2C84 150w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/03/movie-drag-queens/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/movie-drag-queens/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_shares" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/movie-drag-queens/&text=&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/movie-drag-queens/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="366902"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/03/tv-this-week-51/"><img width="300" height="169" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?fit=300%2C169" class="block wp-image-366853" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?w=600 600w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=300%2C169 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=150%2C84 150w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/03/tv-this-week-51/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/03/tv-this-week-51/">&#8216;Sam Bee&#8217; Remembers Puerto Rico, Neil Patrick Harris Is Back On Netflix and More TV This Week</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/tv-this-week-51/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="366852"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">6</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/tv-this-week-51/&text=&#8216;Sam Bee&#8217; Remembers Puerto Rico, Neil Patrick Harris Is Back On Netflix and More TV This Week" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366852"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/tv-this-week-51/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="366852"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">6</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/03/zachary-quinto-busted/"><img width="300" height="207" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?fit=300%2C207" class="block wp-image-366887" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?w=1376 1376w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=300%2C207 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=768%2C530 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=1024%2C707 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/03/zachary-quinto-busted/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/03/zachary-quinto-busted/">Zachary Quinto Busted for Using Fake Name at Starbucks: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/zachary-quinto-busted/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="366885"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">153</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/zachary-quinto-busted/&text=Zachary Quinto Busted for Using Fake Name at Starbucks: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366885"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/zachary-quinto-busted/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="366885"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">153</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/"><img width="300" height="65" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?fit=300%2C65" class="block wp-image-366877" alt="cristiano ronaldo kissed" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?w=1376 1376w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?resize=300%2C65 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?resize=768%2C167 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?resize=1024%2C223 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/">Cristiano Ronaldo Kissed by Male Fans Invading Football Match: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="366871"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">47</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/&text=Cristiano Ronaldo Kissed by Male Fans Invading Football Match: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366871"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="366871"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">47</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/03/stormy-daniels-threat-2/"><img width="300" height="162" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?fit=300%2C162" class="block wp-image-366850" alt="raj shah stormy daniels threat" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?resize=300%2C162 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?resize=768%2C415 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?resize=1024%2C554 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/03/stormy-daniels-threat-2/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/03/stormy-daniels-threat-2/">White House Denies Stormy Daniels Threat Claims as She Sues Trump Lawyer for Defamation</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/stormy-daniels-threat-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="366848"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">65</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/stormy-daniels-threat-2/&text=White House Denies Stormy Daniels Threat Claims as She Sues Trump Lawyer for Defamation" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366848"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/stormy-daniels-threat-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="366848"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">65</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/03/queer-eye-season-2/"><img width="300" height="207" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?fit=300%2C207" class="block wp-image-366846" alt="queer eye season 2" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?w=1200 1200w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=300%2C207 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=768%2C529 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=1024%2C705 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/03/queer-eye-season-2/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/03/queer-eye-season-2/">&#8216;Queer Eye&#8217; Gets Season 2 Pick-Up, and Tan France Takes SNL&#8217;s Pete Davidson Shopping: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/03/queer-eye-season-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="366844"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">69</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/03/queer-eye-season-2/&text=&#8216;Queer Eye&#8217; Gets Season 2 Pick-Up, and Tan France Takes SNL&#8217;s Pete Davidson Shopping: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="366844"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/03/queer-eye-season-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="366844"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">69</span></a></div></div></div></section>
<section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
<section id="be-eye-candy-2" class="widget be-eye-candy"><div class="widget-wrap"><h4 class="widget-title widgettitle">Hunk of the Day</h4>
<div class="eye-candy-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/02/boxers-or-briefs-2/"><img width="300" height="189" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?fit=300%2C189" class="block wp-image-363721" alt="guys in underwear" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?resize=300%2C189 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?resize=768%2C484 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/02/miller.jpg?resize=1024%2C646 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a></p><p><a href="http://www.towleroad.com/2018/02/boxers-or-briefs-2/">Underwear Expert Daniel Miller Previews What Guys are Packing in Boxers or Briefs: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/02/boxers-or-briefs-2/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="363720"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">54</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/02/boxers-or-briefs-2/&text=Underwear Expert Daniel Miller Previews What Guys are Packing in Boxers or Briefs: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="363720"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/02/boxers-or-briefs-2/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="363720"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">54</span></a></div></div></div></section>
<section id="be-columns-widget-2" class="widget be-columns-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Columns</h4>
<ul><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/lobby-hero-review/">Chris Evans and Michael Cera Are Men in Uniform in Kenneth Lonergan’s Superb ‘Lobby Hero’: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/angels-in-america-review/">Andrew Garfield and Nathan Lane Star in Electrifying ‘Angels in America’: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/frozen-broadway/">A Slushy ‘Frozen’ Opens on Broadway: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/03/versace-finale/">It All Comes To An End On &#8216;Versace: American Crime Story&#8217; Finale: RECAP</a></li><li><a href="http://www.towleroad.com/tag/film-review/" class="column">Film Review</a> <a href="http://www.towleroad.com/2018/03/review-love-simon/">Weekend Movie Review: &#8216;Love, Simon&#8217; is a Must-See</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/03/versace-american-crime-story/">A Final Step Backward For &#8216;Versace: American Crime Story&#8217; Before Next Week&#8217;s Finale: RECAP</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/admissions-play/">Liberal Guilt Gets an All-White Canvas in Joshua Harmon&#8217;s &#8216;Admissions&#8217;: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/tv-recap/" class="column">TV Recap</a> <a href="http://www.towleroad.com/2018/03/versace-recap-4/">Donatella and Andrew Cunanan Make Their &#8216;Ascent&#8217; On &#8216;Versace: American Crime Story&#8217; [RECAP]</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/03/acs-versace-recap/">Behind Andrew Cunanan&#8217;s Breakdown On &#8216;American Crime Story: Versace&#8217; [RECAP]</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/02/black-light/">Jomama Jones Is a Spiritual Mother for the Moment in ‘Black Light’ at Joe’s Pub: REVIEW</a></li></ul></div></section>
</aside></div><aside class="sidebar sidebar-secondary widget-area" role="complementary" aria-label="Secondary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-50" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
<section id="be-latest-news-2" class="widget be-latest-news"><div class="widget-wrap"><h4 class="widget-title widgettitle">Latest Posts</h4>
<ul><li><a href="http://www.towleroad.com/2018/03/romania-same-sex/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366898" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/Victor_Ponta_la_semnarea_declaratiei_politice_privind_infiintarea_USL_2.0_-_14.11_3_15621867427_cropped.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/romania-same-sex/">Romania&#8217;s Ruling Party Leader Considering Same-Sex Civil Partnership Legislation</a><span class="post-time">39 mins ago</span></li><li><a href="http://www.towleroad.com/2018/03/silver-foxes-tv-series/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366896" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/silver-foxes-tv-series/">&#8216;Silver Foxes&#8217; TV Series, Described as a Gay &#8216;Golden Girls&#8217;, Picked Up for Development</a><span class="post-time">55 mins ago</span></li><li><a href="http://www.towleroad.com/2018/03/tv-this-week-51/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366853" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?w=600 600w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=300%2C169 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/tv-this-week-51/">&#8216;Sam Bee&#8217; Remembers Puerto Rico, Neil Patrick Harris Is Back On Netflix and More TV This Week</a><span class="post-time">1 hour ago</span></li><li><a href="http://www.towleroad.com/2018/03/gay-man-shot-puerto-vallarta/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366803" alt="puerto vallarta hate crime" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/gay-man-shot-puerto-vallarta/">Gay Man Shot in Puerto Vallarta with Husband Says Police, Mayor, Media Still Not Listening</a><span class="post-time">2 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/zachary-quinto-busted/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366887" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/zachary-quinto-busted/">Zachary Quinto Busted for Using Fake Name at Starbucks: WATCH</a><span class="post-time">3 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/grindr-hiv/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/hiv_grindr.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366882" alt="" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/hiv_grindr.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/hiv_grindr.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/hiv_grindr.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/grindr-hiv/">Grindr to Regularly Urge Users to Get HIV Tests</a><span class="post-time">3 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/paul-ryan-resignation/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/06/ryan.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-348277" alt="Paul Ryan" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/06/ryan.jpeg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/06/ryan.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2017/06/ryan.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/paul-ryan-resignation/">Paul Ryan Denies Resignation Rumors</a><span class="post-time">3 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366877" alt="cristiano ronaldo kissed" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/cr.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/">Cristiano Ronaldo Kissed by Male Fans Invading Football Match: WATCH</a><span class="post-time">4 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/lobby-hero-review/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366859" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/lobby-hero-review/">Chris Evans and Michael Cera Are Men in Uniform in Kenneth Lonergan’s Superb ‘Lobby Hero’: REVIEW</a><span class="post-time">5 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/stormy-daniels-threat-2/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366850" alt="raj shah stormy daniels threat" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/shah.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/stormy-daniels-threat-2/">White House Denies Stormy Daniels Threat Claims as She Sues Trump Lawyer for Defamation</a><span class="post-time">18 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/queer-eye-season-2/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366846" alt="queer eye season 2" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/queer-eye-season-2/">&#8216;Queer Eye&#8217; Gets Season 2 Pick-Up, and Tan France Takes SNL&#8217;s Pete Davidson Shopping: WATCH</a><span class="post-time">20 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/russian-diplomats/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/biscuit.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366839" alt="Biscuit" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/biscuit.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/biscuit.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/biscuit.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/russian-diplomats/">Black Panther, Russian Diplomats, Sarah Paulson, Croatia, Steve King, Gourmet Cheetos: HOT LINKS</a><span class="post-time">22 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/starkville-pride-parade/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/starkville.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366842" alt="starkville pride" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/starkville.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/starkville.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/starkville.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/starkville-pride-parade/">Starkville, Mississippi Got Its Pride, and it was the City&#8217;s Largest Parade Ever: WATCH</a><span class="post-time">23 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/girl-scout-cookies/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/04/staver.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-309774" alt="Mat Staver Liberty Counsel" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/04/staver.jpg?w=600 600w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/04/staver.jpg?resize=300%2C168 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/04/staver.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/girl-scout-cookies/">Liberty Counsel&#8217;s Mat Staver: Buying Girl Scout Cookies &#8216;Promotes Sexual Promiscuity&#8217;</a><span class="post-time">24 hours ago</span></li><li><a href="http://www.towleroad.com/2018/03/this-is-me/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/wall.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366827" alt="Travis Wall Shoshana Bean" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/wall.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/wall.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/wall.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/this-is-me/">Gay Slurs Transform in Emotional &#8216;This Is Me&#8217; Collaboration by Travis Wall and Shoshana Bean: WATCH</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2018/03/gop-senator-joni-ernst-transgender/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/ernst.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366821" alt="Joni Ernst" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/ernst.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/ernst.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/ernst.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/gop-senator-joni-ernst-transgender/">GOP Senator Joni Ernst Breaks with Trump, Says Trans People Should Serve in Military: WATCH</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2018/03/adam-rippon-look/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/looks_rippon.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-366818" alt="adam rippon looks" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/looks_rippon.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/looks_rippon.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/looks_rippon.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/adam-rippon-look/">Adam Rippon Reviews the Occasionally Embarrassing Evolution of His Look Over the Years: WATCH</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2018/03/beijing-film-festival-gay/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/08/callme.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-351506" alt="Call Me By Your Name" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/08/callme.jpeg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/08/callme.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2017/08/callme.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/03/beijing-film-festival-gay/">Beijing Film Festival Pulls &#8216;Call Me By Your Name&#8217; in Suspected Anti-Gay Govt. Clampdown</a><span class="post-time">1 day ago</span></li></ul></div></section>
</aside></div></div><div class="related-post-carousel"><div class="wrap"><h4>You Might Also Like</h4><ul><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Film</span> <a href="http://www.towleroad.com/2018/03/movie-drag-queens/" class="entry-title">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/silver-foxes-tv-series/" class="thumbnail"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366896" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/silverfoxes.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Entertainment</span> <a href="http://www.towleroad.com/2018/03/silver-foxes-tv-series/" class="entry-title">&#8216;Silver Foxes&#8217; TV Series, Described as a Gay &#8216;Golden Girls&#8217;, Picked Up for Development</a></li><li><a href="http://www.towleroad.com/2018/03/tv-this-week-51/" class="thumbnail"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366853" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">television</span> <a href="http://www.towleroad.com/2018/03/tv-this-week-51/" class="entry-title">&#8216;Sam Bee&#8217; Remembers Puerto Rico, Neil Patrick Harris Is Back On Netflix and More TV This Week</a></li><li><a href="http://www.towleroad.com/2018/03/zachary-quinto-busted/" class="thumbnail"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366887" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/quinto-1.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Entertainment</span> <a href="http://www.towleroad.com/2018/03/zachary-quinto-busted/" class="entry-title">Zachary Quinto Busted for Using Fake Name at Starbucks: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/lobby-hero-review/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366859" alt="" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/lobby-hero-2.jpg?zoom=2&amp;resize=195%2C195 390w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">New York</span> <a href="http://www.towleroad.com/2018/03/lobby-hero-review/" class="entry-title">Chris Evans and Michael Cera Are Men in Uniform in Kenneth Lonergan’s Superb ‘Lobby Hero’: REVIEW</a></li><li><a href="http://www.towleroad.com/2018/03/queer-eye-season-2/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366846" alt="queer eye season 2" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/france.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Entertainment</span> <a href="http://www.towleroad.com/2018/03/queer-eye-season-2/" class="entry-title">&#8216;Queer Eye&#8217; Gets Season 2 Pick-Up, and Tan France Takes SNL&#8217;s Pete Davidson Shopping: WATCH</a></li></ul></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="footer-popularity"><div class="wrap"><div class="offset"><h4>Latest Posts</h4><ul class="postfeed"><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>Six RuPaul&#8217;s Drag Race Season 10 contestants —Blair St. Clair, Monique Heart, Monét X Change, Yuhua Hamasaki, Eureka O’Hara, and The Vixen — sat down with Vanity Fair to take a look at Hollywood&#8217;s past movie drag queens. RELATED: 10s Acro&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>Romania&#8217;s ruling party is considering legislation to allow civil partnerships by same-sex couples, according to Liviu Dragnea (above), leader of the Social Democratic Party. The AP reports: Liviu Dragnea, leader of the ruling Social Democratic&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>Silver Foxes, a series described as a gay Golden Girls and created by writers and producers Stan Zimmerman and James Berg (who collaborated on the actual Golden Girls), has been picked up for development by Super Deluxe, a production team owned by Tu&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/tv-this-week-51/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366853 wp-post-image" alt="" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/03/https-i.cdn_.tbs_.com-assets-images-2018-03-032018-prpromo-1600x900.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/tv-this-week-51/">&#8216;Sam Bee&#8217; Remembers Puerto Rico, Neil Patrick Harris Is Back On Netflix and More TV This Week</a></h3><p>Check out our weekly guide to TV this week, and make sure you’re catching the big premieres, crucial episodes and the stuff you won’t admit you watch when no one’s looking. The first season of grown-ish, a spin-off of the popular ABC sitcom black-ish&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/tv-this-week-51/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/gay-man-shot-puerto-vallarta/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366803 wp-post-image" alt="puerto vallarta hate crime" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/03/2_pv.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/gay-man-shot-puerto-vallarta/">Gay Man Shot in Puerto Vallarta with Husband Says Police, Mayor, Media Still Not Listening</a></h3><p>Carl Blea, the gay man shot while holding hands with his husband as they walked home through a park after a night of dancing in Puerto Vallarta, is heading home on Tuesday. RELATED: Gay Man Shot While Holding Hands with Husband in Puerto Vallarta ‘Ha&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/gay-man-shot-puerto-vallarta/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>Zachary Quinto was busted (above) for trying to go undercover as &#8220;Josh&#8221; in an Ann Arbor, Michigan Starbucks. Unfortunately, Quinto has a couple of unforgettable facial features. ALSO: The A-List Gay Cast of ‘Boys in the Band’ Talks About&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>The gay social app Grindr will urge its users to get tested for HIV every 3-6 months and direct them to the nearest testing place, The NYT reports: &#8220;The company is making the move to “reduce H.I.V. transmission and support our whole community —&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>House Speaker Paul Ryan (R-WI) denied rumors that he is planning to resign in the coming two months. Said Ryan spox AshLee Strong in a statement: “The speaker is not resigning.&#8221; The Hill reported: “The rumor mill is that Paul Ryan is getting re&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>Security appeared to be missing in action during a football match between Portugal and Netherlands today while four separate fans were able to enter the pitch and two managed to plant kisses on Cristiano Ronaldo. FLASHBACK: Cristiano Ronaldo Taunted&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-366903 wp-post-image" alt="movie drag queens" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/03/queens.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></h3><p>The ‘oohs’ and ‘awws’ coming from the Helen Hayes Theatre aren’t just for Chris Evans’ thick porn ‘stache or Michael Cera’s eternal baby face. Second Stage Theatre’s high-voltage revival of Kenneth Lonergan’s Lobby Hero, which opened in the company&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/03/movie-drag-queens/">Read</a></p></li></ul></div><div class="above-footer tr-widget-area"><div class="wrap"><section id="text-10" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader2 -->
<div id='ad-leader2' style="text-align:center;">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader2'); });
</script>
</div></div>
		</div></section>
</div></div><aside id="dpp_widget-2" class="widget box desktop widget_dpp_widget"><h3 class="widget-title">Most Commented</h3><span class="dpp_render_area" id="dpp_render_area-2"></span></aside><div class="box hot-reads"><h4>Hot Reads</h4><div class="menu-popular-posts-container"><ul id="menu-popular-posts" class="menu"><li id="menu-item-351483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351483"><a href="http://www.towleroad.com/2017/07/trump-family-2/" itemprop="url">America’s Top Crime Family: The Trumps</a></li>
<li id="menu-item-349563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-349563"><a href="http://www.towleroad.com/2017/06/anti-gay-baker-case/" itemprop="url">High Stakes for LGBTQ Equality in the Anti-Gay Baker Case at the Supreme Court</a></li>
<li id="menu-item-344169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344169"><a href="http://www.towleroad.com/2017/04/state-department-chechnya/" itemprop="url">State Department ‘Deeply Disturbed’ by Reports of Detention, Torture, and Murder of Gay Men in Chechnya</a></li>
<li id="menu-item-344168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344168"><a href="http://www.towleroad.com/2017/04/kenneth-adkins-2/" itemprop="url">Anti-Gay Pastor Who Said Orlando Victims ‘Got What They Deserved’ Guilty of Sexually Molesting Boy and Girl</a></li>
<li id="menu-item-339222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-339222"><a href="http://www.towleroad.com/2017/01/neil-gorsuch/" itemprop="url">Neil Gorsuch is Trump’s Terrible, No Good Nominee for the Supreme Court: An Analysis</a></li>
<li id="menu-item-336834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336834"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/" itemprop="url">2017 Resolutions All Gay Men Should Consider</a></li>
<li id="menu-item-323766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323766"><a href="http://www.towleroad.com/2016/08/eric-andre-bisexual/" itemprop="url">Comedian Eric Andre: The Gay Interview</a></li>
</ul></div></div></div></div><div class="footer-today"><div class="wrap"><div class="today-header"><h4>Today's News</h4><div class="jump-to-day">Jump To Day: <a href="#">Choose <i class="icon-arrow-down"></i></a></div></div><ul class="one-fourth first"><li><a href="http://www.towleroad.com/2018/03/movie-drag-queens/">&#8216;RuPaul&#8217;s Drag Race&#8217; Season 10 Contestants Review Famous Movie Drag Queens: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/romania-same-sex/">Romania&#8217;s Ruling Party Leader Considering Same-Sex Civil Partnership Legislation</a></li><li><a href="http://www.towleroad.com/2018/03/silver-foxes-tv-series/">&#8216;Silver Foxes&#8217; TV Series, Described as a Gay &#8216;Golden Girls&#8217;, Picked Up for Development</a></li><li><a href="http://www.towleroad.com/2018/03/tv-this-week-51/">&#8216;Sam Bee&#8217; Remembers Puerto Rico, Neil Patrick Harris Is Back On Netflix and More TV This Week</a></li><li><a href="http://www.towleroad.com/2018/03/gay-man-shot-puerto-vallarta/">Gay Man Shot in Puerto Vallarta with Husband Says Police, Mayor, Media Still Not Listening</a></li><li><a href="http://www.towleroad.com/2018/03/zachary-quinto-busted/">Zachary Quinto Busted for Using Fake Name at Starbucks: WATCH</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2018/03/grindr-hiv/">Grindr to Regularly Urge Users to Get HIV Tests</a></li><li><a href="http://www.towleroad.com/2018/03/paul-ryan-resignation/">Paul Ryan Denies Resignation Rumors</a></li><li><a href="http://www.towleroad.com/2018/03/cristiano-ronaldo-kissed/">Cristiano Ronaldo Kissed by Male Fans Invading Football Match: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/lobby-hero-review/">Chris Evans and Michael Cera Are Men in Uniform in Kenneth Lonergan’s Superb ‘Lobby Hero’: REVIEW</a></li><li><a href="http://www.towleroad.com/2018/03/stormy-daniels-threat-2/">White House Denies Stormy Daniels Threat Claims as She Sues Trump Lawyer for Defamation</a></li><li><a href="http://www.towleroad.com/2018/03/queer-eye-season-2/">&#8216;Queer Eye&#8217; Gets Season 2 Pick-Up, and Tan France Takes SNL&#8217;s Pete Davidson Shopping: WATCH</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2018/03/russian-diplomats/">Black Panther, Russian Diplomats, Sarah Paulson, Croatia, Steve King, Gourmet Cheetos: HOT LINKS</a></li><li><a href="http://www.towleroad.com/2018/03/starkville-pride-parade/">Starkville, Mississippi Got Its Pride, and it was the City&#8217;s Largest Parade Ever: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/girl-scout-cookies/">Liberty Counsel&#8217;s Mat Staver: Buying Girl Scout Cookies &#8216;Promotes Sexual Promiscuity&#8217;</a></li><li><a href="http://www.towleroad.com/2018/03/this-is-me/">Gay Slurs Transform in Emotional &#8216;This Is Me&#8217; Collaboration by Travis Wall and Shoshana Bean: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/gop-senator-joni-ernst-transgender/">GOP Senator Joni Ernst Breaks with Trump, Says Trans People Should Serve in Military: WATCH</a></li><li><a href="http://www.towleroad.com/2018/03/adam-rippon-look/">Adam Rippon Reviews the Occasionally Embarrassing Evolution of His Look Over the Years: WATCH</a></li></ul><ul class="one-fourth"><li><a href="http://www.towleroad.com/2018/03/beijing-film-festival-gay/">Beijing Film Festival Pulls &#8216;Call Me By Your Name&#8217; in Suspected Anti-Gay Govt. Clampdown</a></li><li><a href="http://www.towleroad.com/2018/03/puerto-vallarta-hate-crime/">Gay Man Shot While Holding Hands with Husband in Puerto Vallarta &#8216;Hate Crime&#8217;</a></li></ul></div></div><aside id="text-12" class="widget box desktop widget_text">			<div class="textwidget">
</div>
		</aside><div class="lower-footer"><div class="wrap"><div class="one-half first"><section id="be-andy-banner-2" class="widget be-andy-banner"><div class="widget-wrap"><h4 class="widget-title widgettitle">Share This</h4>
<p class="featured-image"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/"><img width="477" height="409" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/12/2017RESOLUTIONSImageLowerRes.jpg?resize=477%2C409" class="block wp-image-336420" alt="" /></a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/01/2017-gay-resolutions/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">3.3k</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/01/2017-gay-resolutions/&text=2017 Resolutions All Gay Men Should Consider" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/01/2017-gay-resolutions/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">3.3k</span></a></div></div></section>
</div><div class="one-half"><div class="one-half first"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Read</h4>
<div class="menu-footer-read-container"><ul id="menu-footer-read" class="menu"><li id="menu-item-219178" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219178"><a href="http://www.towleroad.com/tag/politics/" itemprop="url">Politics</a></li>
<li id="menu-item-219476" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219476"><a href="http://www.towleroad.com/tag/travel/" itemprop="url">Travel</a></li>
<li id="menu-item-219478" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219478"><a href="http://www.towleroad.com/tag/film/" itemprop="url">Film</a></li>
<li id="menu-item-219477" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219477"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url">Theatre</a></li>
<li id="menu-item-219479" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219479"><a href="http://www.towleroad.com/tag/television-2/" itemprop="url">Television</a></li>
<li id="menu-item-219480" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219480"><a href="http://www.towleroad.com/tag/science-2/" itemprop="url">Science</a></li>
<li id="menu-item-219481" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219481"><a href="http://www.towleroad.com/tag/law-gay-lgbt/" itemprop="url">Law &#8211; LGBT Rights</a></li>
<li id="menu-item-219183" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219183"><a href="#" itemprop="url">Columns</a></li>
<li id="menu-item-219184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219184"><a href="#" itemprop="url">Specials</a></li>
</ul></div></div></section>
</div><div class="one-half"><section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">About</h4>
<div class="menu-footer-about-container"><ul id="menu-footer-about" class="menu"><li id="menu-item-219388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="http://www.towleroad.com/contact/" itemprop="url">Advertise</a></li>
<li id="menu-item-219196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="http://www.towleroad.com/contact/" itemprop="url">Contact Us</a></li>
<li id="menu-item-219193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="http://www.towleroad.com/about-us/" itemprop="url">About Towleroad</a></li>
<li id="menu-item-219233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219233"><a href="http://www.towleroad.com/authors/" itemprop="url">Contributors</a></li>
<li id="menu-item-219443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="http://www.towleroad.com/towleroad-social-media/" itemprop="url">Towleroad on Social Media</a></li>
<li id="menu-item-219194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="http://www.towleroad.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
<section id="be-social-widget-2" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com"><i class="icon-instagram"></i></a></p></div></section>
</div><p class="copyright">&copy; 2014 Towleroad. All Rights Reserved.</p></div></div></div></footer></div><script type="text/javascript">
 /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
 var disqus_shortname = 'towleroad'; // required: replace example with your blog short name
/* * * DON'T EDIT BELOW THIS LINE * * */
 (function () {
 var s = document.createElement('script'); s.async = true;
 s.type = 'text/javascript';
 s.src = '//' + disqus_shortname + '.disqus.com/count.js';
 (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
 }());
 </script>
<script type="text/javascript">var switchTo5x=true;</script>
<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">stLight.options({publisher: "25ce3796-0f6f-43b9-a36c-78c2238b9f95", doNotHash: true, doNotCopy: true, hashAddressBar: false});</script>	
	<script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><!-- Chartbeat Tag, part 1 --> 
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-283150-1']);
  _gaq.push(['_setDomainName', '.towleroad.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

<!-- Begin comScore Tag -->
<script>
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
</script>

<script>
  COMSCORE.beacon({
    c1:2,
    c2:7584020,
    c3:"",
    c4:"",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=7584020&c3=&c4=&c5=&c6=&c15=&cj=1" />
</noscript>

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"NCUJh1awVK000u", domain:"towleroad.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=NCUJh1awVK000u" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<!-- Quantcast Tag, part 1 --> 
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
   var elem = document.createElement('script');

   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);  
  })();
</script>

<!-- Facebook APP tag -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '1774199316148150',
      xfbml      : true,
      version    : 'v2.6'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- Facebook APP tag end -->


<!-- Quantcast Tag, part 2 -->
<script type="text/javascript">
_qevents.push( { 
qacct:"p-93b6WeVYdHXoc",
labels:"AskTell.Towleroad,Towleroad,TRFront"
} );
</script>
<noscript>
<div style="display: none;"><img src="//pixel.quantserve.com/pixel/p-93b6WeVYdHXoc.gif?labels=AskTell%20Towleroad%2CTowleroad" height="1" width="1" alt="Quantcast"/></div>
</noscript>

<script type="text/javascript">
var _sf_async_config={uid:551,domain:"towleroad.com",useCanonical:true};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script>

<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />

<script async="" defer="" src="//survey.g.doubleclick.net/async_survey?site=lcfgvapu5adkw"></script>

<script type="text/javascript" src="http://www.lijit.com/blog_wijits?json=0&amp;id=trakr&amp;uri=http%3A%2F%2Fwww.lijit.com%2Fusers%2Ftowleroad&amp;js=1"></script>

<script type="text/javascript" src="//s.skimresources.com/js/92217X1546135.skimlinks.js"></script>

<script>(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><link rel='stylesheet' id='ea-share-count-css'  href='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/css/share-count.css?ver=1.8.0' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/modules/photon/photon.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201813'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/lib/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/comment-reply.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.fitvids.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.matchHeight-min.js?ver=0.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ea_theme_details = {"home_url":"http:\/\/www.towleroad.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/global.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.flexslider-min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.9.4","language":""},"disqusIdentifier":"366902 http:\/\/www.towleroad.com\/?p=366902","disqusShortname":"towleroad","disqusTitle":"\u2018RuPaul\u2019s Drag Race\u2019 Season 10 Contestants Review Famous Movie Drag Queens: WATCH","disqusUrl":"http:\/\/www.towleroad.com\/2018\/03\/movie-drag-queens\/","options":{"manualSync":"1"},"postId":"366902"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.9.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dpp_ajax = {"ajaxurl":"http:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-popular-posts/dpp.js?ver=4.9.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/js/share-count.js?ver=1.8.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"towleroad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.9.4'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201813.js' async defer></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:5.6.1',blog:'93805103',post:'366902',tz:'-4',srv:'www.towleroad.com'} ]);
	_stq.push([ 'clickTrackerInit', '93805103', '366902' ]);
</script>
</body></html>
