<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head >
<meta charset="UTF-8" />
<title>SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH - Towleroad</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v7.3 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="SNL returned last night with a brilliant cold open that followed the wiretapping of Trump lawyer Michael Cohen (Ben Stiller) and allowed the sketch to pay a visit to every clown on Trump&#039;s payroll, starting with Trump himself (Alec Baldwin)."/>
<meta name="original-source" content="http://www.towleroad.com/2018/05/snl-stormy-daniels/" />
<script src="/cdn-cgi/apps/head/A3bNKYP2epbsPGoBj9HE4gWaycc.js"></script><link rel="canonical" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/" />
<link rel="publisher" href="https://plus.google.com/+Towleroad"/>
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH - Towleroad" />
<meta property="og:description" content="SNL returned last night with a brilliant cold open that followed the wiretapping of Trump lawyer Michael Cohen (Ben Stiller) and allowed the sketch to pay a visit to every clown on Trump&#039;s payroll, starting with Trump himself (Alec Baldwin)." />
<meta property="og:url" content="http://www.towleroad.com/2018/05/snl-stormy-daniels/" />
<meta property="og:site_name" content="Towleroad" />
<meta property="article:publisher" content="https://www.facebook.com/towleroad.page" />
<meta property="article:author" content="https://www.facebook.com/andytowle" />
<meta property="article:tag" content="Alec Baldwin" />
<meta property="article:tag" content="Daily Resist" />
<meta property="article:tag" content="Saturday Night Live" />
<meta property="article:tag" content="Stormy Daniels" />
<meta property="article:tag" content="tv" />
<meta property="article:published_time" content="2018-05-06T09:14:25-04:00" />
<meta property="article:modified_time" content="2018-05-06T16:52:02-04:00" />
<meta property="og:updated_time" content="2018-05-06T16:52:02-04:00" />
<meta property="fb:app_id" content="180651805330333" />
<meta property="og:image" content="http://www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="SNL returned last night with a brilliant cold open that followed the wiretapping of Trump lawyer Michael Cohen (Ben Stiller) and allowed the sketch to pay a visit to every clown on Trump&#039;s payroll, starting with Trump himself (Alec Baldwin)." />
<meta name="twitter:title" content="SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH - Towleroad" />
<meta name="twitter:site" content="@tlrd" />
<meta name="twitter:image" content="http://www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg" />
<meta name="twitter:creator" content="@andytowle" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"http:\/\/www.towleroad.com\/","sameAs":["https:\/\/www.facebook.com\/towleroad.page","https:\/\/instagram.com\/tlrd\/","https:\/\/www.linkedin.com\/company\/towleroad","https:\/\/plus.google.com\/+Towleroad","https:\/\/www.youtube.com\/user\/TowleroadTV","https:\/\/www.pinterest.com\/towleroad\/","https:\/\/twitter.com\/tlrd"],"@id":"http:\/\/www.towleroad.com\/#organization","name":"Towleroad","logo":"http:\/\/towleroad.com\/wp-content\/uploads\/2015\/06\/600x600_T.jpg"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//www.towleroad.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//code.jquery.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Feed" href="http://www.towleroad.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; Comments Feed" href="http://www.towleroad.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad &raquo; SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH Comments Feed" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.4\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.towleroad.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.5"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56692,8205,9792,65039],[55357,56692,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='child-theme-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/style.css?ver=1498864291' type='text/css' media='all' />
<link rel='stylesheet' id='glaser-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/webfonts/webfonts.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='be-icons-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/icons/styles.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='ea-jquery-ui-css'  href='//code.jquery.com/ui/1.10.4/themes/dot-luv/jquery-ui.min.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='ea-flexslider-css'  href='http://www.towleroad.com/wp-content/themes/genesis-child2/css/flexslider/flexslider.css?ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='be-fonts-css'  href='http://fonts.googleapis.com/css?family=Noto+Sans%3A400%2C700&#038;ver=4.9.5' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='http://www.towleroad.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.0' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis/lib/js/html5shiv.min.js?ver=3.7.3'></script>
<![endif]-->
<link rel='https://api.w.org/' href='http://www.towleroad.com/wp-json/' />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.towleroad.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.5" />
<link rel='shortlink' href='http://www.towleroad.com/?p=369442' />
<link rel="alternate" type="application/json+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2018%2F05%2Fsnl-stormy-daniels%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://www.towleroad.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.towleroad.com%2F2018%2F05%2Fsnl-stormy-daniels%2F&#038;format=xml" />
<meta name='pubexchange:image' content='https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?fit=300%2C163'>
<meta name='pubexchange:title' content='SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH'>

<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><script type="text/javascript">

    	jQuery(".newsletter-optin").click(function() {
			jQuery(this).find("input").click();
    	});

		function setCookie(cname, cvalue, exdays) {
		    var d = new Date();
		    d.setTime(d.getTime() + (exdays*24*60*60*1000));
		    var expires = "expires="+d.toUTCString();
		    document.cookie = cname + "=" + cvalue + "; " + expires;
		}

		function subscribe_to_newsletter(comment_id) {

			jQuery.ajax({
			  type: "POST",
			  url: "http://staging.towleroad.com/disqus.php",
			  data: { comment_id: comment_id },
			beforeSend: function() {
				var loader = jQuery( "<img/>", {
				    src: "http://staging.towleroad.com/wp-admin/images/wpspin_light-2x.gif ", width: "32", height: "32",
				    "class": "loader-image"
				});		
				jQuery(".newsletter-optin").html(loader);
			},			  
			  success: function(data) {
			  		setCookie("newsletter-opted-in", "true", 365);
				jQuery(".newsletter-optin").html("Please check your email inbox to confirm the newsletter registration.");			      	

			    }
			});		
		}

		function disqus_config() {
		    this.callbacks.onNewComment = [function(comment) { 
		      var comment_id = comment.id;
		      var user_opted_for_newsletter_subscription = jQuery(".newsletter-optin input:checkbox:checked").length > 0;
		      if (user_opted_for_newsletter_subscription) {
		      	subscribe_to_newsletter(comment_id);			      	
		  	  }
		    }];
		}
    	var disqus_url ="http://www.towleroad.com/2018/05/snl-stormy-daniels/";
	    var disqus_identifier = "369442 http://www.towleroad.com/?p=369442";
	    var disqus_title = "SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH";
    </script><!-- HEADER CODE START -->
<meta name="google-site-verification" content="aWVVHBSTDagAYi2h1c0bTxrpJO8OQ82AHU_iEUSByuE" />
<meta name="google-site-verification" content="p31FkTwhP2MO0Dy6yv6jB4qZGy0XFROHGJdeUMMMQgE" />
<!-- Pingdom Site Monitoring added by ReadyMadeWeb in August -->
<script>

var _prum = [['id', '55c15d41abe53dd432e0057c'],
             ['mark', 'firstbyte', (new Date()).getTime()]];
(function() {
    var s = document.getElementsByTagName('script')[0]
      , p = document.createElement('script');
    p.async = 'async';
    p.src = '//rum-static.pingdom.net/prum.min.js';
    s.parentNode.insertBefore(p, s);
})();
</script>

<!-- Start: GPT Async -->

<!-- Criteo ad de blocker -->
<script type="text/javascript" src="//static.criteo.net/js/ld/publishertag.js"></script>
<!-- Criteo ad de blocker -->

<!-- AdSense Page Level Ads -->
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4162187998603810",
    enable_page_level_ads: true
  });
</script>
<!-- AdSense Page Level Ads -->

<!-- DFP setup START -->
 <script type='text/javascript'>
 var googletag = googletag || {};
 googletag.cmd = googletag.cmd || [];
 (function() {
 var gads = document.createElement("script");
 gads.async = true;
 gads.type = "text/javascript";
 var useSSL = "https:" == document.location.protocol;
 gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
 var node =document.getElementsByTagName("script")[0];
 node.parentNode.insertBefore(gads, node);
 })();
 </script>

<script>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</script>
<!-- HEADER CODE END -->


<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />
<link rel="pingback" href="http://www.towleroad.com/xmlrpc.php" />
<meta property=\"fb:pages\" content=\"13794040506\" />


<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: \"2\", c2: \"7584020\" });
  (function() {
    var s = document.createElement(\"script\"), el = document.getElementsByTagName(\"script\")[0]; s.async = true;
    s.src = (document.location.protocol == \"https:\" ? \"https://sb\" : \"http://b\") + \".scorecardresearch.com/beacon.js\";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src=\"https://sb.scorecardresearch.com/p?c1=2&c2=7584020&cv=2.0&cj=1\" />
</noscript>
<!-- End comScore Tag -->

<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
n.push=n;n.loaded=!0;n.version=\'2.0\';n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
document,\'script\',\'//connect.facebook.net/en_US/fbevents.js\');

fbq(\'init\', \'1699882000230257\');
fbq(\'track\', \"PageView\");</script>
<noscript><img height=\"1\" width=\"1\" style=\"display:none\"
src=\"https://www.facebook.com/tr?id=1699882000230257&ev=PageView&noscript=1\"
/></noscript>
<!-- End Facebook Pixel Code -->


<script src=\"//load.sumome.com/\" data-sumo-site-id=\"9ed9404ba9695df8b4b4aefc60ff8292dd425098853a4fcbf574bbd39845eec2\" async=\"async\"></script>

<meta name=\"pocket-site-verification\" content=\"a63e5a37c49bc22a353dad335452bd\" />



<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=32%2C32" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=192%2C192" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=180%2C180" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T.jpg?fit=270%2C270" />
		<style type="text/css" id="wp-custom-css">
			blockquote {
    font-family: Georgia, serif;
    font-size: 18px;
    font-style: italic;
    width: 400px;
    margin: .25em 0;
    padding: 0.45em 30px;
    line-height: 1.45;
    position: relative;
    color: #383838;
    background:#ececec;

}
 
blockquote:before {
    display: block;
    content: "\201C";
    font-size: 70px;
    position: absolute;
    left: 0px;
    top: -10px;
    color: #7a7a7a;
}
 
blockquote cite {
    color: #999999;
    font-size: 14px;
    display: block;
    margin-top: 5px;
}
  
blockquote cite:before {
    content: "\2014 \2009";
}		</style>
	</head>
<body class="post-template-default single single-post postid-369442 single-format-standard sidebar-content-sidebar" itemscope itemtype="https://schema.org/WebPage">	<div id='interstitial'>
		<script type='text/javascript'>
			googletag.cmd.push(function() { googletag.display('interstitial'); });
		</script>
	</div>
<div class="site-container"><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="header-sharing"><a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="site"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a> <a href="http://www.twitter.com/share?url=http://www.towleroad.com/"><i class="icon-twitter"></i></a></div><div class="title-area"><p class="site-title" itemprop="headline"><a href="http://www.towleroad.com/">Towleroad</a></p></div><nav class="nav-header" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-primary" class="menu genesis-nav-menu menu-header"><li id="menu-item-364955" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-364955"><a href="http://www.towleroad.com/tag/body-conscious/" itemprop="url"><span itemprop="name">Body</span></a></li>
<li id="menu-item-337715" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-337715"><a href="http://www.towleroad.com/tag/daily-resist/" itemprop="url"><span itemprop="name">Daily Resist</span></a></li>
<li id="menu-item-227804" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227804"><a href="http://www.towleroad.com/tag/politics/" itemprop="url"><span itemprop="name">POLITICS</span></a></li>
<li id="menu-item-227806" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227806"><a href="http://www.towleroad.com/tag/travel/" itemprop="url"><span itemprop="name">Travel</span></a></li>
<li id="menu-item-227809" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227809"><a href="http://www.towleroad.com/tag/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
<li id="menu-item-227807" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227807"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url"><span itemprop="name">Theatre</span></a></li>
<li id="menu-item-227721" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227721"><a href="http://www.towleroad.com/tag/film/" itemprop="url"><span itemprop="name">Film</span></a></li>
<li id="menu-item-227808" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227808"><a href="http://www.towleroad.com/tag/television/" itemprop="url"><span itemprop="name">TV</span></a></li>
<li id="menu-item-270521" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-270521"><a href="http://www.towleroad.com/tag/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
<li class="menu-item search"><i class="icon-search"></i><form class="search-form" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction" method="get" action="http://www.towleroad.com/" role="search"><meta itemprop="target" content="http://www.towleroad.com/?s={s}"/><input itemprop="query-input" type="search" name="s" placeholder="" /><input type="submit" value=""  /></form></li></ul></nav><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-secondary" class="menu genesis-nav-menu menu-secondary"><li id="menu-item-303865" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-303865"><a href="http://www.towleroad.com/tag/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
<li id="menu-item-276395" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-276395"><a href="http://www.towleroad.com/tag/men/" itemprop="url"><span itemprop="name">Men</span></a></li>
<li id="menu-item-227801" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227801"><a href="http://www.towleroad.com/tag/gay-marriage/" itemprop="url"><span itemprop="name">Marriage Equality</span></a></li>
<li id="menu-item-275223" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-275223"><a href="http://www.towleroad.com/tag/space/" itemprop="url"><span itemprop="name">Space</span></a></li>
<li id="menu-item-227820" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227820"><a href="http://www.towleroad.com/tag/transgender/" itemprop="url"><span itemprop="name">Trans Rights</span></a></li>
<li id="menu-item-227817" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227817"><a href="http://www.towleroad.com/tag/books/" itemprop="url"><span itemprop="name">Books</span></a></li>
<li id="menu-item-241504" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-241504"><a href="http://www.towleroad.com/tag/science/" itemprop="url"><span itemprop="name">Science</span></a></li>
<li id="menu-item-227819" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227819"><a href="http://www.towleroad.com/tag/gay-iconography/" itemprop="url"><span itemprop="name">Gay Iconography</span></a></li>
<li id="menu-item-227863" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227863"><a href="http://www.towleroad.com/tag/towleread/" itemprop="url"><span itemprop="name">TowleREAD</span></a></li>
</ul></nav><p class="breaking-news"><span class="red">BREAKING:</span> <a href="http://www.towleroad.com/2018/05/colton-haynes-split/">Colton Haynes Speaks Out After Reports of Split from Husband of 6 Months</a></p></div></header><div class="header-leaderboard tr-widget-area"><div class="wrap"><section id="text-3" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader1-->
<div class='responsive-ad'>
<div id='ad-leader1' style="margin-bottom:10px">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader1'); });
</script>
</div>
</div></div>
		</div></section>
</div></div><div class="site-inner"><div class="wrap"><div class="content-sidebar-wrap"><main class="content"><article class="post-369442 post type-post status-publish format-standard has-post-thumbnail tag-alec-baldwin tag-daily-resist tag-saturday-night-live tag-stormy-daniels tag-tv entry" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</h1>
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369438" alt="Rachel Maddow Rod Rosenstein" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=300%2C169 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=768%2C431 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=1024%2C575 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">This Rachel Maddow Segment on Rod Rosenstein&#8217;s Refusal to Be Extorted by GOP Trump Allies in Congress is a Must-Watch</span></a></div><div class="next"><a href="http://www.towleroad.com/2018/05/colton-haynes-split/" class="arrow icon-arrow-right"><span>Next</span></a><a href="http://www.towleroad.com/2018/05/colton-haynes-split/" class="hover"><span class="label">Next Story</span><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369447" alt="colton haynes split" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?zoom=2&amp;resize=150%2C84 300w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">Colton Haynes Speaks Out After Reports of Split from Husband of 6 Months</span></a></div></div></div><div class="entry-meta"><p class="byline">by <a href="http://www.towleroad.com/author/andy-towle/"> Andy Towle</a><br />May 6, 2018 | 9:14am</p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/snl-stormy-daniels/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">224</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/snl-stormy-daniels/&text=SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="369442 http://www.towleroad.com/?p=369442">Comments</span></a></div></div></header><div class="entry-content" itemprop="text"><p><img class="alignnone wp-image-369443 size-full" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=740%2C402" alt="snl stormy daniels" width="740" height="402" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?w=3110 3110w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=300%2C163 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=768%2C417 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=1024%2C556 1024w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?w=1480 1480w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?w=2220 2220w" sizes="(max-width: 740px) 100vw, 740px" data-recalc-dims="1" /></p>
<p>SNL returned last night with a brilliant cold open that followed the wiretapping of Trump lawyer Michael Cohen (Ben Stiller) and allowed the sketch to pay a visit to every clown on Trump&#8217;s payroll, starting with Trump himself (Alec Baldwin).</p>
<p>The calls then moved along to Dr. Bornstein (Martin Short), Rudy Giuliani (the genius Kate McKinnon) who was seated at FOX News with Ainsley Earhardt.</p><div class="KMiA0Rau" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- rec1-->
<div class='responsive-ad'>
<div id='ad-rec1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec1'); });
</script>
</div>
</div></div>
<p>Stiller&#8217;s Cohen launched a (wiretapped) conference call between McKinnon&#8217;s Giuliani and Baldwin&#8217;s Trump when it was interrupted by Sarah Huckabee Sanders, who said, &#8220;I have lost all credibility. Did you lie to me about the Stormy Daniels affair?&#8221;</p>
<p>Replied Baldwin&#8217;s Trump, appeasing Sanders: &#8220;Yeah that sounds like something I would do.&#8221;</p><div class="54r2YAXr" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- rec2-->
<div class='responsive-ad'>
<div id='ad-rec2'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec2'); });
</script>
</div>
</div></div>
<p>Melania Trump (Cecily Strong) then interrupted the conference call for some advice from Cohen, who was then interrupted by Omarosa (Leslie Jones), and Mike Pence (Beck Bennett).</p>
<p>Finally, a surprise appearance from Scarlett Johansson and Jimmy Fallon as Ivanka Trump and Jared Kushner, before the big reveal.</p>
<p>Stiller&#8217;s Cohen is instructed by Baldwin&#8217;s Trump to call Stormy Daniels, who plays herself.</p>
<p>“I know you don’t believe in climate change,&#8221; said Daniels. &#8220;but a storm’s a coming, baby.”</p>
<p>Watch:</p>
<p><span class="embed-youtube" style="text-align:center; display: block;"><iframe class='youtube-player' type='text/html' width='740' height='447' src='http://www.youtube.com/embed/K1K8s-tQGqY?version=3&#038;rel=1&#038;fs=1&#038;autohide=2&#038;showsearch=0&#038;showinfo=1&#038;iv_load_policy=1&#038;wmode=transparent' allowfullscreen='true' style='border:0;'></iframe></span></p>
<!-- 01_tlrd_block_mid -->
<div class='responsive-ad'>
<div id='ad-block-spon'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-block-spon'); });
</script>
</div>
</div></p><div class="pubexchange_module" id="pubexchange_below_content_1" data-pubexchange-module-id="1851"></div><!--<rdf:RDF xmlns:rdf="http://www.w3.org/1999/02/22-rdf-syntax-ns#"
			xmlns:dc="http://purl.org/dc/elements/1.1/"
			xmlns:trackback="http://madskills.com/public/xml/rss/module/trackback/">
		<rdf:Description rdf:about="http://www.towleroad.com/2018/05/snl-stormy-daniels/"
    dc:identifier="http://www.towleroad.com/2018/05/snl-stormy-daniels/"
    dc:title="SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH"
    trackback:ping="http://www.towleroad.com/2018/05/snl-stormy-daniels/trackback/" />
</rdf:RDF>-->
<div class="post-navigation"><div class="wrap"><div class="prev"><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="arrow icon-arrow-left"><span>Previous</span></a><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="hover"><span class="label">Previous Story</span><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369438" alt="Rachel Maddow Rod Rosenstein" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=300%2C169 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=768%2C431 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=1024%2C575 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">This Rachel Maddow Segment on Rod Rosenstein&#8217;s Refusal to Be Extorted by GOP Trump Allies in Congress is a Must-Watch</span></a></div><div class="next"><a href="http://www.towleroad.com/2018/05/colton-haynes-split/" class="arrow icon-arrow-right"><span>Next</span></a><a href="http://www.towleroad.com/2018/05/colton-haynes-split/" class="hover"><span class="label">Next Story</span><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369447" alt="colton haynes split" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?zoom=2&amp;resize=150%2C84 300w" sizes="(max-width: 150px) 100vw, 150px" /><span class="title">Colton Haynes Speaks Out After Reports of Split from Husband of 6 Months</span></a></div></div></div><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/snl-stormy-daniels/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">224</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/snl-stormy-daniels/&text=SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/snl-stormy-daniels/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">224</span></a> <a class="ea-share-count-button style-bubble comment" href=""><span class="ea-share-count-icon-label"><i class="icon-comment"></i></span><span class="ea-share-count disqus-comment-count" data-disqus-identifier="369442 http://www.towleroad.com/?p=369442">Comments</span></a> <span class="st_email_hcount" st_url="http://www.towleroad.com/2018/05/snl-stormy-daniels/" displayText="Email"></span></div></div><footer class="entry-footer"><p>Posted May 6, 2018 at 9:14am ETC by <a href="http://www.towleroad.com/author/andy-towle/">Andy Towle</a><br />in <a href="http://www.towleroad.com/tag/alec-baldwin/">Alec Baldwin</a>, <a href="http://www.towleroad.com/tag/daily-resist/">Daily Resist</a>, <a href="http://www.towleroad.com/tag/saturday-night-live/">Saturday Night Live</a>, <a href="http://www.towleroad.com/tag/stormy-daniels/">Stormy Daniels</a>, <a href="http://www.towleroad.com/tag/tv/">tv</a></p><div class="archive-post-info tr-widget-area"><section id="text-5" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec1-->
<div class='responsive-ad'>
<div id='ad-rec1'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec1'); });
</script>
</div>
</div>
</div>
		</div></section>
</div></footer></article><div class="before-comments tr-widget-area"><section id="text-30" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><span data-sumome-listbuilder-embed-id="72378c5e8c42f98f626f7c8ec68df01394029895dae00415eb0caf21cf35af7f"></span>

</div>
		</div></section>
</div>
<div id="disqus_thread"></div>
</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="be-social-widget-3" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com/tlrd"><i class="icon-instagram"></i></a></p></div></section>
<section id="text-7" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec3-->
<div class='responsive-ad'>
<div id='ad-rec3'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec3'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="text-11" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec4-->
<div class='responsive-ad'>
<div id='ad-rec4'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec4'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="custom_html-7" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><h4 class="widget-title widgettitle">Like Towleroad</h4>
<div class="textwidget custom-html-widget"><div class="fb-page" data-href="https://www.facebook.com/towleroad.page/" data-small-header="true" data-adapt-container-width="true" data-hide-cover="true" data-show-facepile="true"><blockquote cite="https://www.facebook.com/towleroad.page/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/towleroad.page/">Towleroad</a></blockquote></div></div></div></section>
<section id="text-47" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- rec5-->
<div class='responsive-ad'>
<div id='ad-rec5'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-rec5'); });
</script>
</div>
</div>
</div>
		</div></section>
<section id="be-video-widget-2" class="widget be-video-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Video</h4>
<div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/"><img width="300" height="150" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?fit=300%2C150" class="block wp-image-369451" alt="giuliani avenatti" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?w=1490 1490w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=300%2C150 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=768%2C385 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=1024%2C513 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/05/avenatti-giuliani/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/">Michael Avenatti Blasts Rudy Giuliani After New Disastrous Set of TV Appearances: &#8216;It&#8217;s a Train Wreck&#8217; &#8211; WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/avenatti-giuliani/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_shares" data-postid="369449"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/avenatti-giuliani/&text=Michael Avenatti Blasts Rudy Giuliani After New Disastrous Set of TV Appearances: &#8216;It&#8217;s a Train Wreck&#8217; &#8211; WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369449"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/avenatti-giuliani/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="369449"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><img width="300" height="163" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?fit=300%2C163" class="block wp-image-369443" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?w=3110 3110w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=300%2C163 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=768%2C417 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=1024%2C556 1024w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?w=1480 1480w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?w=2220 2220w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/snl-stormy-daniels/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">224</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/snl-stormy-daniels/&text=SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/snl-stormy-daniels/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="369442"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">224</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/"><img width="300" height="169" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?fit=300%2C169" class="block wp-image-369438" alt="Rachel Maddow Rod Rosenstein" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=300%2C169 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=768%2C431 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=1024%2C575 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84 150w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/">This Rachel Maddow Segment on Rod Rosenstein&#8217;s Refusal to Be Extorted by GOP Trump Allies in Congress is a Must-Watch</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="369437"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">340</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/&text=This Rachel Maddow Segment on Rod Rosenstein&#8217;s Refusal to Be Extorted by GOP Trump Allies in Congress is a Must-Watch" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369437"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="369437"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">340</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/05/kilauea/"><img width="300" height="258" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?fit=300%2C258" class="block wp-image-369431" alt="Ronaldy Dias" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?w=1200 1200w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?resize=300%2C258 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?resize=768%2C660 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?resize=1024%2C880 1024w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?resize=477%2C409 477w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/05/kilauea/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/05/kilauea/">Kilauea Volcano, Meghan Markle, Lebanon, MØ, Tina Fey, Snoop Dogg, Han Solo, Mitt Romney&#8217;s Meat: HOT LINKS</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/kilauea/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="369375"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">19</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/kilauea/&text=Kilauea Volcano, Meghan Markle, Lebanon, MØ, Tina Fey, Snoop Dogg, Han Solo, Mitt Romney&#8217;s Meat: HOT LINKS" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369375"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/kilauea/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="369375"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">19</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/"><img width="300" height="172" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?fit=300%2C172" class="block wp-image-369415" alt="colton haynes marriage" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?w=1376 1376w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=300%2C172 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=768%2C440 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=1024%2C587 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/05/colton-haynes-marriage/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/">Colton Haynes Releases New Song &#8216;Man It Sucks&#8217; Amid Reports His Marriage of 6 Months is Over</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/colton-haynes-marriage/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="369412"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">256</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/colton-haynes-marriage/&text=Colton Haynes Releases New Song &#8216;Man It Sucks&#8217; Amid Reports His Marriage of 6 Months is Over" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369412"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/colton-haynes-marriage/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="369412"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">256</span></a></div></div><div class="video-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/05/crazy-eyes/"><img width="300" height="163" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?fit=300%2C163" class="block wp-image-369408" alt="crazy eyes giuliani" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?w=1376 1376w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=300%2C163 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=768%2C417 768w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=1024%2C557 1024w" sizes="(max-width: 300px) 100vw, 300px" /></a><a class="play" href="http://www.towleroad.com/2018/05/crazy-eyes/"><i class="icon-play"></i></a></p><p><a href="http://www.towleroad.com/2018/05/crazy-eyes/">Jimmy Kimmel: Rudy Giuliani Has &#8216;a Major Case of Crazy Eyes&#8217; &#8211; WATCH</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/05/crazy-eyes/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_shares" data-postid="369407"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/05/crazy-eyes/&text=Jimmy Kimmel: Rudy Giuliani Has &#8216;a Major Case of Crazy Eyes&#8217; &#8211; WATCH" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="369407"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/05/crazy-eyes/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count facebook_likes" data-postid="369407"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span></a></div></div></div></section>
<section id="text-8" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
<section id="be-eye-candy-2" class="widget be-eye-candy"><div class="widget-wrap"><h4 class="widget-title widgettitle">Hunk of the Day</h4>
<div class="eye-candy-post"><p class="featured-image"><a href="http://www.towleroad.com/2018/04/dan-stripped/"><img width="300" height="170" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?fit=300%2C170" class="block wp-image-368934" alt="matt and dan watch what happens live" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?w=1626 1626w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?resize=300%2C170 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?resize=768%2C436 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?resize=1024%2C581 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/04/wwhl.jpg?w=1480 1480w" sizes="(max-width: 300px) 100vw, 300px" /></a></p><p><a href="http://www.towleroad.com/2018/04/dan-stripped/">Matt and Dan Stripped Down for Andy Cohen (and Attention) on &#8216;Watch What Happens Live!&#8217;</a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2018/04/dan-stripped/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="368930"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">151</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2018/04/dan-stripped/&text=Matt and Dan Stripped Down for Andy Cohen (and Attention) on &#8216;Watch What Happens Live!&#8217;" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="368930"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2018/04/dan-stripped/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="368930"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">151</span></a></div></div></div></section>
<section id="be-columns-widget-2" class="widget be-columns-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Columns</h4>
<ul><li><a href="http://www.towleroad.com/tag/tv-recap/" class="column">TV Recap</a> <a href="http://www.towleroad.com/2018/05/snatch-game-2/">A Stumbling &#8216;Snatch Game&#8217; Leaves Queens Shook on &#8216;RuPaul&#8217;s Drag Race&#8217; &#8211; [RECAP and RANKINGS]</a></li><li><a href="http://www.towleroad.com/tag/film-review/" class="column">Film Review</a> <a href="http://www.towleroad.com/2018/04/avengers-infinity-war-review/">The World&#8217;s #1 Movie: &#8216;Avengers: Infinity War&#8217; &#8211; REVIEW</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/04/in-transfers-play/">In ‘Transfers,’ a Shot at Privilege Means Reckoning with Stacked Odds: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/04/rupauls-drag-race-recap-6/">The Queens On &#8216;RuPaul&#8217;s Drag Race&#8217; Talk the Talk [RECAP and RANKING]</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/04/carousel-broadway/">Time’s Up? Not So Fast: ‘Carousel’ Is Back on Broadway: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/04/in-this-flat-earth/">In ‘This Flat Earth,’ Growing Up in the Shadow of a School Shooting</a></li><li><a href="http://www.towleroad.com/tag/recap/" class="column">Recap</a> <a href="http://www.towleroad.com/2018/04/rupauls-drag-race/">&#8216;RuPaul&#8217;s Drag Race&#8217; Queens Get App Happy and Flocked Up on the Runway [RECAP and RANKING]</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/three-tall-women/">In ‘Three Tall Women’ and ‘Yerma,’ Stunning Portraits of Women on the Verge: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/lobby-hero-review/">Chris Evans and Michael Cera Are Men in Uniform in Kenneth Lonergan’s Superb ‘Lobby Hero’: REVIEW</a></li><li><a href="http://www.towleroad.com/tag/theatre-review/" class="column">Theatre Review</a> <a href="http://www.towleroad.com/2018/03/angels-in-america-review/">Andrew Garfield and Nathan Lane Star in Electrifying ‘Angels in America’: REVIEW</a></li></ul></div></section>
</aside></div><aside class="sidebar sidebar-secondary widget-area" role="complementary" aria-label="Secondary Sidebar" itemscope itemtype="https://schema.org/WPSideBar"><section id="text-50" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"></div>
		</div></section>
<section id="be-latest-news-2" class="widget be-latest-news"><div class="widget-wrap"><h4 class="widget-title widgettitle">Latest Posts</h4>
<ul><li><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369451" alt="giuliani avenatti" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/avenatti-giuliani/">Michael Avenatti Blasts Rudy Giuliani After New Disastrous Set of TV Appearances: &#8216;It&#8217;s a Train Wreck&#8217; &#8211; WATCH</a><span class="post-time">6 hours ago</span></li><li><a href="http://www.towleroad.com/2018/05/colton-haynes-split/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369447" alt="colton haynes split" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/03ZPZAPq_400x400.jpg?zoom=2&amp;resize=150%2C84 300w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/colton-haynes-split/">Colton Haynes Speaks Out After Reports of Split from Husband of 6 Months</a><span class="post-time">7 hours ago</span></li><li><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369438" alt="Rachel Maddow Rod Rosenstein" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?w=1376 1376w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=300%2C169 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=768%2C431 768w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=1024%2C575 1024w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/">This Rachel Maddow Segment on Rod Rosenstein&#8217;s Refusal to Be Extorted by GOP Trump Allies in Congress is a Must-Watch</a><span class="post-time">1 day ago</span></li><li><a href="http://www.towleroad.com/2018/05/gay-adoption/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/colyer_fallin.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369435" alt="jeff colyer mary fallin" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/colyer_fallin.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/colyer_fallin.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/colyer_fallin.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/gay-adoption/">Kansas and Oklahoma Poised to Legalize Discrimination Against Gay Couples Who Want to Adopt</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/kilauea/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369431" alt="Ronaldy Dias" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/dias.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/kilauea/">Kilauea Volcano, Meghan Markle, Lebanon, MØ, Tina Fey, Snoop Dogg, Han Solo, Mitt Romney&#8217;s Meat: HOT LINKS</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/giuliani-statement-2/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369421" alt="rudy giuliani statement" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/giuliani-statement-2/">Rudy Giuliani Tries to Sop Up Mess with New Statement</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369415" alt="colton haynes marriage" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/colton-haynes-marriage/">Colton Haynes Releases New Song &#8216;Man It Sucks&#8217; Amid Reports His Marriage of 6 Months is Over</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/crazy-eyes/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369408" alt="crazy eyes giuliani" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/crazy-eyes/">Jimmy Kimmel: Rudy Giuliani Has &#8216;a Major Case of Crazy Eyes&#8217; &#8211; WATCH</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/caitlyn-jenner-uk-parliament/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-322883" alt="Caitlyn Jenner" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?resize=150%2C84 150w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?zoom=2&amp;resize=150%2C84 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/caitlyn-jenner-uk-parliament/">Caitlyn Jenner to Address UK Parliament</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/trump-giuliani/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_trump-1.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369400" alt="Giuliani Trump" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_trump-1.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_trump-1.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_trump-1.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/trump-giuliani/">Trump Throws Giuliani Under the Bus on Stormy Payment Revelations: &#8216;He&#8217;ll Get His Facts Straight&#8217; &#8211; WATCH</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/snatch-game-2/" class="thumbnail"><img width="150" height="84" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/snatchgame.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369395" alt="snatch game" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/snatchgame.jpg?w=600 600w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/snatchgame.jpg?resize=300%2C169 300w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/snatchgame.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/snatch-game-2/">A Stumbling &#8216;Snatch Game&#8217; Leaves Queens Shook on &#8216;RuPaul&#8217;s Drag Race&#8217; &#8211; [RECAP and RANKINGS]</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/gus-kenworthy-rippon/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/kenworthy_rippon.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369377" alt="kenworthy rippon" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/kenworthy_rippon.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/kenworthy_rippon.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/kenworthy_rippon.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/gus-kenworthy-rippon/">Gus Kenworthy Interviewed BFF Adam Rippon for &#8216;Nightline&#8217; and Got a Major Scoop: WATCH</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/trump-religious-freedom-2/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/whouse_trump.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369372" alt="trump religious freedom" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/whouse_trump.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/whouse_trump.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/whouse_trump.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/trump-religious-freedom-2/">Trump Just Handed a Weapon to Anti-LGBTQ Cretins of Every Stripe with New &#8216;Religious Freedom&#8217; Executive Order</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/michael-avenatti-payment/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/avenatti.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369368" alt="michael avenatti" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/avenatti.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/avenatti.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/avenatti.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/michael-avenatti-payment/">Michael Avenatti: &#8216;There&#8217;s No Question&#8217; the Stormy Daniels Payment &#8216;Had Everything to Do with the Election&#8217; &#8211; WATCH</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/trump-nbc/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/nbc_trump.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369365" alt="nbc trump" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/nbc_trump.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/nbc_trump.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/nbc_trump.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/trump-nbc/">Trump Smells Blood After NBC News Wiretap &#8216;Update&#8217;, Tearing Into His &#8216;Former Home&#8217;</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/richard-grenell-mike-pence/" class="thumbnail"><img width="150" height="84" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/grenell.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369360" alt="Richard Grenell Mike Pence" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/grenell.jpg?resize=150%2C84 150w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/grenell.jpg?zoom=2&amp;resize=150%2C84 300w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/grenell.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/richard-grenell-mike-pence/">Richard Grenell, Trump&#8217;s Highest-Ranking Openly Gay Appointee, Sworn in by Homophobe Mike Pence: WATCH</a><span class="post-time">2 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/streaming-in-may/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/catchone.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369355" alt="jewel&#039;s catch one" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/catchone.jpg?resize=150%2C84 150w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/catchone.jpg?zoom=2&amp;resize=150%2C84 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/catchone.jpg?zoom=3&amp;resize=150%2C84 450w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/streaming-in-may/">&#8216;Jewel&#8217;s Catch One,&#8217; &#8216;I, Tonya&#8217; and Everything Else Streaming in May on Amazon, Netflix, Hulu, and HBO</a><span class="post-time">3 days ago</span></li><li><a href="http://www.towleroad.com/2018/05/pose-trailer/" class="thumbnail"><img width="150" height="84" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/2_pose.jpg?resize=150%2C84" class="attachment-be_latest size-be_latest wp-image-369352" alt="pose trailer" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/2_pose.jpg?w=1376 1376w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/2_pose.jpg?resize=300%2C168 300w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/2_pose.jpg?resize=768%2C429 768w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/2_pose.jpg?resize=1024%2C572 1024w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/2_pose.jpg?resize=150%2C84 150w" sizes="(max-width: 150px) 100vw, 150px" /></a><a class="entry-title" href="http://www.towleroad.com/2018/05/pose-trailer/">The Official Trailer for Ryan Murphy&#8217;s &#8216;Pose&#8217; is a Total Ball: WATCH</a><span class="post-time">3 days ago</span></li></ul></div></section>
</aside></div></div><div class="related-post-carousel"><div class="wrap"><h4>You Might Also Like</h4><ul><li><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369451" alt="giuliani avenatti" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">POLITICS</span> <a href="http://www.towleroad.com/2018/05/avenatti-giuliani/" class="entry-title">Michael Avenatti Blasts Rudy Giuliani After New Disastrous Set of TV Appearances: &#8216;It&#8217;s a Train Wreck&#8217; &#8211; WATCH</a></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/" class="thumbnail"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369443" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">Daily Resist</span> <a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/" class="entry-title">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></li><li><a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369438" alt="Rachel Maddow Rod Rosenstein" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/maddow_rosenstein.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">POLITICS</span> <a href="http://www.towleroad.com/2018/05/rachel-maddow-rod-rosenstein/" class="entry-title">This Rachel Maddow Segment on Rod Rosenstein&#8217;s Refusal to Be Extorted by GOP Trump Allies in Congress is a Must-Watch</a></li><li><a href="http://www.towleroad.com/2018/05/giuliani-statement-2/" class="thumbnail"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369421" alt="rudy giuliani statement" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">POLITICS</span> <a href="http://www.towleroad.com/2018/05/giuliani-statement-2/" class="entry-title">Rudy Giuliani Tries to Sop Up Mess with New Statement</a></li><li><a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/" class="thumbnail"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369415" alt="colton haynes marriage" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">music</span> <a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/" class="entry-title">Colton Haynes Releases New Song &#8216;Man It Sucks&#8217; Amid Reports His Marriage of 6 Months is Over</a></li><li><a href="http://www.towleroad.com/2018/05/crazy-eyes/" class="thumbnail"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369408" alt="crazy eyes giuliani" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><span class="category">POLITICS</span> <a href="http://www.towleroad.com/2018/05/crazy-eyes/" class="entry-title">Jimmy Kimmel: Rudy Giuliani Has &#8216;a Major Case of Crazy Eyes&#8217; &#8211; WATCH</a></li></ul></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="footer-popularity"><div class="wrap"><div class="offset"><h4>Latest Posts</h4><ul class="postfeed"><li><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369451 wp-post-image" alt="giuliani avenatti" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/giuliani_avenatti.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/">Michael Avenatti Blasts Rudy Giuliani After New Disastrous Set of TV Appearances: &#8216;It&#8217;s a Train Wreck&#8217; &#8211; WATCH</a></h3><p>Rudy Giuliani appeared on ABC News&#8217; This Week (above) with George Stephanopoulos and continued to unload about Trump and Michael Cohen even though he admitted he&#8217;s just &#8220;halfway&#8221; up to speed on the facts. And it showed. Asked&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/avenatti-giuliani/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369443 wp-post-image" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></h3><p>Late this week it was reported that actor Colton Haynes had split from his husband of six months, Beverly Hills florist-to-the-stars Jeff Leatham after Haynes erased photos of the couple from his Instagram page. Haynes also released a new song called&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369443 wp-post-image" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></h3><p>SNL returned last night with a brilliant cold open that followed the wiretapping of Trump lawyer Michael Cohen (Ben Stiller) and allowed the sketch to pay a visit to every clown on Trump&#8217;s payroll, starting with Trump himself (Alec Baldwin). Th&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369443 wp-post-image" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></h3><p>On last night&#8217;s Rachel Maddow Show, Maddow noted that all the discussion this week about Rudy Giuliani and the payments to Stormy Daniels were just noise obscuring the real &#8220;existential threat&#8221; to the Trump presidency. Maddow took a&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369443 wp-post-image" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></h3><p>The Kansas and Oklahoma legislatures passed hateful anti-LGBTQ adoption bills on Friday. Kansas Governor Jeff Colyer has indicated he will sign the bill into law and Oklahoma Governor Mary Fallin has not said what she will do, but given her track rec&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369443 wp-post-image" alt="snl stormy daniels" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/stormy.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></h3><p>HAWAII. Kilauea volcano erupts, spewing lava into residential neighborhoods. &#8220;Hawaii County said steam and lava poured out of a crack in Leilani Estates, which is near the town of Pahoa on the Big Island. County, state and federal officials had&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/giuliani-statement-2/"><img width="195" height="195" src="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369421 wp-post-image" alt="rudy giuliani statement" srcset="https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?resize=195%2C195 195w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?zoom=2&amp;resize=195%2C195 390w, https://i2.wp.com/www.towleroad.com/wp-content/uploads/2018/05/r_giuliani.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/giuliani-statement-2/">Rudy Giuliani Tries to Sop Up Mess with New Statement</a></h3><p>Trump lawyer Rudy Giuliani released a statement on Friday attempting to clean up a mess he created in interviews with Sean Hannity and FOX &amp; Friends earlier this week. Giuliani&#8217;s remarks have precipitated a cascade of explanations from memb&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/giuliani-statement-2/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/"><img width="195" height="195" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369415 wp-post-image" alt="colton haynes marriage" srcset="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?resize=195%2C195 195w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?zoom=2&amp;resize=195%2C195 390w, https://i0.wp.com/www.towleroad.com/wp-content/uploads/2018/05/haynes.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/colton-haynes-marriage/">Colton Haynes Releases New Song &#8216;Man It Sucks&#8217; Amid Reports His Marriage of 6 Months is Over</a></h3><p>Colton Haynes and Jeff Leatham have split up after six months of marriage, TMZ is reporting: &#8220;Colton has unfollowed Jeff on Instagram and almost completely wiped any photos of Jeff off his page.&#8221; Haynes married Leatham on October 28 in Pa&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/colton-haynes-marriage/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/crazy-eyes/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-369408 wp-post-image" alt="crazy eyes giuliani" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2018/05/eyes_giuliani.jpg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/crazy-eyes/">Jimmy Kimmel: Rudy Giuliani Has &#8216;a Major Case of Crazy Eyes&#8217; &#8211; WATCH</a></h3><p>Last night, Jimmy Kimmel took note of Trump lawyer Rudy Giuliani&#8217;s stuttering attempts to explain the Stormy Daniels reimbursements, paying particular attention to Giuliani&#8217;s excitement, evinced by &#8220;a major case of crazy eyes.&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/crazy-eyes/">Read</a></p></li><li><a href="http://www.towleroad.com/2018/05/caitlyn-jenner-uk-parliament/"><img width="195" height="195" src="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?resize=195%2C195" class="attachment-thumbnail size-thumbnail wp-image-322883 wp-post-image" alt="Caitlyn Jenner" srcset="https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?resize=195%2C195 195w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?zoom=2&amp;resize=195%2C195 390w, https://i1.wp.com/www.towleroad.com/wp-content/uploads/2016/08/jenner.jpeg?zoom=3&amp;resize=195%2C195 585w" sizes="(max-width: 195px) 100vw, 195px" /></a><h3><a href="http://www.towleroad.com/2018/05/caitlyn-jenner-uk-parliament/">Caitlyn Jenner to Address UK Parliament</a></h3><p>Caitlyn Jenner will give a lecture on diversity to the UK Parliament which will be broadcast by Channel 4 as part of an annual lecture series. The Guardian reports: The transgender activist and former Olympic gold medallist is following in the footst&hellip; <br /><a class="more-link" href="http://www.towleroad.com/2018/05/caitlyn-jenner-uk-parliament/">Read</a></p></li></ul></div><div class="above-footer tr-widget-area"><div class="wrap"><section id="text-10" class="widget widget_text"><div class="widget-wrap">			<div class="textwidget"><!-- leader2 -->
<div id='ad-leader2' style="text-align:center;">
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('ad-leader2'); });
</script>
</div></div>
		</div></section>
</div></div><aside id="dpp_widget-2" class="widget box desktop widget_dpp_widget"><h3 class="widget-title">Most Commented</h3><span class="dpp_render_area" id="dpp_render_area-2"></span></aside><div class="box hot-reads"><h4>Hot Reads</h4><div class="menu-popular-posts-container"><ul id="menu-popular-posts" class="menu"><li id="menu-item-351483" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-351483"><a href="http://www.towleroad.com/2017/07/trump-family-2/" itemprop="url">America’s Top Crime Family: The Trumps</a></li>
<li id="menu-item-349563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-349563"><a href="http://www.towleroad.com/2017/06/anti-gay-baker-case/" itemprop="url">High Stakes for LGBTQ Equality in the Anti-Gay Baker Case at the Supreme Court</a></li>
<li id="menu-item-344169" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344169"><a href="http://www.towleroad.com/2017/04/state-department-chechnya/" itemprop="url">State Department ‘Deeply Disturbed’ by Reports of Detention, Torture, and Murder of Gay Men in Chechnya</a></li>
<li id="menu-item-344168" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-344168"><a href="http://www.towleroad.com/2017/04/kenneth-adkins-2/" itemprop="url">Anti-Gay Pastor Who Said Orlando Victims ‘Got What They Deserved’ Guilty of Sexually Molesting Boy and Girl</a></li>
<li id="menu-item-339222" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-339222"><a href="http://www.towleroad.com/2017/01/neil-gorsuch/" itemprop="url">Neil Gorsuch is Trump’s Terrible, No Good Nominee for the Supreme Court: An Analysis</a></li>
<li id="menu-item-336834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-336834"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/" itemprop="url">2017 Resolutions All Gay Men Should Consider</a></li>
<li id="menu-item-323766" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-323766"><a href="http://www.towleroad.com/2016/08/eric-andre-bisexual/" itemprop="url">Comedian Eric Andre: The Gay Interview</a></li>
</ul></div></div></div></div><div class="footer-today"><div class="wrap"><div class="today-header"><h4>Today's News</h4><div class="jump-to-day">Jump To Day: <a href="#">Choose <i class="icon-arrow-down"></i></a></div></div><ul class="one-fourth first"><li><a href="http://www.towleroad.com/2018/05/avenatti-giuliani/">Michael Avenatti Blasts Rudy Giuliani After New Disastrous Set of TV Appearances: &#8216;It&#8217;s a Train Wreck&#8217; &#8211; WATCH</a></li><li><a href="http://www.towleroad.com/2018/05/colton-haynes-split/">Colton Haynes Speaks Out After Reports of Split from Husband of 6 Months</a></li><li><a href="http://www.towleroad.com/2018/05/snl-stormy-daniels/">SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH</a></li></ul></div></div><aside id="text-12" class="widget box desktop widget_text">			<div class="textwidget">
</div>
		</aside><div class="lower-footer"><div class="wrap"><div class="one-half first"><section id="be-andy-banner-2" class="widget be-andy-banner"><div class="widget-wrap"><h4 class="widget-title widgettitle">Share This</h4>
<p class="featured-image"><a href="http://www.towleroad.com/2017/01/2017-gay-resolutions/"><img width="477" height="409" src="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2016/12/2017RESOLUTIONSImageLowerRes.jpg?resize=477%2C409" class="block wp-image-336420" alt="" /></a></p><div class="sharing"><a href="https://www.facebook.com/sharer/sharer.php?u=http://www.towleroad.com/2017/01/2017-gay-resolutions/&display=popup&ref=plugin&src=share_button" title="Share on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_shares" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Share</span></span><span class="ea-share-count">3.3k</span></a> <a href="https://twitter.com/share?url=http://www.towleroad.com/2017/01/2017-gay-resolutions/&text=2017 Resolutions All Gay Men Should Consider" title="Share on Twitter"  target="_blank"  class="ea-share-count-button style-bubble ea-share-no-count twitter" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-twitter"></i><span class="ea-share-count-label"></span></span></a> <a href="http://www.facebook.com/plugins/like.php?href=http://www.towleroad.com/2017/01/2017-gay-resolutions/" title="Like on Facebook"  target="_blank"  class="ea-share-count-button style-bubble facebook_likes" data-postid="336705"><span class="ea-share-count-icon-label"><i class="ea-share-count-icon icon-social-facebook"></i><span class="ea-share-count-label">Like</span></span><span class="ea-share-count">3.3k</span></a></div></div></section>
</div><div class="one-half"><div class="one-half first"><section id="nav_menu-2" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">Read</h4>
<div class="menu-footer-read-container"><ul id="menu-footer-read" class="menu"><li id="menu-item-219178" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219178"><a href="http://www.towleroad.com/tag/politics/" itemprop="url">Politics</a></li>
<li id="menu-item-219476" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219476"><a href="http://www.towleroad.com/tag/travel/" itemprop="url">Travel</a></li>
<li id="menu-item-219478" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219478"><a href="http://www.towleroad.com/tag/film/" itemprop="url">Film</a></li>
<li id="menu-item-219477" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219477"><a href="http://www.towleroad.com/tag/theatre/" itemprop="url">Theatre</a></li>
<li id="menu-item-219479" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219479"><a href="http://www.towleroad.com/tag/television-2/" itemprop="url">Television</a></li>
<li id="menu-item-219480" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219480"><a href="http://www.towleroad.com/tag/science-2/" itemprop="url">Science</a></li>
<li id="menu-item-219481" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-219481"><a href="http://www.towleroad.com/tag/law-gay-lgbt/" itemprop="url">Law &#8211; LGBT Rights</a></li>
<li id="menu-item-219183" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219183"><a href="#" itemprop="url">Columns</a></li>
<li id="menu-item-219184" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-219184"><a href="#" itemprop="url">Specials</a></li>
</ul></div></div></section>
</div><div class="one-half"><section id="nav_menu-3" class="widget widget_nav_menu"><div class="widget-wrap"><h4 class="widget-title widgettitle">About</h4>
<div class="menu-footer-about-container"><ul id="menu-footer-about" class="menu"><li id="menu-item-219388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="http://www.towleroad.com/contact/" itemprop="url">Advertise</a></li>
<li id="menu-item-219196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="http://www.towleroad.com/contact/" itemprop="url">Contact Us</a></li>
<li id="menu-item-219193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="http://www.towleroad.com/about-us/" itemprop="url">About Towleroad</a></li>
<li id="menu-item-219233" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219233"><a href="http://www.towleroad.com/authors/" itemprop="url">Contributors</a></li>
<li id="menu-item-219443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="http://www.towleroad.com/towleroad-social-media/" itemprop="url">Towleroad on Social Media</a></li>
<li id="menu-item-219194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="http://www.towleroad.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
<section id="be-social-widget-2" class="widget be-social-widget"><div class="widget-wrap"><h4 class="widget-title widgettitle">Follow Us</h4>
<p><a href="https://twitter.com/tlrd"><i class="icon-twitter"></i></a> <a href="https://www.facebook.com/towleroad.page"><i class="icon-social-facebook"></i></a> <a href="http://www.instagram.com"><i class="icon-instagram"></i></a></p></div></section>
</div><p class="copyright">&copy; 2014 Towleroad. All Rights Reserved.</p></div></div></div></footer></div><script type="text/javascript">
 /* * * CONFIGURATION VARIABLES: EDIT BEFORE PASTING INTO YOUR WEBPAGE * * */
 var disqus_shortname = 'towleroad'; // required: replace example with your blog short name
/* * * DON'T EDIT BELOW THIS LINE * * */
 (function () {
 var s = document.createElement('script'); s.async = true;
 s.type = 'text/javascript';
 s.src = '//' + disqus_shortname + '.disqus.com/count.js';
 (document.getElementsByTagName('HEAD')[0] || document.getElementsByTagName('BODY')[0]).appendChild(s);
 }());
 </script>
<script type="text/javascript">var switchTo5x=true;</script>
<script type="text/javascript" src="http://w.sharethis.com/button/buttons.js"></script>
<script type="text/javascript">stLight.options({publisher: "25ce3796-0f6f-43b9-a36c-78c2238b9f95", doNotHash: true, doNotCopy: true, hashAddressBar: false});</script>	
	<script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><!-- Chartbeat Tag, part 1 --> 
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script type="text/javascript">
  var _gaq = _gaq || [];
  _gaq.push(['_setAccount', 'UA-283150-1']);
  _gaq.push(['_setDomainName', '.towleroad.com']);
  _gaq.push(['_trackPageview']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();
</script>

<!-- Begin comScore Tag -->
<script>
    document.write(unescape("%3Cscript src='" + (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js' %3E%3C/script%3E"));
</script>

<script>
  COMSCORE.beacon({
    c1:2,
    c2:7584020,
    c3:"",
    c4:"",
    c5:"",
    c6:"",
    c15:""
  });
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=7584020&c3=&c4=&c5=&c6=&c15=&cj=1" />
</noscript>

<!-- Start Alexa Certify Javascript -->
<script type="text/javascript">
_atrk_opts = { atrk_acct:"NCUJh1awVK000u", domain:"towleroad.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=NCUJh1awVK000u" style="display:none" height="1" width="1" alt="" /></noscript>
<!-- End Alexa Certify Javascript -->

<!-- Quantcast Tag, part 1 --> 
<script type="text/javascript">
  var _qevents = _qevents || [];

  (function() {
   var elem = document.createElement('script');

   elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
   elem.async = true;
   elem.type = "text/javascript";
   var scpt = document.getElementsByTagName('script')[0];
   scpt.parentNode.insertBefore(elem, scpt);  
  })();
</script>

<!-- Facebook APP tag -->
<script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '1774199316148150',
      xfbml      : true,
      version    : 'v2.6'
    });
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<!-- Facebook APP tag end -->


<!-- Quantcast Tag, part 2 -->
<script type="text/javascript">
_qevents.push( { 
qacct:"p-93b6WeVYdHXoc",
labels:"AskTell.Towleroad,Towleroad,TRFront"
} );
</script>
<noscript>
<div style="display: none;"><img src="//pixel.quantserve.com/pixel/p-93b6WeVYdHXoc.gif?labels=AskTell%20Towleroad%2CTowleroad" height="1" width="1" alt="Quantcast"/></div>
</noscript>

<script type="text/javascript">
var _sf_async_config={uid:551,domain:"towleroad.com",useCanonical:true};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script>

<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />
<!-- ukey="119170C1" -->
<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />

<script async="" defer="" src="//survey.g.doubleclick.net/async_survey?site=lcfgvapu5adkw"></script>

<script type="text/javascript" src="http://www.lijit.com/blog_wijits?json=0&amp;id=trakr&amp;uri=http%3A%2F%2Fwww.lijit.com%2Fusers%2Ftowleroad&amp;js=1"></script>

<script type="text/javascript" src="//s.skimresources.com/js/92217X1546135.skimlinks.js"></script>

<script>(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><link rel='stylesheet' id='ea-share-count-css'  href='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/css/share-count.css?ver=1.8.0' type='text/css' media='all' />
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"towleroad"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.15'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.15"},"disqusIdentifier":"369442 http:\/\/www.towleroad.com\/?p=369442","disqusShortname":"towleroad","disqusTitle":"SNL Taps the Real Stormy Daniels for a Banger Cold Open: WATCH","disqusUrl":"http:\/\/www.towleroad.com\/2018\/05\/snl-stormy-daniels\/","postId":"369442"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.15'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201818'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/lib/js/responsive-menu.js?ver=1.0.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/comment-reply.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.fitvids.js?ver=1.1'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.matchHeight-min.js?ver=0.5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ea_theme_details = {"home_url":"http:\/\/www.towleroad.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/global.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/themes/genesis-child2/js/jquery.flexslider-min.js?ver=1.0'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-includes/js/wp-embed.min.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/jetpack/_inc/build/shortcodes/js/instagram.min.js?ver=4.9.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var dpp_ajax = {"ajaxurl":"http:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/disqus-popular-posts/dpp.js?ver=4.9.5'></script>
<script type='text/javascript' src='http://www.towleroad.com/wp-content/plugins/EA-Share-Count/assets/js/share-count.js?ver=1.8.0'></script>
<script type='text/javascript' src='https://stats.wp.com/e-201818.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.0',blog:'93805103',post:'369442',tz:'-4',srv:'www.towleroad.com'} ]);
	_stq.push([ 'clickTrackerInit', '93805103', '369442' ]);
</script>
</body></html>
