<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<title>&#039;Pose&#039; Delivers A Legendary Series Finale And Glorious Goodbye To Season 3 [RECAP] - Towleroad Gay News</title>
<meta name="description" content="While the last few episodes of Pose have indulged in a bit of over-the-top wish fulfillment, last night&#039;s two-hour series finale placed the focus squarely" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<script src="/cdn-cgi/apps/head/A3bNKYP2epbsPGoBj9HE4gWaycc.js"></script><link rel="canonical" href="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="&#039;Pose&#039; Delivers A Legendary Series Finale And Glorious Goodbye To Season 3 [RECAP] - Towleroad Gay News" />
<meta property="og:description" content="While the last few episodes of Pose have indulged in a bit of over-the-top wish fulfillment, last night&#039;s two-hour series finale placed the focus squarely" />
<meta property="og:url" content="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" />
<meta property="og:site_name" content="Towleroad Gay News" />
<meta property="article:publisher" content="https://www.facebook.com/towleroad.page" />
<meta property="article:tag" content="television" />
<meta property="article:tag" content="Billy Porter" />
<meta property="article:tag" content="Pose" />
<meta property="article:tag" content="Ryan Murphy" />
<meta property="article:tag" content="Steven Canals" />
<meta property="article:tag" content="tv" />
<meta property="article:tag" content="TV Recap" />
<meta property="article:tag" content="TV Recaps" />
<meta property="article:section" content="towleroad" />
<meta property="og:updated_time" content="2021-06-07T11:04:04-04:00" />
<meta property="fb:app_id" content="180651805330333" />
<meta property="og:image" content="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg" />
<meta property="og:image:secure_url" content="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="533" />
<meta property="og:image:alt" content="pose" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:title" content="&#039;Pose&#039; Delivers A Legendary Series Finale And Glorious Goodbye To Season 3 [RECAP] - Towleroad Gay News" />
<meta name="twitter:description" content="While the last few episodes of Pose have indulged in a bit of over-the-top wish fulfillment, last night&#039;s two-hour series finale placed the focus squarely" />
<meta name="twitter:site" content="@tlrd" />
<meta name="twitter:creator" content="@tlrd" />
<meta name="twitter:image" content="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg" />
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.towleroad.com/#organization","name":"Towleroad","logo":{"@type":"ImageObject","@id":"https://www.towleroad.com/#logo","url":"http://towleroad.com/wp-content/uploads/2015/06/600x600_T.jpg","caption":"Towleroad","inLanguage":"en-US"}},{"@type":"WebSite","@id":"https://www.towleroad.com/#website","url":"https://www.towleroad.com","name":"Towleroad","publisher":{"@id":"https://www.towleroad.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg","url":"https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg","width":"200","height":"200","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.towleroad.com/author/bobby-hankinson/","name":"Bobby Hankinson","url":"https://www.towleroad.com/author/bobby-hankinson/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/1a7f04222dd727d24dc016df1b353ace?s=96&amp;d=mm&amp;r=pg","url":"https://secure.gravatar.com/avatar/1a7f04222dd727d24dc016df1b353ace?s=96&amp;d=mm&amp;r=pg","caption":"Bobby Hankinson","inLanguage":"en-US"},"worksFor":{"@id":"https://www.towleroad.com/#organization"}},{"@type":"WebPage","@id":"https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/#webpage","url":"https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/","name":"&#039;Pose&#039; Delivers A Legendary Series Finale And Glorious Goodbye To Season 3 [RECAP] - Towleroad Gay News","datePublished":"2021-06-07T11:00:26-04:00","dateModified":"2021-06-07T11:04:04-04:00","author":{"@id":"https://www.towleroad.com/author/bobby-hankinson/"},"isPartOf":{"@id":"https://www.towleroad.com/#website"},"primaryImageOfPage":{"@id":"https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"&#039;Pose&#039; Delivers A Legendary Series Finale And Glorious Goodbye To Season 3 [RECAP] - Towleroad Gay","keywords":"pose","datePublished":"2021-06-07T11:00:26-04:00","dateModified":"2021-06-07T11:04:04-04:00","author":{"@type":"Person","name":"Bobby Hankinson"},"publisher":{"@id":"https://www.towleroad.com/#organization"},"description":"While the last few episodes of Pose have indulged in a bit of over-the-top wish fulfillment, last night&#039;s two-hour series finale placed the focus squarely","copyrightYear":"2021","copyrightHolder":{"@id":"https://www.towleroad.com/#organization"},"name":"&#039;Pose&#039; Delivers A Legendary Series Finale And Glorious Goodbye To Season 3 [RECAP] - Towleroad Gay","@id":"https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/#richSnippet","isPartOf":{"@id":"https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/#webpage"},"image":{"@id":"https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Towleroad Gay News &raquo; Feed" href="https://www.towleroad.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad Gay News &raquo; Comments Feed" href="https://www.towleroad.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad Gay News &raquo; &#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP] Comments Feed" href="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.towleroad.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
			advanced_ads_ready=function(){var e,t=[],n="object"==typeof document&&document,d=n&&n.documentElement.doScroll,o="DOMContentLoaded",a=n&&(d?/^loaded|^c/:/^loaded|^i|^c/).test(n.readyState);return!a&&n&&(e=function(){for(n.removeEventListener(o,e),window.removeEventListener("load",e),a=1;e=t.shift();)e()},n.addEventListener(o,e),window.addEventListener("load",e)),function(e){a?setTimeout(e,0):t.push(e)}}();		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='genesis-blocks-fontawesome-css' href='https://www.towleroad.com/wp-content/plugins/genesis-blocks/dist/assets/fontawesome/css/all.min.css?ver=1622181529' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-plugin-css-css' href='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/css/share.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-genericons-css-css' href='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/css/genericons.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='news-pro-css' href='https://www.towleroad.com/wp-content/themes/news-pro/style.css?ver=3.2.2' type='text/css' media='all' />
<style id='news-pro-inline-css' type='text/css'>


		a,
		.entry-title a:focus,
		.entry-title a:hover {
			color: #0066cc;
		}

		@media only screen and ( max-width: 1023px ) {
			.genesis-responsive-menu .genesis-nav-menu a:focus,
			.genesis-responsive-menu .genesis-nav-menu a:hover,
			.genesis-responsive-menu .genesis-nav-menu .menu-item.current-menu-item > a,
			.menu-toggle:focus,
			.menu-toggle:hover,
			.sub-menu-toggle:focus,
			.sub-menu-toggle:hover {
				color: #0066cc;
			}
		}

		
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.towleroad.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='genesis-blocks-style-css-css' href='https://www.towleroad.com/wp-content/plugins/genesis-blocks/dist/blocks.style.build.css?ver=1622181529' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.towleroad.com/wp-includes/css/dashicons.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='google-fonts-css' href='//fonts.googleapis.com/css?family=Raleway%3A400%2C700&#038;ver=3.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css' href='https://www.towleroad.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.8' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css' href='https://www.towleroad.com/wp-content/plugins/genesis-tabs/assets/css/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0' id='genesis-simple-share-plugin-js-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/waypoints.min.js?ver=0.1.0' id='genesis-simple-share-waypoint-js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.25.0' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.1' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.11.0' id='advanced_ads_pro/visitor_conditions-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.11.0' id='advanced-ds-pro/front-js'></script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.11.0' id='advanced-ads-pro/cache_busting-js'></script>
<link rel="https://api.w.org/" href="https://www.towleroad.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.towleroad.com/wp-json/wp/v2/posts/457930" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.towleroad.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.towleroad.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://www.towleroad.com/?p=457930' />
<link rel="alternate" type="application/json+oembed" href="https://www.towleroad.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.towleroad.com%2F2021%2F06%2Fpose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.towleroad.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.towleroad.com%2F2021%2F06%2Fpose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap%2F&#038;format=xml" />
<meta name="pubexchange:title" content="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]">
<script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="towlelayer-custom-css"></style><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel="pingback" href="https://www.towleroad.com/xmlrpc.php" />
<script src="https://cdn.blueconic.net/brdblstcrp.js"></script>
<meta property=\"fb:pages\" content=\"13794040506\" />
<meta name="ahrefs-site-verification" content="3782df24765053415a4bf79b1904e680f3900df45eba4f6b2a18863303be0285">
<script type="text/javascript" src="//s.skimresources.com/js/92217X1546135.skimlinks.js"></script>
<style type="text/css">.site-title a { background: url(https://www.towleroad.com/wp-content/uploads/2018/11/logo4.png) no-repeat !important; }</style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TBJM');</script>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<script type="text/javascript">
			if ( typeof advadsGATracking === 'undefined' ) {
				window.advadsGATracking = {
					delayedAds: {},
					deferedAds: {}
				};
			}
		</script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>


<script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
	googletag.cmd.push(function() {
		 var mapboard2 =  googletag.sizeMapping().
                addSize([1023, 1],  [[728, 90], [970, 90], [970, 250]]).
            	addSize([767, 1], [728, 90]).
            	addSize([400, 1], [[320, 50], [320, 100]]).
            	build();
    	var mapboard1 =  googletag.sizeMapping().
                addSize([1023, 1],  [[728, 90], [970, 90], [970, 250]]).
            	addSize([767, 1], [728, 90]).
            	addSize([400, 1], [[320, 50], [320, 100]]).
            	build();
        var maprec1 = googletag.sizeMapping().
            	addSize([1023, 1], [[300, 250], [336, 280]]).
            	addSize([980, 1],  [[300, 250], [336, 280]]).
            	addSize([800, 1],  [[300, 250], [336, 280]]).
            	addSize([300, 1],  [[300, 250], [320, 100], [320, 50], [300, 50]]).
            	build();
        var maprec2 = googletag.sizeMapping().
                addSize([1023, 1], [[300, 250], [336, 280]]).
                addSize([980, 1],  [[300, 250], [336, 280]]).
                addSize([800, 1],  [[300, 250], [336, 280]]).
                addSize([300, 1],  [[300, 250], [320, 100], [320, 50], [300, 50]]).
                build();
        var maprec3 = googletag.sizeMapping().
                addSize([1023, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([980, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([800, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([740, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([640, 1], [[300, 600], [300, 250],[160, 600]]).
                addSize([300, 1],  [[300, 250], [300, 600], [160,600], [320, 100], [320, 50], [300, 50]]).
              addSize([0, 0], []).
                build();
    	var maprec4 = googletag.sizeMapping().
            	addSize([1023, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([980, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([800, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([740, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([640, 1], [[300, 600], [300, 250],[160, 600]]).
             addSize([300, 1],  [[300, 250], [300, 600], [160,600], [320, 100], [320, 50], [300, 50]]).
              addSize([0, 0], []).
            	build();
       
		googletag.defineSlot('/1026291/01_tlrd_board_2', ['fluid', [320, 50]], 'leader2').defineSizeMapping(mapboard2).addService(googletag.pubads());
      	googletag.defineSlot('/1026291/01_tlrd_board_1', ['fluid', [320, 50]], 'leader1').defineSizeMapping(mapboard1).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_1', ['fluid', [300, 250]], 'rec1').defineSizeMapping(maprec1).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_2', ['fluid', [300, 250]], 'rec2').defineSizeMapping(maprec2).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_3', ['fluid', [300, 250]], 'rec3').defineSizeMapping(maprec3).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_4', ['fluid', [300, 250]], 'rec4').defineSizeMapping(maprec4).addService(googletag.pubads());
      	

      	googletag.pubads().setTargeting('art_title', ['pose-delivers-a-legendary-series-finale']); 
      	googletag.pubads().setTargeting('tag', ['']); 
        googletag.pubads().disableInitialLoad();
   googletag.pubads().enableLazyLoad({fetchMarginPercent: -1});
       	googletag.pubads().enableSingleRequest();
      	googletag.enableServices();
  	});

    </script>

<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID: '5afc5395-1615-42a2-9f3b-57ac2f50f8bd', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
         slotID: 'leader1', //example: 'div-gpt-ad-1475102693815-0'
         slotName: '/1026291/01_tlrd_board_1', //example: '12345/box-1'
         sizes: [[728,90], [320, 50]] //example: [[300,250], [300,600]]
     },
     {
         slotID: 'leader2',
         slotName: '/1026291/01_tlrd_board_2',
         sizes: [[728,90], [320, 50]] 
     },
     {
         slotID: 'rec1', 
         slotName: '/1026291/01_tlrd_rec_1',
         sizes: [[300,250]] 
     },     
     {
         slotID: 'rec2', 
         slotName: '/1026291/01_tlrd_rec_2', 
         sizes: [[300,250]] 
     },     
	 {
         slotID: 'rec3', 
         slotName: '/1026291/01_tlrd_rec_3', 
         sizes: [[160,600], [300,250], [300,600]] 
     },
     {
         slotID: 'rec4', 
         slotName: '/1026291/01_tlrd_rec_4', 
         sizes: [[160,600], [300,250], [300,600]] 
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
        
     });
}); 
</script>
 <style id="uagb-style-conditional-extension">@media (min-width: 1025px){body .uag-hide-desktop.uagb-google-map__wrap,body .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){body .uag-hide-tab.uagb-google-map__wrap,body .uag-hide-tab{display:none}}@media (max-width: 767px){body .uag-hide-mob.uagb-google-map__wrap,body .uag-hide-mob{display:none}}</style>
<link rel="icon" href="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-270x270.jpg" />
<style type="text/css" id="wp-custom-css">
			body {
	color:#333;
}
a.breadcrumb-link {
	color:#ff0000;
}
.breadcrumb {
	padding:0 0 0 10px;
}


.title-area {
	padding-left:10px;
	padding-top:0px;
}
.site-header .wrap {padding:0px;
}
.site-header .widget-area {
	width:50%;
	float:right;
	padding-left:0px;
	padding-right:0px;
	text-align:left;
}
.nav-secondary {
border: 0px solid #e3e3e3;
}
.genesis-nav-menu a {
	border:0px;
padding: 5px 5px;
}
.title-area .wrap{
	padding:1px 0;
}
.title-area {
width:100%;
}
.header-image .site-title a {
	min-height:4.5rem;
	margin-bottom:1.2rem;
}
.site-container-wrap {
	border:0;
	
}
.content {
	padding:10px;
}
.entry {
	padding:10px;
	border-bottom:0px;
	padding-bottom:1rem;;
}
.entry-title {
	margin:1rem 0;
}
.entry-header .entry-meta {
	margin:1.5rem;
}
.entry-footer .entry-meta {
	padding:0px 0px 0px ;
	margin:0px;
}
.after-entry-widget-area li::before, .news-pro-home .content li::before, .sidebar li::before {
	content: "";
}
.footer-widgets-1{
	width:100%;
}
.widget-title{
	margin-bottom:15px;
}
.home-top .widget.ui-tabs .entry h2 a {background-color:rgba(0,0,0,0.4)
}
.sponsthing{
font-size:10px;background-color:#B0C4DE;
}
.artstick .content{
width:95%;
	float:left;
}
.artstick  .sidebar-primary { 
display: none;
}

/* Previous and next single post navigation links */
.adjacent-entry-pagination {
 background: none;
 border-bottom: 3px solid #ddd;
 border-top: 0px solid #ddd;
 margin: 2rem 0;
 padding: 2rem 0;
}
.single .pagination-next,
.single .pagination-previous {
 font-size: 1.5rem;
 font-weight: 900;
 padding: 1.5rem .5rem;
 width: 45%;
}
.adjacent-entry-pagination .pagination-previous {
 float: left;
 padding-right: 1.5rem;
}
.adjacent-entry-pagination .pagination-next {
 float: right;
 padding-left: 1.5rem;
}
.home .entry-footer{
	display:none;
}
.home .archive-pagination {font-size:2rem;
}
.pagination-previous {
	border:black;
	border-style:solid;
	border-width:.05px;
	background-color:yellow;
}
.pagination-next {
		border:black;
	border-style:solid;
		border-width:.05px;
	background-color:yellow;
}

.more-link {font-weight:bolder;
	font-size:85%;
}
.home-top {margin-bottom:;
} 

.search-form-input{
	padding:5px;
}


.contestsub {
color:red;
}
.hacks19 {
font-size:3rem;
	margin:3rem;
	
}

.content-tweet{
	font-size:.9rem;
}

.advads-close-button{
   transform: scale(1.5);
	color:lightpink;
}
.alignright {
float:right;
text-align:right;
	font-size:1.2px;
}


.site-footer {
	margin-top:100px;
}

.entry-meta {
	width:500px%;
}
h1.entry-title {
	font-size:3rem;
		line-height:1.2em;
}
h2.entry-title {
	font-size:2.4rem;
	line-height:1.3em;
}
a.post-page-numbers {
	padding: 0px 4px;
font-size:2.5rem;
	border-width:.5px;
	border-style:solid;
	display:inline-block;
 font-family:'Roboto',sans-serif;
	background-color:beige ;
 font-weight:600;
 transition: all 0.2s;
}

	
#lightningblock {

	background-color:lemonchiffon;
}



.entry-pagination  {
	font-size: 3rem;
	margin-bottom:3Rem;
}


@media screen and (min-width: 992px) {
#leader2 {
	min-width:320px%;
	background-color:none;
min-height: 100px;		
  }
	#rec1 {
		min-height: 336px;
	}
		#rec2{
		min-height: 336px;
	}
	#leader1{
		min-height: 250px;
	}

}

@media screen and (max-width: 992px)   {
  .mystickyad {
    min-height: 100px;
		min-width:729px;
		background-color: rgba(255, 99, 71, 0.3);
	}
 	#leader1 {
    min-height: 100px;
  }
}


@media screen and (max-width: 600px) {
	#leader1{
		min-height: 1px
	}
	#rec4 {
		min-height: 250px;
	}
	.mystickyad {
    min-height: 100px;
		background-color: none;
			}
}
		</style>
</head>
<body class="post-template-default single single-post postid-457930 single-format-standard custom-background custom-header header-image content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden aa-prefix-towle" itemscope itemtype="https://schema.org/WebPage"><script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '180651805330333',
      cookie     : true,
      xfbml      : true,
      version    : '{api-version}'
    });
      
    FB.AppEvents.logPageView();   
      
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "https://connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<script type='text/javascript'>
    (function() {
        /** CONFIGURATION START **/
        var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
        _sf_async_config.uid = 551; //CHANGE THIS TO YOUR ACCOUNT ID
        _sf_async_config.domain = 'towleroad.com'; //CHANGE THIS TO YOUR SITE ID
        _sf_async_config.useCanonical = true;
        _sf_async_config.useCanonicalDomain = true;
        _sf_async_config.sections = ''; //SET PAGE SECTION(S)
        _sf_async_config.authors = ''; //SET PAGE AUTHOR(S)
        /** CONFIGURATION END **/
        function loadChartbeat() {
            var e = document.createElement('script');
            var n = document.getElementsByTagName('script')[0];
            e.type = 'text/javascript';
            e.async = true;
            e.src = '//static.chartbeat.com/js/chartbeat.js';
            n.parentNode.insertBefore(e, n);
        }
        loadChartbeat();
     })();
</script>

<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TBJM"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="site-container-wrap"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-about" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-219388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="https://www.towleroad.com/contact/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-219196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="https://www.towleroad.com/contact/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-219193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="https://www.towleroad.com/about-us/" itemprop="url"><span itemprop="name">About Towleroad</span></a></li>
<li id="menu-item-219443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="https://www.towleroad.com/towleroad-social-media/" itemprop="url"><span itemprop="name">Towleroad on Social Media</span></a></li>
<li id="menu-item-219194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="https://www.towleroad.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
<li class="right search"><form class="search-form" method="get" action="https://www.towleroad.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.towleroad.com/?s={s}" itemprop="target"></form></li></ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.towleroad.com/">Towleroad Gay News</a></p><div class="towlegenesis-banner-1 towletarget" id="towle1245085241" data-advadstrackid="449800" data-advadstrackbid="1" data-advadsredirect=""><div id="leader1" style="width:100%;float:left;display:block;margin-bottom:10px;">
</div>
</div><p class="site-description" itemprop="description">Gay Blog Towleroad: More than gay news | gay men</p></div><nav class="nav-header" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-primary" class="menu genesis-nav-menu menu-header js-superfish"><li id="menu-item-364955" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-364955"><a href="https://www.towleroad.com/tag/body-conscious/" itemprop="url"><span itemprop="name">Body</span></a></li>
<li id="menu-item-337715" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-337715"><a href="https://www.towleroad.com/tag/daily-resist/" itemprop="url"><span itemprop="name">Daily Resist</span></a></li>
<li id="menu-item-227804" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227804"><a href="https://www.towleroad.com/tag/politics/" itemprop="url"><span itemprop="name">POLITICS</span></a></li>
<li id="menu-item-227806" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227806"><a href="https://www.towleroad.com/tag/travel/" itemprop="url"><span itemprop="name">Travel</span></a></li>
<li id="menu-item-227809" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227809"><a href="https://www.towleroad.com/tag/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
<li id="menu-item-227807" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227807"><a href="https://www.towleroad.com/tag/theatre/" itemprop="url"><span itemprop="name">Theatre</span></a></li>
<li id="menu-item-227721" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227721"><a href="https://www.towleroad.com/tag/film/" itemprop="url"><span itemprop="name">Film</span></a></li>
<li id="menu-item-227808" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227808"><a href="https://www.towleroad.com/tag/television/" itemprop="url"><span itemprop="name">TV</span></a></li>
<li id="menu-item-270521" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-270521"><a href="https://www.towleroad.com/tag/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
</ul></nav></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-secondary" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-303865" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-303865"><a href="https://www.towleroad.com/tag/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
<li id="menu-item-276395" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-276395"><a href="https://www.towleroad.com/tag/men/" itemprop="url"><span itemprop="name">Men</span></a></li>
<li id="menu-item-227801" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227801"><a href="https://www.towleroad.com/tag/gay-marriage/" itemprop="url"><span itemprop="name">Marriage Equality</span></a></li>
<li id="menu-item-275223" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-275223"><a href="https://www.towleroad.com/tag/space/" itemprop="url"><span itemprop="name">Space</span></a></li>
<li id="menu-item-227820" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227820"><a href="https://www.towleroad.com/tag/transgender/" itemprop="url"><span itemprop="name">Trans Rights</span></a></li>
<li id="menu-item-227817" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227817"><a href="https://www.towleroad.com/tag/books/" itemprop="url"><span itemprop="name">Books</span></a></li>
<li id="menu-item-241504" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-241504"><a href="https://www.towleroad.com/tag/science/" itemprop="url"><span itemprop="name">Science</span></a></li>
<li id="menu-item-227819" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227819"><a href="https://www.towleroad.com/tag/gay-iconography/" itemprop="url"><span itemprop="name">Gay Iconography</span></a></li>
<li id="menu-item-227863" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227863"><a href="https://www.towleroad.com/tag/towleread/" itemprop="url"><span itemprop="name">TowleREAD</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-457930 post type-post status-publish format-standard category-towleroad tag-television tag-billy-porter tag-pose tag-ryan-murphy tag-steven-canals tag-tv tag-tv-recap tag-tv-recaps entry" aria-label="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]</h1>
<p class="entry-meta"><span class="alignleft info-left"><div class="share-entry-meta share-filled share-medium" id="share-entry-meta-457930"><div class="facebook" id="facebook-entry-meta-457930" data-url="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" data-urlalt="https://www.towleroad.com/?p=457930" data-text="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-entry-meta-457930" data-url="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" data-urlalt="https://www.towleroad.com/?p=457930" data-text="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="linkedin" id="linkedin-entry-meta-457930" data-url="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" data-urlalt="https://www.towleroad.com/?p=457930" data-text="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" data-title="Share" data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div></div>
<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#facebook-entry-meta-457930').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-entry-meta-457930').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  twitter: { via: 'tlrd' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#linkedin-entry-meta-457930').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});

				});
		</script></span><span class="alignright info-right"><span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.towleroad.com/author/bobby-hankinson/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Bobby Hankinson</span></a></span> <time class="entry-time" itemprop="datePublished" datetime="2021-06-07T11:00:26-04:00">June 7, 2021</time> <span class="entry-comments-link"><a href="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/#respond"><span class="dsq-postid" data-dsqidentifier="457930 https://www.towleroad.com/?p=457930">Leave a Comment</span></a></span> </span></p></header><div class="entry-content" itemprop="text">
<figure class="wp-block-image size-large"><img loading="lazy" width="800" height="533" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg" alt="Billy Porter as Pray Tell and Mj Rodriguez as Blanca slayed another performance on Pose. Eric Liebowitz/FX" class="wp-image-457933 jetpack-lazy-image" data-lazy-srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg 800w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r-300x200.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r-768x512.jpg 768w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r-600x400.jpg 600w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" width="800" height="533" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg" alt="Billy Porter as Pray Tell and Mj Rodriguez as Blanca slayed another performance on Pose. Eric Liebowitz/FX" class="wp-image-457933" srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r.jpg 800w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r-300x200.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r-768x512.jpg 768w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_1589r-600x400.jpg 600w" sizes="(max-width: 800px) 100vw, 800px" /></noscript><figcaption>Billy Porter as Pray Tell and Mj Rodriguez as Blanca slayed another performance on <em>Pose</em>. Eric Liebowitz/FX</figcaption></figure>
<p>While the last few episodes of <em>Pose</em> have indulged in a bit of <a href="https://www.towleroad.com/2021/05/pose-season-3-episode-5-gives-dominique-jacksons-elektra-everything-she-wants-recap/" data-type="post" data-id="456980" class="rank-math-link">over-the-top wish fulfillment</a>, last night&#8217;s two-hour series finale placed the focus squarely back on reality. The result was a triumphant, defiant tribute to the entire queer community.</p><div class="towlefirstpost-injection towletarget" id="towle1746096626" data-advadstrackid="449824" data-advadstrackbid="1" data-advadsredirect="">
<div id='rec1'>
</div>
</div>
<p>The writers had an ambitious agenda of topics and historical markers to address &#8212; drug trials, racial inequity in healthcare, ACT UP &#8212; and that&#8217;s before weaving narrative threads through yet another time jump into 1998.</p>
<p>Like the rest of the abbreviated final season, last night&#8217;s finale ripped through story beats at a dizzying pace. The first half in particular had Pray Tell at death&#8217;s door to leading protests to the Mayor&#8217;s door in what felt like a blink of an eye. However, if pacing was the price for so many powerful homages to queer history, it was well worth the narrative whiplash.</p>
<p>Maybe it&#8217;s hitting different because we&#8217;re still processing our most recent viral pandemic that in many ways threw the devastating mishandling of HIV/AIDS into even starker contrast. Scenes of healthcare protests and police violence have newfound resonance after the last 18 months. Or, maybe the reminder of a generation of lost friends, and the friends we never got to make, feels particularly acute during Pride month. Whatever the reason, the result is a now iconic installment of emotionally-gripping TV that begs for a rewatch.</p>
<p>Free from <a href="https://www.towleroad.com/2021/05/pose-treats-its-heroines-to-a-dream-wedding-in-season-3-episode-6-something-borrowed-something-blue-recap/" data-type="post" data-id="457305" class="rank-math-link">fantastically lavish weddings</a> and <a href="https://www.towleroad.com/2021/05/pose-season-3-episode-5-gives-dominique-jacksons-elektra-everything-she-wants-recap/" data-type="post" data-id="456980" class="rank-math-link">organized crime syndicates</a>, <em>Pose</em> was at its very best placing the extraordinary ensemble in context, honoring both story and history better than ever before.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="800" height="533" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r.jpg" alt="Mj Rodriguez as Blanca and Billy Porter as Pray Tell fight for spots in a drug trial on Pose. Eric Liebowitz/FX" class="wp-image-457937 jetpack-lazy-image" data-lazy-srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r.jpg 800w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r-300x200.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r-768x512.jpg 768w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r-600x400.jpg 600w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" width="800" height="533" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r.jpg" alt="Mj Rodriguez as Blanca and Billy Porter as Pray Tell fight for spots in a drug trial on Pose. Eric Liebowitz/FX" class="wp-image-457937" srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r.jpg 800w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r-300x200.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r-768x512.jpg 768w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0083r-600x400.jpg 600w" sizes="(max-width: 800px) 100vw, 800px" /></noscript><figcaption>Mj Rodriguez as Blanca and Billy Porter as Pray Tell fight for spots in a drug trial on <em>Pose</em>. Eric Liebowitz/FX</figcaption></figure>
<p>Beginning with the advent of protease inhibitor and drug cocktails, the episode immediately confronts the racial inequality in these life-saving drug trials, with Blanca, Nurse Judy and the real Dr. McDreamy, Christopher, fighting for a spot for Pray Tell. Of course, for the 80 trial slots, only two were given to people of color. They fight with a hospital bigwig about getting a spot for Pray, but Christopher also demands one for Blanca.</p><div class="towle2nd-post-injection towletarget" id="towle1454048471" data-advadstrackid="449825" data-advadstrackbid="1" data-advadsredirect="">
<div id='rec2'>
</div>
</div>
<p>The episode really highlighted the cruel chance of the virus; why Pray got so sick, but Blanca stayed mostly healthy, or why they would be lucky enough for access to these drugs, while others aren&#8217;t. It brings ACT UP back into the story, but it also allows the show to make a still relevant message about healthcare disparities for communities of color. It&#8217;s a lot of ground to cover quickly, including hesitancy from Blanca and Ricky that reflects the history of abuse and mistrust between black and brown people and the medical community.</p>
<p>The densely packed first hour kept from getting too unmoored thanks to anchoring itself in Blanca and Pray Tell&#8217;s stories. In addition to weaving ACT UP&#8217;s actual history into the plot, there is also an absolutely devastating homage to the San Francisco Gay Men&#8217;s Chorus, inspired by <a href="https://sdlgbtn.com/causes/2017/11/28/picture-1993-reminds-people-loss-life-due-aids" target="_blank" rel="noreferrer noopener" class="rank-math-link">the famous photograph</a>.</p>
<p>When it comes to Pray&#8217;s final farewell, he certainly went out with style. It feels like this whole season has been building toward his death, but a brief, promising recovery (thanks to the drug trials) was a cruel, though fair, bit of bait and switch.</p>
<p>In celebration of their new leases on life, Pray and Blanca&#8217;s lip sync to Diana Ross&#8217;s version of &#8220;Ain&#8217;t No Mountain High Enough&#8221; at the ball. It is hands down one, if not the, best performance number in the show&#8217;s history. There&#8217;s an extra layer of sentimentality, since it&#8217;s the Candy&#8217;s Sweet Refrain category, and the wind and rain elements were absolute showstoppers. Even without the stunts, Mj Rodriguez and Billy Porter are radiant with their chiffongraphy. Between this scene and their season one performance of &#8220;Home,&#8221; can someone please get these two some kind of live variety revue on a streaming service ASAP?!</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="683" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1024x683.jpg" alt="Dyllón Burnside as Ricky and Billy Porter as Pray Tell. Eric Liebowitz/FX" class="wp-image-457938 jetpack-lazy-image" data-lazy-srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1024x683.jpg 1024w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-300x200.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-768x512.jpg 768w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1536x1024.jpg 1536w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-2048x1365.jpg 2048w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-600x400.jpg 600w" data-lazy-sizes="(max-width: 1024px) 100vw, 1024px" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1024x683.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" width="1024" height="683" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1024x683.jpg" alt="Dyllón Burnside as Ricky and Billy Porter as Pray Tell. Eric Liebowitz/FX" class="wp-image-457938" srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1024x683.jpg 1024w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-300x200.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-768x512.jpg 768w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-1536x1024.jpg 1536w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-2048x1365.jpg 2048w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_0905r-600x400.jpg 600w" sizes="(max-width: 1024px) 100vw, 1024px" /></noscript><figcaption>Dyllón Burnside as Ricky and Billy Porter as Pray Tell on <em>Pose</em>. Eric Liebowitz/FX</figcaption></figure>
<p>Of course, Pray&#8217;s final acts were both in service to his community. At its heart, <em>Pose</em> has always been about the resilience, determination and ingenuity of the queer community, specifically the black trans community. So, it doesn&#8217;t take long to piece together how Pray had been giving Ricky the lifesaving drugs he also desperately needed.</p>
<p>Pray&#8217;s final scene, removing his makeup after the performance with Blanca, is perfect. If anyone out there is still not convinced Billy Porter must be in Emmy contention, may I suggest watching what he can do with a jar of cold cream. It&#8217;s simple and beautiful and uncharacteristically restrained for this show.</p>
<p>Although he wasn&#8217;t technically present for his final act, it did feel like something he would proudly have been a part of. Blanca took part of his ashes to the Mayor&#8217;s house, a reference to the real ACT UP Ashes Actions at the White House. Already a devastating sight, hearing the cries for healthcare and witnessing the violent police response may be the series&#8217; greatest time jump of all, connecting the past so distinctly to our present.</p>
<p>Pray&#8217;s ashes were not only destined for the mayor&#8217;s doorstep. In another high-watermark scene, Pray&#8217;s mother arrives at Blanca&#8217;s apartment to deliver the ashes he requested be placed in lockets for loved ones. The moment they share is the ultimate tribute to Pray from the two women in his life that loved him the most.</p>
<p>The second half of the episode took care to resolve any last lingering threads. A time jump to 1998 shows the ladies still thriving. Elektra is somehow even richer, Lulu is a working accountant and Angel is embracing motherhood.</p>
<p>Blanca, however, is shining brightest of all. She&#8217;s married to Christopher, she&#8217;s a full nurse now and she&#8217;s a patient advocate, helping HIV-positive patients get the treatment, resources and support they need. She&#8217;s still doing ballroom, and there&#8217;s a new generation of Evangelistas being raised by Daddy Ricky and Grandmama Blanca. Over a bougie, <em>Sex and the City</em>-style lunch, Blanca invites Lu, Angel and Elektra to the next ball to see the children, but they all dismiss the invite as having outgrown the scene.</p>
<figure class="wp-block-image size-large"><img loading="lazy" width="800" height="603" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r.jpg" alt class="wp-image-457939 jetpack-lazy-image" data-lazy-srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r.jpg 800w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r-300x226.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r-768x579.jpg 768w" data-lazy-sizes="(max-width: 800px) 100vw, 800px" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img loading="lazy" width="800" height="603" src="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r.jpg" alt="" class="wp-image-457939" srcset="https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r.jpg 800w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r-300x226.jpg 300w, https://www.towleroad.com/wp-content/uploads/2021/06/POSE_307_4330r-768x579.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript><figcaption>Mj Rodriguez as Blanca and Dyllón Burnside as Ricky are ready to lead the next generation on <em>Pose</em>. Eric Liebowitz/FX</figcaption></figure>
<p>It&#8217;s another fake-out. At the ball, not only do Blanca and Ricky&#8217;s children slay, but the original Evangelistas make an appearance to honor Blanca with official legendary status. An extremely well-earned accolade, it&#8217;s the perfect bookend for a series that began with Blanca&#8217;s diagnosis and determination to create her legacy. She&#8217;s got new children to care for (including a recently diagnosed patient she recruits to the Evangelistas). She&#8217;s offering the same sage advice Pray once offered her as she struggled to get her house off the ground. Now, she is a pillar of the community, and her legacy has long been secured.</p>
<p>This is not the happy ending she &#8212; nor any of us &#8212; expected, and that&#8217;s what make it so much sweeter.</p>
<p>The legacy of <em>Pose</em> feels equally established. It&#8217;s a vital time capsule, telling a rarely told story about some of the most incredible (and often overlooked) members of the queer community. It&#8217;s a radical piece of art created by brilliant minds like Steven Canals, Janet Mock, Our Lady J and (although we may rag on him at times) Ryan Murphy. It&#8217;s a love letter to a community, from that community. There has never been anything like it before, but I hope more than anything it is not the last.</p>
<p><em>Pose</em> broke multiple boundaries in front of and behind the camera. There are so many more stories waiting to be told, and now we no longer need to wonder what&#8217;s possible when people are given the opportunity to tell their own story. The only question remaining is will those in power continue to make space for these stories, and, really, will we, as audiences, refuse to accept anything less?</p>
<p>Furthermore, we better start seeing these actors everywhere. I mean it. This is one of the strongest ensembles ever on television, and most are just getting started in their careers. Cast them in indie features. Cast them in broad, multi-cam comedies. Put them in your streaming mumblecore dramedy. Make them Marvel superheroes! The talent here is just too immense to only be contained to this one (albeit fantastic) series.</p>
<p>For all its incredible history, emotionally devastating plot lines and enchanting performances, perhaps <em>Pose</em>&#8216;s greatest achievement will be the stories yet to be told. </p>
<p>What did you think of the series finale? Tell us in the comments.</p>
<h2><strong><a href="https://www.towleroad.com/tag/pose/"><em>Pose</em></a> Previously on Towleroad</strong></h2>
<div class="share-after share-filled share-medium" id="share-after-457930"><div class="facebook" id="facebook-after-457930" data-url="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" data-urlalt="https://www.towleroad.com/?p=457930" data-text="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-after-457930" data-url="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" data-urlalt="https://www.towleroad.com/?p=457930" data-text="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="linkedin" id="linkedin-after-457930" data-url="https://www.towleroad.com/2021/06/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap/" data-urlalt="https://www.towleroad.com/?p=457930" data-text="&#8216;Pose&#8217; Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]" data-title="Share" data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div></div>
<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#facebook-after-457930').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-after-457930').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  twitter: { via: 'tlrd' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#linkedin-after-457930').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});

				});
		</script>
</div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.towleroad.com/category/towleroad/" rel="category tag">towleroad</a></span> <span class="entry-tags">Tagged With: <a href="https://www.towleroad.com/tag/television/" rel="tag">television</a>, <a href="https://www.towleroad.com/tag/billy-porter/" rel="tag">Billy Porter</a>, <a href="https://www.towleroad.com/tag/pose/" rel="tag">Pose</a>, <a href="https://www.towleroad.com/tag/ryan-murphy/" rel="tag">Ryan Murphy</a>, <a href="https://www.towleroad.com/tag/steven-canals/" rel="tag">Steven Canals</a>, <a href="https://www.towleroad.com/tag/tv/" rel="tag">tv</a>, <a href="https://www.towleroad.com/tag/tv-recap/" rel="tag">TV Recap</a>, <a href="https://www.towleroad.com/tag/tv-recaps/" rel="tag">TV Recaps</a></span></p></footer></article><div class="after-entry widget-area"><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 2rem;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 2rem;
}

.rpwe-time{
color: #bbb;
font-size: 1.5rem;
}

.rpwe-comment{
color: #bbb;
font-size: 1.5rem;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><section id="rpwe_widget-6" class="widget rpwe_widget recent-posts-extended"><div class="widget-wrap"><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/pentagon-not-allow/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/457874-origin_1-300x75.jpg" alt="Pentagon not to allow pride flags to be flown on installations"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pentagon-not-allow/" title="Permalink to Pentagon not to allow pride flags to be flown on installations" rel="bookmark">Pentagon not to allow pride flags to be flown on installations</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/pinkwashing-allies-pride/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Screen-Shot-2021-06-06-at-4.33.11-PM-300x75.png" alt="For Pride, Split Valuable Allies from Corporate Pandering  and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pinkwashing-allies-pride/" title="Permalink to For Pride, Split Valuable Allies from Corporate Pandering  and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?" rel="bookmark">For Pride, Split Valuable Allies from Corporate Pandering and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?</a></h3></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/marilyn-monroes-cookbooks/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/457880-origin_1-300x75.jpg" alt="Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/marilyn-monroes-cookbooks/" title="Permalink to Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000" rel="bookmark">Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000</a></h3></li></ul></div></div></section>
<section id="custom_html-43" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><div class="textwidget custom-html-widget"><div class="pubexchange_module" id="pubexchange_below_content_1" data-pubexchange-module-id="1851"></div></div></div></section>
</div><div class="adjacent-entry-pagination pagination"><div class="pagination-previous alignleft"><a href="https://www.towleroad.com/2021/06/pinkwashing-allies-pride/" rel="prev"><span class="screen-reader-text">Previous Post: </span><span class="adjacent-post-link">&#xAB; For Pride, Split Valuable Allies from Corporate Pandering and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?</span></a></div><div class="pagination-next alignright"><a href="https://www.towleroad.com/2021/06/pentagon-not-allow/" rel="next"><span class="screen-reader-text">Next Post: </span><span class="adjacent-post-link">Pentagon not to allow pride flags to be flown on installations &#xBB;</span></a></div></div>
<div id="disqus_thread"></div>
</main><div class="towlemobilerec4 towletarget" id="towle2063160489" data-advadstrackid="449835" data-advadstrackbid="1" data-advadsredirect=""><div id="rec4" style="width:100%;text-align:center;">
</div></div><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.towleroad.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-2">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-2" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.towleroad.com/?s={s}" itemprop="target"></form></div></section>
<style>
		.rpwe-block ul {
			list-style: none !important;
			margin-left: 0 !important;
			padding-left: 0 !important;
		}

		.rpwe-block li {
			border-bottom: 1px solid #eee;
			margin-bottom: 10px;
			padding-bottom: 10px;
			list-style-type: none;
		}

		.rpwe-block a {
			display: inline !important;
			text-decoration: none;
		}

		.rpwe-block h3 {
			background: none !important;
			clear: none;
			margin-bottom: 0 !important;
			margin-top: 0 !important;
			font-weight: 400;
			font-size: 12px !important;
			line-height: 1.5em;
		}

		.rpwe-thumb {
			border: 1px solid #EEE !important;
			box-shadow: none !important;
			margin: 2px 10px 2px 0;
			padding: 3px !important;
		}

		.rpwe-summary {
			font-size: 12px;
		}

		.rpwe-time {
			color: #bbb;
			font-size: 11px;
		}

		.rpwe-comment {
			color: #bbb;
			font-size: 11px;
			padding-left: 5px;
		}

		.rpwe-alignleft {
			display: inline;
			float: left;
		}

		.rpwe-alignright {
			display: inline;
			float: right;
		}

		.rpwe-aligncenter {
			display: block;
			margin-left: auto;
			margin-right: auto;
		}

		.rpwe-clearfix:before,
		.rpwe-clearfix:after {
			content: "";
			display: table !important;
		}

		.rpwe-clearfix:after {
			clear: both;
		}

		.rpwe-clearfix {
			zoom: 1;
		}
	</style>
<section id="rpwe_widget-10" class="widget rpwe_widget recent-posts-extended"><div class="widget-wrap"><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pentagon-not-allow/" title="Permalink to Pentagon not to allow pride flags to be flown on installations" rel="bookmark">Pentagon not to allow pride flags to be flown on installations</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pinkwashing-allies-pride/" title="Permalink to For Pride, Split Valuable Allies from Corporate Pandering  and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?" rel="bookmark">For Pride, Split Valuable Allies from Corporate Pandering and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/marilyn-monroes-cookbooks/" title="Permalink to Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000" rel="bookmark">Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000</a></h3></li></ul></div></div></section>
<section class="widget towlewidget"><div class="widget-wrap"><div class="towlewidgetsiderec3 towletarget" id="towle2127141355" data-advadstrackid="449827" data-advadstrackbid="1" data-advadsredirect=""><div id="rec3" style="width:100%;text-align:center;">
</div></div></div></section>
<style>
		.rpwe-block ul {
			list-style: none !important;
			margin-left: 0 !important;
			padding-left: 0 !important;
		}

		.rpwe-block li {
			border-bottom: 1px solid #eee;
			margin-bottom: 10px;
			padding-bottom: 10px;
			list-style-type: none;
		}

		.rpwe-block a {
			display: inline !important;
			text-decoration: none;
		}

		.rpwe-block h3 {
			background: none !important;
			clear: none;
			margin-bottom: 0 !important;
			margin-top: 0 !important;
			font-weight: 400;
			font-size: 12px !important;
			line-height: 1.5em;
		}

		.rpwe-thumb {
			border: 1px solid #EEE !important;
			box-shadow: none !important;
			margin: 2px 10px 2px 0;
			padding: 3px !important;
		}

		.rpwe-summary {
			font-size: 12px;
		}

		.rpwe-time {
			color: #bbb;
			font-size: 11px;
		}

		.rpwe-comment {
			color: #bbb;
			font-size: 11px;
			padding-left: 5px;
		}

		.rpwe-alignleft {
			display: inline;
			float: left;
		}

		.rpwe-alignright {
			display: inline;
			float: right;
		}

		.rpwe-aligncenter {
			display: block;
			margin-left: auto;
			margin-right: auto;
		}

		.rpwe-clearfix:before,
		.rpwe-clearfix:after {
			content: "";
			display: table !important;
		}

		.rpwe-clearfix:after {
			clear: both;
		}

		.rpwe-clearfix {
			zoom: 1;
		}
	</style>
<section id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><div class="widget-wrap"><h3 class="widgettitle widget-title">Recent Posts</h3>
<div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/pentagon-not-allow/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/457874-origin_1-90x90.jpg" alt="Pentagon not to allow pride flags to be flown on installations"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pentagon-not-allow/" title="Permalink to Pentagon not to allow pride flags to be flown on installations" rel="bookmark">Pentagon not to allow pride flags to be flown on installations</a></h3><time class="rpwe-time published" datetime="2021-06-07T11:45:39-04:00">1 hour ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/pinkwashing-allies-pride/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Screen-Shot-2021-06-06-at-4.33.11-PM-90x90.png" alt="For Pride, Split Valuable Allies from Corporate Pandering  and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pinkwashing-allies-pride/" title="Permalink to For Pride, Split Valuable Allies from Corporate Pandering  and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?" rel="bookmark">For Pride, Split Valuable Allies from Corporate Pandering and &#8216;pinkwashing&#8217; , Researcher Says. What Do You Think?</a></h3><time class="rpwe-time published" datetime="2021-06-06T16:36:31-04:00">20 hours ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/marilyn-monroes-cookbooks/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/457880-origin_1-90x90.jpg" alt="Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/marilyn-monroes-cookbooks/" title="Permalink to Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000" rel="bookmark">Marilyn Monroe&#8217;s cookbooks to be auctioned off for $75,000</a></h3><time class="rpwe-time published" datetime="2021-06-05T16:36:26-04:00">2 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/lesbian-bars/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/457707-origin_1-90x90.jpg" alt="Personhood is Powerful. Lesbian Bars Adjust, Ask, Include&#8211;And Rebrand to Match:&#8217;Queer Human Bar Built by Lesbians&#8217;"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/lesbian-bars/" title="Permalink to Personhood is Powerful. Lesbian Bars Adjust, Ask, Include&#8211;And Rebrand to Match:&#8217;Queer Human Bar Built by Lesbians&#8217;" rel="bookmark">Personhood is Powerful. Lesbian Bars Adjust, Ask, Include&#8211;And Rebrand to Match:&#8217;Queer Human Bar Built by Lesbians&#8217;</a></h3><time class="rpwe-time published" datetime="2021-06-05T13:38:34-04:00">2 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/dc-doug-emhoff-chasten-buttigieg/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Buttigieg-90x90.jpg" alt="Chasten, Emhoff Take DC. Second Gent Pushes Vaccine on Pride Lap of Gay Bars. Chasten Owns RNC Chair, Leaves Her Own Platform as Receipt."></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/dc-doug-emhoff-chasten-buttigieg/" title="Permalink to Chasten, Emhoff Take DC. Second Gent Pushes Vaccine on Pride Lap of Gay Bars. Chasten Owns RNC Chair, Leaves Her Own Platform as Receipt." rel="bookmark">Chasten, Emhoff Take DC. Second Gent Pushes Vaccine on Pride Lap of Gay Bars. Chasten Owns RNC Chair, Leaves Her Own Platform as Receipt.</a></h3><time class="rpwe-time published" datetime="2021-06-04T17:59:34-04:00">3 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/born-this-way-another-way/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Screen-Shot-2021-06-04-at-2.49.53-PM-90x90.png" alt="&#8216;Born This Way&#8217; Turns 10 And Reveals There Is, In Fact, an &#8216;Other Way;&#8217; And It&#8217;s Great! LISTEN. PLUS: Indya is Marcia P; Chastain Plays Tammy Faye: HOT LINKS"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/born-this-way-another-way/" title="Permalink to &#8216;Born This Way&#8217; Turns 10 And Reveals There Is, In Fact, an &#8216;Other Way;&#8217; And It&#8217;s Great! LISTEN. PLUS: Indya is Marcia P; Chastain Plays Tammy Faye: HOT LINKS" rel="bookmark">&#8216;Born This Way&#8217; Turns 10 And Reveals There Is, In Fact, an &#8216;Other Way;&#8217; And It&#8217;s Great! LISTEN. PLUS: Indya is Marcia P; Chastain Plays Tammy Faye: HOT LINKS</a></h3><time class="rpwe-time published" datetime="2021-06-04T16:06:34-04:00">3 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/ron-desantis-pulse-trans-ban/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Screen-Shot-2021-06-04-at-3.06.53-PM-90x90.png" alt="Ron DeSantis Bans Trans Sports Participation, Vetoes Funds For Pulse Survivor Treatment  As Pride Month and 2024 Election Cycle Begins"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/ron-desantis-pulse-trans-ban/" title="Permalink to Ron DeSantis Bans Trans Sports Participation, Vetoes Funds For Pulse Survivor Treatment  As Pride Month and 2024 Election Cycle Begins" rel="bookmark">Ron DeSantis Bans Trans Sports Participation, Vetoes Funds For Pulse Survivor Treatment As Pride Month and 2024 Election Cycle Begins</a></h3><time class="rpwe-time published" datetime="2021-06-04T15:08:19-04:00">3 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/pride-flag-ban/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Pride-Flag-Capitol-90x90.jpg" alt="Longshot LGBTQ Pride Flag Ban Gains GOP Supporters as President Biden Acknowledges Pride Month"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/pride-flag-ban/" title="Permalink to Longshot LGBTQ Pride Flag Ban Gains GOP Supporters as President Biden Acknowledges Pride Month" rel="bookmark">Longshot LGBTQ Pride Flag Ban Gains GOP Supporters as President Biden Acknowledges Pride Month</a></h3><time class="rpwe-time published" datetime="2021-06-04T10:45:18-04:00">3 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/mexico-117-lgbtq-candidates/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/457721-origin_1-90x90.jpg" alt="117 LGBTQ Candidates  in Mexico Mid-term Elections&#8211; 2 Percent of All Running;  Gay and Trans Candidates in Key Race"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/mexico-117-lgbtq-candidates/" title="Permalink to 117 LGBTQ Candidates  in Mexico Mid-term Elections&#8211; 2 Percent of All Running;  Gay and Trans Candidates in Key Race" rel="bookmark">117 LGBTQ Candidates in Mexico Mid-term Elections&#8211; 2 Percent of All Running; Gay and Trans Candidates in Key Race</a></h3><time class="rpwe-time published" datetime="2021-06-03T14:18:45-04:00">4 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/06/vogueing-colombian-protesters/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/06/Screen-Shot-2021-06-03-at-10.49.47-AM-90x90.png" alt="Vogueing Protesters Use Harlem Ball Moves in Bogota, Make NYTimes.  Can &#8216;Drag Race&#8217; Train Special Forces To Fight Global Fascism?"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/06/vogueing-colombian-protesters/" title="Permalink to Vogueing Protesters Use Harlem Ball Moves in Bogota, Make NYTimes.  Can &#8216;Drag Race&#8217; Train Special Forces To Fight Global Fascism?" rel="bookmark">Vogueing Protesters Use Harlem Ball Moves in Bogota, Make NYTimes. Can &#8216;Drag Race&#8217; Train Special Forces To Fight Global Fascism?</a></h3><time class="rpwe-time published" datetime="2021-06-03T13:50:12-04:00">4 days ago</time></li></ul></div></div></section>
<section id="dpp_widget-2" class="widget widget_dpp_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Most Commented</h3>
<span class="dpp_render_area" id="dpp_render_area-2"></span></div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-about-container"><ul id="menu-footer-about-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="https://www.towleroad.com/contact/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="https://www.towleroad.com/contact/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="https://www.towleroad.com/about-us/" itemprop="url">About Towleroad</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="https://www.towleroad.com/towleroad-social-media/" itemprop="url">Towleroad on Social Media</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="https://www.towleroad.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
<section id="custom_html-41" class="widget_text widget widget_custom_html"><div class="widget_text widget-wrap"><h3 class="widgettitle widget-title">Social</h3>
<div class="textwidget custom-html-widget"><p><a href="https://twitter.com/tlrd" rel="me">Twitter
@tlrd</a></p>
<p><a href="https://facebook.com/towleroad.page" rel="me">Facebook</a></p>
<p><a href="https://instagram.com/tlrd" rel="me">Instagram @tlrd</a></p>
</div></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2021 · <a rel="nofollow" href="https://www.towleroad.com/wp-login.php">Log in</a></p></div></footer><div class="towledisplay-gpt-before-body-end towletarget" id="towle746671175" data-advadstrackid="457469" data-advadstrackbid="1" data-advadsredirect=""><script> 
	    googletag.cmd.push(function(){ googletag.pubads().refresh(); 
			
   
   
    googletag.cmd.push(function() { googletag.display('leader2'); });
	googletag.cmd.push(function() { googletag.display('leader1'); });
    googletag.cmd.push(function() { googletag.display('rec1'); });
    googletag.cmd.push(function() { googletag.display('rec2'); });
    googletag.cmd.push(function() { googletag.display('rec3'); });
    googletag.cmd.push(function() { googletag.display('rec4'); });
	     });


    </script>
</div></div></div><script>
		var advanced_ads_ga_UID = 'UA-2831502-1';
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();</script><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><div class="towlestickybar mystickyad  towlesticky towletarget" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 10px; position: fixed; bottom: 0; z-index: 10000; " id="towle125251358" data-advadstrackid="449785" data-advadstrackbid="1" data-advadsredirect=""><span class="advads-close-button" onclick="void(0)" title="close" style="width: 15px; height: 15px; background: #fff; position: relative; line-height: 15px; text-align: center; cursor: pointer; z-index: 10000;right:-15px;float: right; margin-left: -15px;">×</span>
<div id='leader2'>
</div></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var wrapper_id = "#towle125251358"; var $wrapper = jQuery( wrapper_id );advads.move( wrapper_id, "", {  });window.advanced_ads_sticky_items = window.advanced_ads_sticky_items || {};advanced_ads_sticky_items[ "towle125251358" ] = { "can_convert_to_abs": "1", "initial_css": $wrapper.attr( "style" ), "modifying_func": function() { $wrapper.css({ "-webkit-transform": "translateX(-50%)", "-moz-transform": "translateX(-50%)", "transform": "translateX(-50%)", "left": "50%", "margin-right": "-50%" });jQuery( "#towle125251358" ).on( "click", "span", function() { advads.close( "#towle125251358" ); });}};
if ( advads.wait_for_images ) { 
    var sticky_wait_for_images_time = new Date().getTime();
    $wrapper.data( "sticky_wait_for_images_time", sticky_wait_for_images_time );
    advads.wait_for_images( $wrapper, function() {
        // At the moment when this function is called, it is possible that 
        // the placement has been updated using "Reload ads on resize" feature of Responsive add-on 
        if ( $wrapper.data( "sticky_wait_for_images_time" ) === sticky_wait_for_images_time ) {
            advanced_ads_sticky_items[ "towle125251358" ]["modifying_func"]();
        } 
    } );
} else { 
    advanced_ads_sticky_items[ "towle125251358" ]["modifying_func"]();
};
});</script> <script type="text/javascript">
		function genesisBlocksShare( url, title, w, h ){
			var left = ( window.innerWidth / 2 )-( w / 2 );
			var top  = ( window.innerHeight / 2 )-( h / 2 );
			return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=600, height=600, top='+top+', left='+left);
		}
	</script>
<script type="text/javascript">
  var _sf_async_config = { uid: 551, domain: 'towleroad.com', useCanonical: true };
  (function() {
    function loadChartbeat() {
      window._sf_endpt = (new Date()).getTime();
      var e = document.createElement('script');
      e.setAttribute('language', 'javascript');
      e.setAttribute('type', 'text/javascript');
      e.setAttribute('src','//static.chartbeat.com/js/chartbeat.js');
      document.body.appendChild(e);
    };
    var oldonload = window.onload;
    window.onload = (typeof window.onload != 'function') ?
      loadChartbeat : function() { oldonload(); loadChartbeat(); };
  })();
</script>
<div id="amzn-assoc-ad-1f73a4d8-e2cd-4bbc-a758-192dfc2670f4"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=1f73a4d8-e2cd-4bbc-a758-192dfc2670f4"></script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"NCUJh1awVK000u", domain:"towleroad.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=NCUJh1awVK000u" style="display:none" height="1" width="1" alt="" /></noscript>

<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />

<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />

<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','o4fuy');
twq('track','PageView');
</script>

<script defer src='https://static.cloudflareinsights.com/beacon.min.js' data-cf-beacon='{"token": "c84345d83bbb443197d16b284dcd3bdd"}'></script>
<script>(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"towleroad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.22' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.22"},"disqusIdentifier":"457930 https:\/\/www.towleroad.com\/?p=457930","disqusShortname":"towleroad","disqusTitle":"\u2018Pose\u2019 Delivers a Legendary Series Finale and Glorious Goodbye to Season 3 [RECAP]","disqusUrl":"https:\/\/www.towleroad.com\/2021\/06\/pose-delivers-a-legendary-series-finale-and-glorious-goodbye-to-season-3-recap\/","postId":"457930"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.22' id='disqus_embed-js'></script>
<script type='text/javascript' id='advanced-ads-layer-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"towlelayer","placements":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.7.2' id='advanced-ads-layer-footer-js-js'></script>
<script type='text/javascript' id='advanced-ads-sticky-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"towlesticky","placements":["skin-ads-placed","slides-sticky-side","stickyright-inner","stickybar"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1.8.1' id='advanced-ads-sticky-footer-js-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/genesis-blocks/dist/assets/js/dismiss.js?ver=1622181529' id='genesis-blocks-dismiss-js-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/comment-reply.min.js?ver=5.7.2' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3' id='superfish-args-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/news-pro/js/jquery.matchHeight.min.js?ver=3.2.2' id='news-match-height-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/news-pro/js/global.js?ver=3.2.2' id='news-global-js-js'></script>
<script type='text/javascript' id='news-responsive-menus-js-extra'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-secondary",".nav-primary",".nav-header"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/news-pro/js/responsive-menus.min.js?ver=3.2.2' id='news-responsive-menus-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' id='q2w3_fixed_widget-js-extra'>
/* <![CDATA[ */
var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":10,"margin_bottom":0,"stop_id":"","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["towlewidget-3"]}];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.3.0' id='q2w3_fixed_widget-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"towletarget","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.0.1' id='advadsTrackingScript-js'></script>
<script type='text/javascript' id='advadsTrackingGAFront-js-extra'>
/* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/ga-tracking.min.js?ver=2.0.1' id='advadsTrackingGAFront-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/delayed.min.js?ver=2.0.1' id='advadsTrackingDelayed-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' id='dpp-js-extra'>
/* <![CDATA[ */
var dpp_ajax = {"ajaxurl":"https:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/disqus-popular-posts/dpp.js?ver=5.7.2' id='dpp-js'></script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
<script>window.advads_has_ads = [["450675","ad",null],["449800","ad",null],["449824","ad",null],["449825","ad",null],["449835","ad",null],["449827","ad",null],["457469","ad",null],["449785","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><script>var advads_tracking_ads = {"1":[450675,449800,449824,449825,449835,449827,457469,449785]};var advads_tracking_urls = {"1":"https:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};var advads_tracking_methods = {"1":"ga"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/www.towleroad.com\/linkout\/"};var advads_gatracking_uids = {"1":"UA-2831501-1"};var advads_gatracking_allads = {"1":{"457475":{"title":"image skin","target":"https:\/\/ad.doubleclick.net\/ddm\/jump\/N2436.148384TOWLEROAD\/B25782099.303002599;sz=1x1;ord=[timestamp];gdpr=${GDPR};gdpr_consent=${GDPR_CONSENT_755}?\">","impression":true,"click":true},"457474":{"title":"header code Stripped for Roadblock","target":"","impression":true,"click":true},"457471":{"title":"skin Ads placed","target":"","impression":true,"click":true},"457469":{"title":"Display GPT Codes with Skins","target":"","impression":true,"click":true},"457467":{"title":"Header Code 3 with Interstitials and Skin pieces","target":"","impression":true,"click":true},"456969":{"title":"Display GPT allwith interstitial","target":"","impression":true,"click":true},"456967":{"title":"header codes (2 with interstitial)","target":"","impression":true,"click":true},"456820":{"title":"Head interstitial","target":"","impression":true,"click":true},"456691":{"title":"interstitial","target":"","impression":true,"click":true},"456162":{"title":"fluid ad for Slide pages","target":"","impression":true,"click":true},"455322":{"title":"Adsense Auto Ads All except syndicated on syndicate","target":"","impression":true,"click":true},"450675":{"title":"header codes","target":"","impression":true,"click":true},"450674":{"title":"Rectangle4","target":"","impression":false,"click":false},"450673":{"title":"Rectangle3","target":"","impression":false,"click":false},"450672":{"title":"Rectangle2","target":"","impression":false,"click":false},"450671":{"title":"Rectangle1","target":"","impression":false,"click":false},"450670":{"title":"Banner1","target":"","impression":false,"click":false},"450669":{"title":"Banner2","target":"","impression":false,"click":false},"449835":{"title":"Rec4","target":"","impression":true,"click":true},"449826":{"title":"Adsense Native","target":"","impression":true,"click":true},"449827":{"title":"Rec3","target":"","impression":true,"click":true},"449825":{"title":"Rec2","target":"","impression":true,"click":true},"449824":{"title":"Rec1","target":"","impression":true,"click":true},"449800":{"title":"Leader1","target":"","impression":true,"click":true},"449785":{"title":"leader2","target":"","impression":true,"click":true}}};var advads_gatracking_anonym = false;var advads_gatracking_transmitpageqs = {};</script><script defer src="https://static.cloudflareinsights.com/beacon.min.js" data-cf-beacon='{"rayId":"65bb9585683359d4","token":"e6d20d56d73944c299c4e04b97722bef","version":"2021.5.2","si":10}'></script>
</body></html>
