<!DOCTYPE html>
<html lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />

<title>Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated - Towleroad Gay News</title>
<meta name="description" content="Senate Minority Leader Mitch McConnell (R-Kentucky) urged fellow Republican men to get vaccinated on Monday, when he spoke at a Kentucky event. “As a" />
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large" />
<script src="/cdn-cgi/apps/head/A3bNKYP2epbsPGoBj9HE4gWaycc.js"></script><link rel="canonical" href="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated - Towleroad Gay News">
<meta property="og:description" content="Senate Minority Leader Mitch McConnell (R-Kentucky) urged fellow Republican men to get vaccinated on Monday, when he spoke at a Kentucky event. “As a">
<meta property="og:url" content="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/">
<meta property="og:site_name" content="Towleroad Gay News">
<meta property="article:publisher" content="https://www.facebook.com/towleroad.page">
<meta property="article:author" content="https://www.facebook.com/goff.michael">
<meta property="article:tag" content="Covid-19">
<meta property="article:tag" content="Congressional">
<meta property="article:tag" content="Republicans">
<meta property="article:tag" content="Vaccine">
<meta property="article:section" content="Body">
<meta property="og:updated_time" content="2021-04-03T15:49:03-04:00">
<meta property="fb:app_id" content="180651805330333">
<meta property="og:image" content="https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg">
<meta property="og:image:secure_url" content="https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg">
<meta property="og:image:width" content="690">
<meta property="og:image:height" content="500">
<meta property="og:image:alt" content="republican men vaccinated">
<meta property="og:image:type" content="image/jpeg">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated - Towleroad Gay News">
<meta name="twitter:description" content="Senate Minority Leader Mitch McConnell (R-Kentucky) urged fellow Republican men to get vaccinated on Monday, when he spoke at a Kentucky event. “As a">
<meta name="twitter:site" content="@tlrd">
<meta name="twitter:creator" content="@michael_goff">
<meta name="twitter:image" content="https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg">
<script type="application/ld+json" class="rank-math-schema-pro">{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://www.towleroad.com/#company","name":"Towleroad","logo":{"@type":"ImageObject","url":"http://towleroad.com/wp-content/uploads/2015/06/600x600_T.jpg","caption":"Towleroad","inLanguage":"en-US"}},{"@type":"WebSite","@id":"https://www.towleroad.com/#website","url":"https://www.towleroad.com","name":"Towleroad","publisher":{"@id":"https://www.towleroad.com/#company"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#primaryImage","url":"https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg","width":"690","height":"500","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.towleroad.com/author/michael-goff/","name":"Michael Goff","image":{"@type":"ImageObject","url":"https://secure.gravatar.com/avatar/c8369abbb425b852bc97f30ea09f6cf1?s=96&amp;d=mm&amp;r=g","caption":"Michael Goff","inLanguage":"en-US"},"sameAs":["https://www.facebook.com/goff.michael","https://www.facebook.com/goff.michael","https://twitter.com/michael_goff"],"worksFor":{"@id":"https://www.towleroad.com/#company"}},{"@type":"WebPage","@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#webpage","url":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/","name":"Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated - Towleroad Gay News","datePublished":"2021-04-03T15:48:18-04:00","dateModified":"2021-04-03T15:49:03-04:00","author":{"@id":"https://www.towleroad.com/author/michael-goff/"},"isPartOf":{"@id":"https://www.towleroad.com/#website"},"primaryImageOfPage":{"@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#primaryImage"},"inLanguage":"en-US"},{"@type":"NewsArticle","headline":"Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated - Towleroad Gay News","keywords":"republican men vaccinated","datePublished":"2021-04-03T15:48:18-04:00","dateModified":"2021-04-03T15:49:03-04:00","author":{"@type":"Person","name":"Michael Goff"},"publisher":{"@id":"https://www.towleroad.com/#company"},"description":"Senate Minority Leader Mitch McConnell (R-Kentucky) urged fellow Republican men to get vaccinated on Monday, when he spoke at a Kentucky event. \u201cAs a","copyrightYear":"2021","copyrightHolder":{"@id":"https://www.towleroad.com/#company"},"name":"Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated - Towleroad Gay News","@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#richSnippet","isPartOf":{"@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#webpage"},"image":{"@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#primaryImage"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#webpage"}}]}</script>

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Towleroad Gay News &raquo; Feed" href="https://www.towleroad.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad Gay News &raquo; Comments Feed" href="https://www.towleroad.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Towleroad Gay News &raquo; Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated Comments Feed" href="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.towleroad.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<script>
						advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
						</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='genesis-blocks-fontawesome-css' href='https://www.towleroad.com/wp-content/plugins/genesis-blocks/dist/assets/fontawesome/css/all.min.css?ver=1616110591' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-plugin-css-css' href='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/css/share.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-simple-share-genericons-css-css' href='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/css/genericons.min.css?ver=0.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='news-pro-css' href='https://www.towleroad.com/wp-content/themes/news-pro/style.css?ver=3.2.2' type='text/css' media='all' />
<style id='news-pro-inline-css' type='text/css'>


		a,
		.entry-title a:focus,
		.entry-title a:hover {
			color: #0066cc;
		}

		@media only screen and ( max-width: 1023px ) {
			.genesis-responsive-menu .genesis-nav-menu a:focus,
			.genesis-responsive-menu .genesis-nav-menu a:hover,
			.genesis-responsive-menu .genesis-nav-menu .menu-item.current-menu-item > a,
			.menu-toggle:focus,
			.menu-toggle:hover,
			.sub-menu-toggle:focus,
			.sub-menu-toggle:hover {
				color: #0066cc;
			}
		}

		
</style>
<link rel='stylesheet' id='wp-block-library-css' href='https://www.towleroad.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='genesis-blocks-style-css-css' href='https://www.towleroad.com/wp-content/plugins/genesis-blocks/dist/blocks.style.build.css?ver=1616110591' type='text/css' media='all' />
<link rel='stylesheet' id='pdf-viewer-block-styles-css' href='https://www.towleroad.com/wp-content/plugins/pdf-viewer-block/public/css/pdf-viewer-block.css?ver=5.7' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.towleroad.com/wp-includes/css/dashicons.min.css?ver=5.7' type='text/css' media='all' />
<style id="google-fonts-css" media="all">@font-face {
  font-family: 'Raleway';
  font-style: normal;
  font-weight: 400;
  src: url(/fonts.gstatic.com/s/raleway/v19/1Ptxg8zYS_SKggPN4iEgvnHyvveLxVvaorCIPrQ.ttf) format('truetype');
}
@font-face {
  font-family: 'Raleway';
  font-style: normal;
  font-weight: 700;
  src: url(/fonts.gstatic.com/s/raleway/v19/1Ptxg8zYS_SKggPN4iEgvnHyvveLxVs9pbCIPrQ.ttf) format('truetype');
}
</style>
<link rel='stylesheet' id='jetpack_css-css' href='https://www.towleroad.com/wp-content/plugins/jetpack/css/jetpack.css?ver=9.5' type='text/css' media='all' />
<link rel='stylesheet' id='genesis-tabs-stylesheet-css' href='https://www.towleroad.com/wp-content/plugins/genesis-tabs/assets/css/style.css?ver=0.9.5' type='text/css' media='all' />
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/jquery.sharrre.min.js?ver=0.1.0' id='genesis-simple-share-plugin-js-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/waypoints.min.js?ver=0.1.0' id='genesis-simple-share-waypoint-js-js'></script>
<script type='text/javascript' id='advanced-ads-advanced-js-js-extra'>
/* <![CDATA[ */
var advads_options = {"blog_id":"1","privacy":{"enabled":false,"state":"not_needed"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads/public/assets/js/advanced.min.js?ver=1.24.1' id='advanced-ads-advanced-js-js'></script>
<script type='text/javascript' id='advanced-ads-responsive-js-extra'>
/* <![CDATA[ */
var advanced_ads_responsive = {"reload_on_resize":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-responsive/public/assets/js/script.js?ver=1.10.1' id='advanced-ads-responsive-js'></script>
<script type='text/javascript' id='advanced_ads_pro/visitor_conditions-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_visitor_conditions = {"referrer_cookie_name":"advanced_ads_pro_visitor_referrer","referrer_exdays":"365","page_impr_cookie_name":"advanced_ads_page_impressions","page_impr_exdays":"3650"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-pro/modules/advanced-visitor-conditions/inc/conditions.min.js?ver=2.11.0' id='advanced_ads_pro/visitor_conditions-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-pro/assets/advanced-ads-pro.js?ver=2.11.0' id='advanced-ds-pro/front-js'></script>
<script type='text/javascript' id='advanced-ads-pro/cache_busting-js-extra'>
/* <![CDATA[ */
var advanced_ads_pro_ajax_object = {"ajax_url":"https:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php","lazy_load_module_enabled":"","lazy_load":{"default_offset":0,"offsets":[]},"moveintohidden":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-pro/modules/cache-busting/inc/base.min.js?ver=2.11.0' id='advanced-ads-pro/cache_busting-js'></script>
<link rel="https://api.w.org/" href="https://www.towleroad.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.towleroad.com/wp-json/wp/v2/posts/453575" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.towleroad.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.towleroad.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.7" />
<link rel='shortlink' href='https://www.towleroad.com/?p=453575' />
<link rel="alternate" type="application/json+oembed" href="https://www.towleroad.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.towleroad.com%2F2021%2F04%2Fmconnell-republican-men-vaccinated%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.towleroad.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.towleroad.com%2F2021%2F04%2Fmconnell-republican-men-vaccinated%2F&#038;format=xml" />
<meta name="pubexchange:image" content="https://i0.wp.com/www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1-300x217.jpg?w=300">
<meta name="pubexchange:title" content="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated">
<script>advads_items = { conditions: {}, display_callbacks: {}, display_effect_callbacks: {}, hide_callbacks: {}, backgrounds: {}, effect_durations: {}, close_functions: {}, showed: [] };</script><style type="text/css" id="towlelayer-custom-css"></style><script type="text/javascript">
		var advadsCfpQueue = [];
		var advadsCfpAd = function( adID ){
			if ( 'undefined' == typeof advadsProCfp ) { advadsCfpQueue.push( adID ) } else { advadsProCfp.addElement( adID ) }
		};
		</script>
<link rel="pingback" href="https://www.towleroad.com/xmlrpc.php" />
<meta name="pocket-site-verification" content="a63e5a37c49bc22a353dad335452bd" />
<script src="https://cdn.blueconic.net/brdblstcrp.js"></script>
<meta property=\"fb:pages\" content=\"13794040506\" />
<meta name="ahrefs-site-verification" content="3782df24765053415a4bf79b1904e680f3900df45eba4f6b2a18863303be0285">
<script type='text/javascript'>
  window.__pia_affiliate_id = 384
  ;(function () {
    var wa = document.createElement('script')
    wa.type = 'text/javascript'
    wa.async = true
    wa.src = 'https://www.privateinternetaccess.com/affiliate.min.js'
    var s = document.getElementsByTagName('script')[0]
    s.parentNode.insertBefore(wa, s)
  })()
</script>
<style type="text/css">.site-title a { background: url(https://www.towleroad.com/wp-content/uploads/2018/11/logo4.png) no-repeat !important; }</style>

<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-TBJM');</script>

<style type="text/css" id="custom-background-css">
body.custom-background { background-color: #ffffff; }
</style>
<script type="text/javascript">
			if ( typeof advadsGATracking === 'undefined' ) {
				window.advadsGATracking = {
					delayedAds: {},
					deferedAds: {}
				};
			}
		</script>
<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>


<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-4162187998603810",
    enable_page_level_ads: true
  });
</script>


<script async='async' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
	googletag.cmd.push(function() {
    	var mapboard1 =  googletag.sizeMapping().
                addSize([1023, 1],  [[728, 90], [970, 90], [970, 250]]).
            	addSize([767, 1], [728, 90]).
            	addSize([400, 1], [[320, 50], [320, 100]]).
            	build();
        var maprec1 = googletag.sizeMapping().
            	addSize([1023, 1], [[300, 250], [336, 280]]).
            	addSize([980, 1],  [[300, 250], [336, 280]]).
            	addSize([800, 1],  [[300, 250], [336, 280]]).
            	addSize([300, 1],  [[300, 250], [320, 100], [320, 50], [300, 50]]).
            	build();
        var maprec2 = googletag.sizeMapping().
                addSize([1023, 1], [[300, 250], [336, 280]]).
                addSize([980, 1],  [[300, 250], [336, 280]]).
                addSize([800, 1],  [[300, 250], [336, 280]]).
                addSize([300, 1],  [[300, 250], [320, 100], [320, 50], [300, 50]]).
                build();
        var maprec3 = googletag.sizeMapping().
                addSize([1023, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([980, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([800, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([740, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
                addSize([640, 1], [[300, 600], [300, 250],[160, 600]]).
                addSize([300, 1],  [[300, 250], [300, 600], [160,600], [320, 100], [320, 50], [300, 50]]).
              addSize([0, 0], []).
                build();
    	var maprec4 = googletag.sizeMapping().
            	addSize([1023, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([980, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([800, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([740, 1], [[300, 600], [300, 250], [160, 600], [336, 280]]).
            	addSize([640, 1], [[300, 600], [300, 250],[160, 600]]).
             addSize([300, 1],  [[300, 250], [300, 600], [160,600], [320, 100], [320, 50], [300, 50]]).
              addSize([0, 0], []).
            	build();
        var mapboard2 =  googletag.sizeMapping().
                addSize([1023, 1],  [[728, 90], [970, 90], [970, 250]]).
            	addSize([767, 1], [728, 90]).
            	addSize([400, 1], [[320, 50], [320, 100]]).
            	build();

      	googletag.defineSlot('/1026291/01_tlrd_board_1', ['fluid', [320, 50]], 'leader1').defineSizeMapping(mapboard1).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_1', ['fluid', [300, 250]], 'rec1').defineSizeMapping(maprec1).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_2', ['fluid', [300, 250]], 'rec2').defineSizeMapping(maprec2).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_3', ['fluid', [300, 250]], 'rec3').defineSizeMapping(maprec3).addService(googletag.pubads());
        googletag.defineSlot('/1026291/01_tlrd_rec_4', ['fluid', [300, 250]], 'rec4').defineSizeMapping(maprec4).addService(googletag.pubads());
      	googletag.defineSlot('/1026291/01_tlrd_board_2', ['fluid', [320, 50]], 'leader2').defineSizeMapping(mapboard2).addService(googletag.pubads());

      	googletag.pubads().setTargeting('art_title', ['mconnell-republican-men-vaccinated']); 
      	googletag.pubads().setTargeting('tag', ['']); 
        googletag.pubads().disableInitialLoad();
   googletag.pubads().enableLazyLoad({fetchMarginPercent: -1});
       	googletag.pubads().enableSingleRequest();
      	googletag.enableServices();
  	});

    </script>

<script>
//load the apstag.js library
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},targetingKeys:function(){return[]},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore(A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");

//initialize the apstag.js library on the page to allow bidding
apstag.init({
     pubID: '5afc5395-1615-42a2-9f3b-57ac2f50f8bd', //enter your pub ID here as shown above, it must within quotes
     adServer: 'googletag'
});
apstag.fetchBids({
     slots: [{
         slotID: 'leader1', //example: 'div-gpt-ad-1475102693815-0'
         slotName: '/1026291/01_tlrd_board_1', //example: '12345/box-1'
         sizes: [[728,90], [320, 50]] //example: [[300,250], [300,600]]
     },
     {
         slotID: 'leader2',
         slotName: '/1026291/01_tlrd_board_2',
         sizes: [[728,90], [320, 50]] 
     },
     {
         slotID: 'rec1', 
         slotName: '/1026291/01_tlrd_rec_1',
         sizes: [[300,250]] 
     },     
     {
         slotID: 'rec2', 
         slotName: '/1026291/01_tlrd_rec_2', 
         sizes: [[300,250]] 
     },     
	 {
         slotID: 'rec3', 
         slotName: '/1026291/01_tlrd_rec_3', 
         sizes: [[160,600], [300,250], [300,600]] 
     },
     {
         slotID: 'rec4', 
         slotName: '/1026291/01_tlrd_rec_4', 
         sizes: [[160,600], [300,250], [300,600]] 
     }],
     timeout: 2e3
}, function(bids) {
     // set apstag targeting on googletag, then trigger the first DFP request in googletag's disableInitialLoad integration
     googletag.cmd.push(function(){
         apstag.setDisplayBids();
         googletag.pubads().refresh();
     });
}); 
</script>
<script data-ad-client="ca-pub-4162187998603810" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <style id="uagb-style-conditional-extension">@media (min-width: 1025px){.entry-content .uag-hide-desktop.uagb-google-map__wrap,.entry-content .uag-hide-desktop{display:none}}@media (min-width: 768px) and (max-width: 1024px){.entry-content .uag-hide-tab.uagb-google-map__wrap,.entry-content .uag-hide-tab{display:none}}@media (max-width: 767px){.entry-content .uag-hide-mob.uagb-google-map__wrap,.entry-content .uag-hide-mob{display:none}}</style>
<link rel="icon" href="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://www.towleroad.com/wp-content/uploads/2017/03/cropped-fav-T-270x270.jpg" />
<style type="text/css" id="wp-custom-css">
			body {
	color:#333;
}
a.breadcrumb-link {
	color:#ff0000;
}
.breadcrumb {
	padding:0 0 0 10px;
}

.title-area {
	padding-left:0px;
	padding-top:0px;
}
.site-header .wrap {padding:0px;
}
.site-header .widget-area {
	width:100%;
	float:left;
	padding-left:0px;
	padding-right:0px;
	text-align:left;
}
.nav-secondary {
border: 0px solid #e3e3e3;
}
.genesis-nav-menu a {
	border:0px;
padding: 10px 10px;
}
.title-area .wrap{
	padding:10px 0;
}
.title-area {
width:100%;
}
.header-image .site-title a {
	min-height:4.5rem;
	margin-bottom:1.2rem;
}
.site-container-wrap {
	border:0px;
}
.content {
	padding-right:1em;
	border-right:0px;
}
.entry {
	padding:0px;
	border-bottom:0px;
	padding-bottom:1rem;;
}
.entry-title {
	margin:1rem 0;
}
.entry-header .entry-meta {
	margin:.5rem;
}
.entry-footer .entry-meta {
	padding:0px 0px 0px;
	margin:0px;
}
.after-entry-widget-area li::before, .news-pro-home .content li::before, .sidebar li::before {
	content: "";
}
.footer-widgets-1{
	width:100%;
}
.widget-title{
	margin-bottom:15px;
}
.home-top .widget.ui-tabs .entry h2 a {background-color:rgba(0,0,0,0.4)
}
.sponsthing{
font-size:10px;background-color:#B0C4DE;
}
.artstick .content{
width:95%;
	float:left;
}
.artstick  .sidebar-primary { 
display: none;
}

/* Previous and next single post navigation links */
.adjacent-entry-pagination {
 background: none;
 border-bottom: 3px solid #ddd;
 border-top: 0px solid #ddd;
 margin: 2em 0;
 padding: 2em 0;
}
.single .pagination-next,
.single .pagination-previous {
 font-size: 1.5rem;
 font-weight: 900;
 padding: 1.5em .5em;
 width: 45%;
}
.adjacent-entry-pagination .pagination-previous {
 float: left;
 padding-right: 1.5em;
}
.adjacent-entry-pagination .pagination-next {
 float: right;
 padding-left: 1.5em;
}
.home .entry-footer{
	display:none;
}
.home .archive-pagination {font-size:2rem;
}
.pagination-previous {background-color:yellow;
}
.pagination-next {background-color:yellow;}

.more-link {font-weight:bolder;
	font-size:85%;
}
.home-top {margin-bottom:;
} 

.contestsub {
color:red;
}
.hacks19 {
font-size:3rem;
	margin:3em;
	
}
.search-form-input{
	padding:0;
}

.content-tweet{
	font-size:.9rem;
}

.advads-close-button{
   transform: scale(1.5);
	color:lightpink;
}


.site-footer {
	margin-top:100px;
}

.entry-meta {
	width:500px;
}
h1.entry-title {
	font-size:3rem;
}
h2.entry-title {
	font-size:2.6rem;
}





		</style>
</head>
<body class="post-template-default single single-post postid-453575 single-format-standard custom-background custom-header header-image content-sidebar genesis-breadcrumbs-hidden genesis-footer-widgets-hidden aa-prefix-towle" itemscope itemtype="https://schema.org/WebPage"><script>
  window.fbAsyncInit = function() {
    FB.init({
      appId      : '3740778515980102',
      cookie     : true,
      xfbml      : true,
      version    : 'v9.0'
    });
      
    FB.AppEvents.logPageView();   
      
  };

  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "https://connect.facebook.net/en_US/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-TBJM"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div class="site-container"><ul class="genesis-skip-link"><li><a href="#genesis-nav-primary" class="screen-reader-shortcut"> Skip to primary navigation</a></li><li><a href="#genesis-content" class="screen-reader-shortcut"> Skip to main content</a></li><li><a href="#genesis-sidebar-primary" class="screen-reader-shortcut"> Skip to primary sidebar</a></li></ul><div class="site-container-wrap"><nav class="nav-secondary" aria-label="Secondary" itemscope itemtype="https://schema.org/SiteNavigationElement"><div class="wrap"><ul id="menu-footer-about" class="menu genesis-nav-menu menu-secondary js-superfish"><li id="menu-item-219388" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="https://www.towleroad.com/contact/" itemprop="url"><span itemprop="name">Advertise</span></a></li>
<li id="menu-item-219196" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="https://www.towleroad.com/contact/" itemprop="url"><span itemprop="name">Contact Us</span></a></li>
<li id="menu-item-219193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="https://www.towleroad.com/about-us/" itemprop="url"><span itemprop="name">About Towleroad</span></a></li>
<li id="menu-item-219443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="https://www.towleroad.com/towleroad-social-media/" itemprop="url"><span itemprop="name">Towleroad on Social Media</span></a></li>
<li id="menu-item-219194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="https://www.towleroad.com/privacy-policy/" itemprop="url"><span itemprop="name">Privacy Policy</span></a></li>
</ul></div></nav><header class="site-header" itemscope itemtype="https://schema.org/WPHeader"><div class="wrap"><div class="title-area"><p class="site-title" itemprop="headline"><a href="https://www.towleroad.com/">Towleroad Gay News</a></p><div class="towlegenesis-banner-1 towletarget" id="towle852426432" data-advadstrackid="449800" data-advadstrackbid="1" data-advadsredirect=""><div id="leader1" style="width:100%;float:left;display:block;margin-bottom:10px;">
<script>
        googletag.cmd.push(function() {
      	    googletag.display('leader1');
        });
    </script>
</div>
</div><p class="site-description" itemprop="description">Gay Blog Towleroad: More than gay news | gay men</p></div><nav class="nav-header" itemscope itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-primary" class="menu genesis-nav-menu menu-header js-superfish"><li id="menu-item-364955" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-364955"><a href="https://www.towleroad.com/tag/body-conscious/" itemprop="url"><span itemprop="name">Body</span></a></li>
<li id="menu-item-337715" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-337715"><a href="https://www.towleroad.com/tag/daily-resist/" itemprop="url"><span itemprop="name">Daily Resist</span></a></li>
<li id="menu-item-227804" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227804"><a href="https://www.towleroad.com/tag/politics/" itemprop="url"><span itemprop="name">POLITICS</span></a></li>
<li id="menu-item-227806" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227806"><a href="https://www.towleroad.com/tag/travel/" itemprop="url"><span itemprop="name">Travel</span></a></li>
<li id="menu-item-227809" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227809"><a href="https://www.towleroad.com/tag/music/" itemprop="url"><span itemprop="name">Music</span></a></li>
<li id="menu-item-227807" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227807"><a href="https://www.towleroad.com/tag/theatre/" itemprop="url"><span itemprop="name">Theatre</span></a></li>
<li id="menu-item-227721" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227721"><a href="https://www.towleroad.com/tag/film/" itemprop="url"><span itemprop="name">Film</span></a></li>
<li id="menu-item-227808" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227808"><a href="https://www.towleroad.com/tag/television/" itemprop="url"><span itemprop="name">TV</span></a></li>
<li id="menu-item-270521" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-270521"><a href="https://www.towleroad.com/tag/sports/" itemprop="url"><span itemprop="name">Sports</span></a></li>
</ul></nav></div></header><nav class="nav-primary" aria-label="Main" itemscope itemtype="https://schema.org/SiteNavigationElement" id="genesis-nav-primary"><div class="wrap"><ul id="menu-secondary" class="menu genesis-nav-menu menu-primary js-superfish"><li id="menu-item-303865" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-303865"><a href="https://www.towleroad.com/tag/business/" itemprop="url"><span itemprop="name">Business</span></a></li>
<li id="menu-item-276395" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-276395"><a href="https://www.towleroad.com/tag/men/" itemprop="url"><span itemprop="name">Men</span></a></li>
<li id="menu-item-227801" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227801"><a href="https://www.towleroad.com/tag/gay-marriage/" itemprop="url"><span itemprop="name">Marriage Equality</span></a></li>
<li id="menu-item-275223" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-275223"><a href="https://www.towleroad.com/tag/space/" itemprop="url"><span itemprop="name">Space</span></a></li>
<li id="menu-item-227820" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227820"><a href="https://www.towleroad.com/tag/transgender/" itemprop="url"><span itemprop="name">Trans Rights</span></a></li>
<li id="menu-item-227817" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227817"><a href="https://www.towleroad.com/tag/books/" itemprop="url"><span itemprop="name">Books</span></a></li>
<li id="menu-item-241504" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-241504"><a href="https://www.towleroad.com/tag/science/" itemprop="url"><span itemprop="name">Science</span></a></li>
<li id="menu-item-227819" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227819"><a href="https://www.towleroad.com/tag/gay-iconography/" itemprop="url"><span itemprop="name">Gay Iconography</span></a></li>
<li id="menu-item-227863" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-227863"><a href="https://www.towleroad.com/tag/towleread/" itemprop="url"><span itemprop="name">TowleREAD</span></a></li>
</ul></div></nav><div class="site-inner"><div class="content-sidebar-wrap"><main class="content" id="genesis-content"><article class="post-453575 post type-post status-publish format-standard has-post-thumbnail category-body category-politics tag-covid-19 tag-congressional tag-republicans tag-vaccine entry" aria-label="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" itemscope itemtype="https://schema.org/CreativeWork"><header class="entry-header"><h1 class="entry-title" itemprop="headline">Sen. Mitch McConnell Speaks Up. Wants Fellow Republican Men Vaccinated</h1>
<p class="entry-meta"><time class="entry-time" itemprop="datePublished" datetime="2021-04-03T15:48:18-04:00">April 3, 2021</time> by <span class="entry-author" itemprop="author" itemscope itemtype="https://schema.org/Person"><a href="https://www.towleroad.com/author/michael-goff/" class="entry-author-link" rel="author" itemprop="url"><span class="entry-author-name" itemprop="name">Michael Goff</span></a></span> <span class="entry-comments-link"><a href="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/#respond"><span class="dsq-postid" data-dsqidentifier="453575 https://www.towleroad.com/?p=453575">Leave a Comment</span></a></span> </p></header><div class="entry-content" itemprop="text"><div class="share-before share-filled share-medium" id="share-before-453575"><div class="facebook" id="facebook-before-453575" data-url="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" data-urlalt="https://www.towleroad.com/?p=453575" data-text="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-before-453575" data-url="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" data-urlalt="https://www.towleroad.com/?p=453575" data-text="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="linkedin" id="linkedin-before-453575" data-url="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" data-urlalt="https://www.towleroad.com/?p=453575" data-text="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" data-title="Share" data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div></div>
<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#facebook-before-453575').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-before-453575').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  twitter: { via: 'tlrd' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#linkedin-before-453575').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});

				});
		</script>
<figure class="wp-block-image"><img src="https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg" alt="mconnell-republican-men-vaccinated" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" class=" jetpack-lazy-image"><noscript><img src="https://www.towleroad.com/wp-content/uploads/2021/04/453575-origin_1.jpg" alt="mconnell-republican-men-vaccinated"/></noscript></figure>
<p>Senate Minority Leader Mitch McConnell (R-Kentucky) urged fellow Republican men to get vaccinated on Monday, when he spoke at a Kentucky event. “As a Republican man, as soon as it was my turn, I took the vaccine,” he said. “I would encourage all Republican men to do that… take the vaccination.” McConnell himself received his first dose of the Pfizer-BioNTech vaccine on Dec. 18. In his speech, McConnell discussed the efficacy of the available COVID-19 vaccines. “Two of ‘em are 90 percent effective,” he said. “One of ‘em is 70 percent effective, and I didn’t realize until this pandemic began tha&#8230;</p><div class="towlefirstpost-injection towletarget" id="towle540543500" data-advadstrackid="449824" data-advadstrackbid="1" data-advadsredirect="">
<div id='rec1' style="margin-bottom:1rem;">
<script>
    googletag.cmd.push(function() { googletag.display('rec1'); });
  </script>
</div>
</div>
<span id="more-453575"></span>
<figure class="wp-block-pullquote"><blockquote><p>“As a Republican man, as soon as it was my turn, I took the vaccine,” he said. “I would encourage all Republican men to do that… take the vaccination.”</p><cite>Mitch McConnell R-Kentucky</cite></blockquote></figure>
<p><a class="nordot-read-more " rel="noopener" href="https://this.kiji.is/751119836857221120?c=644607769890374753" target="_blank">Read More</a></p>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 2rem !important;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 14px;
}

.rpwe-time{
color: #bbb;
font-size: 11px;
}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><section id="rpwe_widget-15" class="widget rpwe_widget recent-posts-extended amr_widget"><div class="widget-wrap"><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/ewan-mcgregor-50/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb jetpack-lazy-image" src="https://www.towleroad.com/wp-content/uploads/2021/04/EwanMcGregor_50-350x75.jpeg" alt="Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week.  SPECIAL" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/04/EwanMcGregor_50-350x75.jpeg?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/EwanMcGregor_50-350x75.jpeg" alt="Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week.  SPECIAL"></noscript></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/ewan-mcgregor-50/" title="Permalink to Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week.  SPECIAL" rel="bookmark">Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week. SPECIAL</a></h3><time class="rpwe-time published" datetime="2021-04-02T11:34:46-04:00">April 2, 2021</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/easter-hop-links-2/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb jetpack-lazy-image" src="https://www.towleroad.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-9.26.48-PM-1-350x75.png" alt="Tim Cook&#8217;s Peach Flambe  ; Macron on Side;  17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS" data-lazy-src="https://www.towleroad.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-9.26.48-PM-1-350x75.png?is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-9.26.48-PM-1-350x75.png" alt="Tim Cook&#8217;s Peach Flambe  ; Macron on Side;  17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS"></noscript></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/easter-hop-links-2/" title="Permalink to Tim Cook&#8217;s Peach Flambe  ; Macron on Side;  17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS" rel="bookmark">Tim Cook&#8217;s Peach Flambe ; Macron on Side; 17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS</a></h3><time class="rpwe-time published" datetime="2021-04-01T21:43:14-04:00">April 1, 2021</time></li></ul></div></div></section>
<div class="pubexchange_module" id="pubexchange_below_content_1" data-pubexchange-module-id="1851"></div><div class="share-after share-filled share-medium" id="share-after-453575"><div class="facebook" id="facebook-after-453575" data-url="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" data-urlalt="https://www.towleroad.com/?p=453575" data-text="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" data-title="Share" data-reader="Share on Facebook" data-count="%s shares on Facebook"></div><div class="twitter" id="twitter-after-453575" data-url="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" data-urlalt="https://www.towleroad.com/?p=453575" data-text="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" data-title="Tweet" data-reader="Tweet this" data-count="%s Tweets"></div><div class="linkedin" id="linkedin-after-453575" data-url="https://www.towleroad.com/2021/04/mconnell-republican-men-vaccinated/" data-urlalt="https://www.towleroad.com/?p=453575" data-text="Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated" data-title="Share" data-reader="Share on LinkedIn" data-count="%s shares on LinkedIn"></div></div>
<script type='text/javascript'>
				jQuery(document).ready(function($) {
					$('#facebook-after-453575').sharrre({
										  share: {
										    facebook: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('facebook');
										  }
										});
$('#twitter-after-453575').sharrre({
										  share: {
										    twitter: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  twitter: { via: 'tlrd' } },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('twitter');
										  }
										});
$('#linkedin-after-453575').sharrre({
										  share: {
										    linkedin: true
										  },
										  urlCurl: 'https://www.towleroad.com/wp-content/plugins/genesis-simple-share/assets/js/sharrre/sharrre.php',
										  enableHover: false,
										  enableTracking: true,
										  disableCount: true,
										  buttons: {  },
										  click: function(api, options){
										    api.simulateClick();
										    api.openPopup('linkedin');
										  }
										});

				});
		</script>
</div><div class="towlemobilerec4 towletarget" id="towle424294063" data-advadstrackid="449835" data-advadstrackbid="1" data-advadsredirect=""><div id="rec4" style="width:100%;text-align:center;">
<script>
        googletag.cmd.push(function() {
             googletag.display('rec4');
        });
    </script>
</div></div><footer class="entry-footer"><p class="entry-meta"><span class="entry-categories">Filed Under: <a href="https://www.towleroad.com/category/body/" rel="category tag">Body</a>, <a href="https://www.towleroad.com/category/politics/" rel="category tag">Politics</a></span> <span class="entry-tags">Tagged With: <a href="https://www.towleroad.com/tag/covid-19/" rel="tag">Covid-19</a>, <a href="https://www.towleroad.com/tag/congressional/" rel="tag">Congressional</a>, <a href="https://www.towleroad.com/tag/republicans/" rel="tag">Republicans</a>, <a href="https://www.towleroad.com/tag/vaccine/" rel="tag">Vaccine</a></span></p></footer></article><div class="after-entry widget-area"><style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 10px;
padding-bottom: 10px;
list-style-type: none;
}

.rpwe-block a{
display: inline !important;
text-decoration: none;
}

.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 0 !important;
font-weight: 400;
font-size: 2rem;
line-height: 1.5em;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-summary{
font-size: 2rem;
}

.rpwe-time{
color: #bbb;
font-size: 1.5rem;
}

.rpwe-comment{
color: #bbb;
font-size: 1.5rem;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><section id="rpwe_widget-6" class="widget rpwe_widget recent-posts-extended"><div class="widget-wrap"><h3 class="widgettitle widget-title">Recent Posts</h3>
<div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/rupauls-drag-race-henny-bunches-of-hautes-recap-and-rankings/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb rpwe-default-thumb" src="https://placehold.it/45x45/f0f0f0/ccc" alt="RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]" width="350" height="75"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/rupauls-drag-race-henny-bunches-of-hautes-recap-and-rankings/" title="Permalink to RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]" rel="bookmark">RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]</a></h3><time class="rpwe-time published" datetime="2021-04-03T08:59:37-04:00">7 hours ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/florida-men-it-gaetz-better/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-02-at-9.48.55-PM-350x75.png" alt="Dating Lil Nas; NFT Paris Hilton; Florida Men:   It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/florida-men-it-gaetz-better/" title="Permalink to Dating Lil Nas; NFT Paris Hilton; Florida Men:   It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS" rel="bookmark">Dating Lil Nas; NFT Paris Hilton; Florida Men: It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS</a></h3><time class="rpwe-time published" datetime="2021-04-02T21:53:33-04:00">18 hours ago</time></li></ul></div></div></section>
</div><div class="adjacent-entry-pagination pagination"><div class="pagination-previous alignleft"><a href="https://www.towleroad.com/2021/04/rupauls-drag-race-henny-bunches-of-hautes-recap-and-rankings/" rel="prev"><span class="screen-reader-text">Previous Post: </span><span class="adjacent-post-link">&#xAB; RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]</span></a></div><div class="pagination-next alignright"></div></div>
<div id="disqus_thread"></div>
</main><aside class="sidebar sidebar-primary widget-area" role="complementary" aria-label="Primary Sidebar" itemscope itemtype="https://schema.org/WPSideBar" id="genesis-sidebar-primary"><h2 class="genesis-sidebar-title screen-reader-text">Primary Sidebar</h2><section id="search-3" class="widget widget_search"><div class="widget-wrap"><form class="search-form" method="get" action="https://www.towleroad.com/" role="search" itemprop="potentialAction" itemscope itemtype="https://schema.org/SearchAction"><label class="search-form-label screen-reader-text" for="searchform-1">Search this website</label><input class="search-form-input" type="search" name="s" id="searchform-1" placeholder="Search this website" itemprop="query-input"><input class="search-form-submit" type="submit" value="Search"><meta content="https://www.towleroad.com/?s={s}" itemprop="target"></form></div></section>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 5px;
list-style-type: none;
}


.rpwe-block a{
display: inline !important;
text-decoration: none;
font-size:1.4rem;
line-height:1.2em;
}


.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 5px !important;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-time{
color: #bbb;
font-size: 1rem;

}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><section id="rpwe_widget-10" class="widget rpwe_widget recent-posts-extended"><div class="widget-wrap"><div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/rupauls-drag-race-henny-bunches-of-hautes-recap-and-rankings/" title="Permalink to RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]" rel="bookmark">RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/florida-men-it-gaetz-better/" title="Permalink to Dating Lil Nas; NFT Paris Hilton; Florida Men:   It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS" rel="bookmark">Dating Lil Nas; NFT Paris Hilton; Florida Men: It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS</a></h3></li><li class="rpwe-li rpwe-clearfix"><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/ewan-mcgregor-50/" title="Permalink to Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week.  SPECIAL" rel="bookmark">Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week. SPECIAL</a></h3></li></ul></div></div></section>
<section class="widget towlewidget"><div class="widget-wrap"><div class="towlewidgetsiderec3 towletarget" id="towle517384585" data-advadstrackid="449827" data-advadstrackbid="1" data-advadsredirect=""><div id="rec3" style="width:100%;text-align:center;">
<script>
        googletag.cmd.push(function() {
       	     googletag.display('rec3');
        });
    </script>
</div></div></div></section>
<style>.rpwe-block ul{
list-style: none !important;
margin-left: 0 !important;
padding-left: 0 !important;
}

.rpwe-block li{
border-bottom: 1px solid #eee;
margin-bottom: 5px;
list-style-type: none;
}


.rpwe-block a{
display: inline !important;
text-decoration: none;
font-size:1.4rem;
line-height:1.2em;
}


.rpwe-block h3{
background: none !important;
clear: none;
margin-bottom: 0 !important;
margin-top: 5px !important;
}

.rpwe-thumb{
border: 1px solid #eee !important;
box-shadow: none !important;
margin: 2px 10px 2px 0;
padding: 3px !important;
}

.rpwe-time{
color: #bbb;
font-size: 1rem;

}

.rpwe-comment{
color: #bbb;
font-size: 11px;
padding-left: 5px;
}

.rpwe-alignleft{
display: inline;
float: left;
}

.rpwe-alignright{
display: inline;
float: right;
}

.rpwe-aligncenter{
display: block;
margin-left: auto;
margin-right: auto;
}

.rpwe-clearfix:before,
.rpwe-clearfix:after{
content: "";
display: table !important;
}

.rpwe-clearfix:after{
clear: both;
}

.rpwe-clearfix{
zoom: 1;
}
</style><section id="rpwe_widget-4" class="widget rpwe_widget recent-posts-extended"><div class="widget-wrap"><h3 class="widgettitle widget-title">Recent Posts</h3>
<div class="rpwe-block "><ul class="rpwe-ul"><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/rupauls-drag-race-henny-bunches-of-hautes-recap-and-rankings/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb rpwe-default-thumb" src="https://placehold.it/45x45/f0f0f0/ccc" alt="RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]" width="90" height="90"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/rupauls-drag-race-henny-bunches-of-hautes-recap-and-rankings/" title="Permalink to RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]" rel="bookmark">RuPaul&#8217;s Drag Race: Henny Bunches of Hautes [RECAP and RANKINGS]</a></h3><time class="rpwe-time published" datetime="2021-04-03T08:59:37-04:00">7 hours ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/florida-men-it-gaetz-better/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-02-at-9.48.55-PM-90x90.png" alt="Dating Lil Nas; NFT Paris Hilton; Florida Men:   It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/florida-men-it-gaetz-better/" title="Permalink to Dating Lil Nas; NFT Paris Hilton; Florida Men:   It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS" rel="bookmark">Dating Lil Nas; NFT Paris Hilton; Florida Men: It Gaetz Better; Governor Bans Covid Passports; Trump Launches Site In Exile: HOT LINKS</a></h3><time class="rpwe-time published" datetime="2021-04-02T21:53:33-04:00">18 hours ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/ewan-mcgregor-50/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/EwanMcGregor_50-90x90.jpeg" alt="Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week.  SPECIAL"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/ewan-mcgregor-50/" title="Permalink to Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week.  SPECIAL" rel="bookmark">Work in Film: Ewan McGregor, an Eternal Sexpot, Turned 50 This Week. SPECIAL</a></h3><time class="rpwe-time published" datetime="2021-04-02T11:34:46-04:00">1 day ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/easter-hop-links-2/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-01-at-9.26.48-PM-1-90x90.png" alt="Tim Cook&#8217;s Peach Flambe  ; Macron on Side;  17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/easter-hop-links-2/" title="Permalink to Tim Cook&#8217;s Peach Flambe  ; Macron on Side;  17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS" rel="bookmark">Tim Cook&#8217;s Peach Flambe ; Macron on Side; 17 Years of NPH &#038; David ; Dionne Warwick Loves Twitter; Supergirl: EASTER HOP LINKS</a></h3><time class="rpwe-time published" datetime="2021-04-01T21:43:14-04:00">2 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/invincible-amazon/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/453340-origin_1-90x90.jpg" alt="First Three Episodes Of ‘Invincible’ Air On Amazon Prime Video: WATCH"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/invincible-amazon/" title="Permalink to First Three Episodes Of ‘Invincible’ Air On Amazon Prime Video: WATCH" rel="bookmark">First Three Episodes Of ‘Invincible’ Air On Amazon Prime Video: WATCH</a></h3><time class="rpwe-time published" datetime="2021-04-01T17:00:26-04:00">2 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/just-living-his-life/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/453319-origin_1-90x90.jpg" alt="Chauvin Trial. Day 5 Floyd was &#8220;Just Living His Live.&#8221;  &#8211; -Girlfriend Tells Of Meeting,  Romantic Walks, Shared Struggle with Opioids."></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/just-living-his-life/" title="Permalink to Chauvin Trial. Day 5 Floyd was &#8220;Just Living His Live.&#8221;  &#8211; -Girlfriend Tells Of Meeting,  Romantic Walks, Shared Struggle with Opioids." rel="bookmark">Chauvin Trial. Day 5 Floyd was &#8220;Just Living His Live.&#8221; &#8211; -Girlfriend Tells Of Meeting, Romantic Walks, Shared Struggle with Opioids.</a></h3><time class="rpwe-time published" datetime="2021-04-01T16:12:34-04:00">2 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/04/mama-gloria-in-chicago/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/04/453305-origin_1-90x90.jpg" alt="9 Years Ago, The Chicago Tribune Wrote About &#8216;Mama Gloria&#8217;s&#8217; Charm School. Now 75, Her Story is on Stage, Screen, A New Book"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/04/mama-gloria-in-chicago/" title="Permalink to 9 Years Ago, The Chicago Tribune Wrote About &#8216;Mama Gloria&#8217;s&#8217; Charm School. Now 75, Her Story is on Stage, Screen, A New Book" rel="bookmark">9 Years Ago, The Chicago Tribune Wrote About &#8216;Mama Gloria&#8217;s&#8217; Charm School. Now 75, Her Story is on Stage, Screen, A New Book</a></h3><time class="rpwe-time published" datetime="2021-04-01T11:44:50-04:00">2 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/03/coke-delta-condemn/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/03/453251-origin_1-90x90.jpg" alt="Finally after pressure, Coke, Delta Condemn Voting Restrictions as &#8216;Unacceptable&#8217; and Based on &#8216;Big Lie&#8217;. Too Little, Too Late?"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/03/coke-delta-condemn/" title="Permalink to Finally after pressure, Coke, Delta Condemn Voting Restrictions as &#8216;Unacceptable&#8217; and Based on &#8216;Big Lie&#8217;. Too Little, Too Late?" rel="bookmark">Finally after pressure, Coke, Delta Condemn Voting Restrictions as &#8216;Unacceptable&#8217; and Based on &#8216;Big Lie&#8217;. Too Little, Too Late?</a></h3><time class="rpwe-time published" datetime="2021-03-31T16:41:29-04:00">3 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/03/lance-bass-opening-big-gay-club/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/03/Screen-Shot-2021-03-31-at-2.24.16-PM-90x90.png" alt="NSYNC&#8217;s Lance Bass Opening Big Gay Club; Ariana Grande joins The Voice; Drew Launching Mag; Gordon Liddy Dead: HOT LINKS"></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/03/lance-bass-opening-big-gay-club/" title="Permalink to NSYNC&#8217;s Lance Bass Opening Big Gay Club; Ariana Grande joins The Voice; Drew Launching Mag; Gordon Liddy Dead: HOT LINKS" rel="bookmark">NSYNC&#8217;s Lance Bass Opening Big Gay Club; Ariana Grande joins The Voice; Drew Launching Mag; Gordon Liddy Dead: HOT LINKS</a></h3><time class="rpwe-time published" datetime="2021-03-31T15:00:30-04:00">3 days ago</time></li><li class="rpwe-li rpwe-clearfix"><a class="rpwe-img" href="https://www.towleroad.com/2021/03/gaetz-under-investigation/" rel="bookmark"><img class="rpwe-alignleft rpwe-thumb" src="https://www.towleroad.com/wp-content/uploads/2021/03/453213-origin_1-90x90.jpg" alt="Florida Rep. Matt Gaetz under investigation over alleged sexual relationship with teen. Like No Other: TIMELINE of Gaetz Headlines."></a><h3 class="rpwe-title"><a href="https://www.towleroad.com/2021/03/gaetz-under-investigation/" title="Permalink to Florida Rep. Matt Gaetz under investigation over alleged sexual relationship with teen. Like No Other: TIMELINE of Gaetz Headlines." rel="bookmark">Florida Rep. Matt Gaetz under investigation over alleged sexual relationship with teen. Like No Other: TIMELINE of Gaetz Headlines.</a></h3><time class="rpwe-time published" datetime="2021-03-31T07:30:00-04:00">3 days ago</time></li></ul></div></div></section>
<section id="dpp_widget-2" class="widget widget_dpp_widget"><div class="widget-wrap"><h3 class="widgettitle widget-title">Most Commented</h3>
<span class="dpp_render_area" id="dpp_render_area-2"></span></div></section>
<section id="nav_menu-5" class="widget widget_nav_menu"><div class="widget-wrap"><div class="menu-footer-about-container"><ul id="menu-footer-about-1" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219388"><a href="https://www.towleroad.com/contact/" itemprop="url">Advertise</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219196"><a href="https://www.towleroad.com/contact/" itemprop="url">Contact Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219193"><a href="https://www.towleroad.com/about-us/" itemprop="url">About Towleroad</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219443"><a href="https://www.towleroad.com/towleroad-social-media/" itemprop="url">Towleroad on Social Media</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-219194"><a href="https://www.towleroad.com/privacy-policy/" itemprop="url">Privacy Policy</a></li>
</ul></div></div></section>
</aside></div></div><footer class="site-footer" itemscope itemtype="https://schema.org/WPFooter"><div class="wrap"><p>Copyright &#x000A9;&nbsp;2021 · <a rel="nofollow" href="https://www.towleroad.com/wp-login.php">Log in</a></p></div></footer></div></div><script>
		var advanced_ads_ga_UID = 'UA-2831502-1';
		var advanced_ads_ga_anonymIP = true;
advanced_ads_check_adblocker=function(t){function e(t){(window.requestAnimationFrame||window.mozRequestAnimationFrame||window.webkitRequestAnimationFrame||function(t){return setTimeout(t,16)}).call(window,t)}var n=[],a=null;return e(function(){var t=document.createElement("div");t.innerHTML="&nbsp;",t.setAttribute("class","ad_unit ad-unit text-ad text_ad pub_300x250"),t.setAttribute("style","width: 1px !important; height: 1px !important; position: absolute !important; left: 0px !important; top: 0px !important; overflow: hidden !important;"),document.body.appendChild(t),e(function(){var e=window.getComputedStyle&&window.getComputedStyle(t),o=e&&e.getPropertyValue("-moz-binding");a=e&&"none"===e.getPropertyValue("display")||"string"==typeof o&&-1!==o.indexOf("about:");for(var i=0;i<n.length;i++)n[i](a);n=[]})}),function(t){if(null===a)return void n.push(t);t(a)}}(),function(){var t=function(t,e){this.name=t,this.UID=e,this.analyticsObject=null;var n=this,a={hitType:"event",eventCategory:"Advanced Ads",eventAction:"AdBlock",eventLabel:"Yes",nonInteraction:!0,transport:"beacon"};this.analyticsObject="string"==typeof GoogleAnalyticsObject&&"function"==typeof window[GoogleAnalyticsObject]&&window[GoogleAnalyticsObject],!1===this.analyticsObject?(!function(t,e,n,a,o,i,d){t.GoogleAnalyticsObject=o,t[o]=t[o]||function(){(t[o].q=t[o].q||[]).push(arguments)},t[o].l=1*new Date,i=e.createElement(n),d=e.getElementsByTagName(n)[0],i.async=1,i.src="https://www.google-analytics.com/analytics.js",d.parentNode.insertBefore(i,d)}(window,document,"script",0,"_advads_ga"),_advads_ga("create",n.UID,"auto",this.name),advanced_ads_ga_anonymIP&&_advads_ga("set","anonymizeIp",!0),_advads_ga(n.name+".send",a)):(window.console&&window.console.log("Advanced Ads Analytics >> using other's variable named `"+GoogleAnalyticsObject+"`"),window[GoogleAnalyticsObject]("create",n.UID,"auto",this.name),window[GoogleAnalyticsObject]("set","anonymizeIp",!0),window[GoogleAnalyticsObject](n.name+".send",a))};advanced_ads_check_adblocker(function(e){e&&"string"==typeof advanced_ads_ga_UID&&advanced_ads_ga_UID&&new t("advadsTracker",advanced_ads_ga_UID)})}();</script><script type="text/javascript">(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: true, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script><div class="towlestickybar towlesticky towletarget" style="margin-left: auto; margin-right: auto; text-align: center; margin-top: 10px; position: fixed; bottom: 0; z-index: 10000; " id="towle78415186" data-advadstrackid="449785" data-advadstrackbid="1" data-advadsredirect=""><span class="advads-close-button" onclick="void(0)" title="close" style="width: 15px; height: 15px; background: #fff; position: relative; line-height: 15px; text-align: center; cursor: pointer; z-index: 10000;right:-15px;float: right; margin-left: -15px;">×</span>
<div id='leader2'>
<script>
    googletag.cmd.push(function() { googletag.display('leader2'); });
  </script>
</div></div><script>( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {var wrapper_id = "#towle78415186"; var $wrapper = jQuery( wrapper_id );advads.move( wrapper_id, "", {  });window.advanced_ads_sticky_items = window.advanced_ads_sticky_items || {};advanced_ads_sticky_items[ "towle78415186" ] = { "can_convert_to_abs": "1", "initial_css": $wrapper.attr( "style" ), "modifying_func": function() { $wrapper.css({ "-webkit-transform": "translateX(-50%)", "-moz-transform": "translateX(-50%)", "transform": "translateX(-50%)", "left": "50%", "margin-right": "-50%" });jQuery( "#towle78415186" ).on( "click", "span", function() { advads.close( "#towle78415186" ); });}};
if ( advads.wait_for_images ) { 
    var sticky_wait_for_images_time = new Date().getTime();
    $wrapper.data( "sticky_wait_for_images_time", sticky_wait_for_images_time );
    advads.wait_for_images( $wrapper, function() {
        // At the moment when this function is called, it is possible that 
        // the placement has been updated using "Reload ads on resize" feature of Responsive add-on 
        if ( $wrapper.data( "sticky_wait_for_images_time" ) === sticky_wait_for_images_time ) {
            advanced_ads_sticky_items[ "towle78415186" ]["modifying_func"]();
        } 
    } );
} else { 
    advanced_ads_sticky_items[ "towle78415186" ]["modifying_func"]();
};
});</script> <script type="text/javascript">
		function genesisBlocksShare( url, title, w, h ){
			var left = ( window.innerWidth / 2 )-( w / 2 );
			var top  = ( window.innerHeight / 2 )-( h / 2 );
			return window.open(url, title, 'toolbar=no, location=no, directories=no, status=no, menubar=no, scrollbars=no, resizable=no, copyhistory=no, width=600, height=600, top='+top+', left='+left);
		}
	</script>
<div id="amzn-assoc-ad-1f73a4d8-e2cd-4bbc-a758-192dfc2670f4"></div><script async src="//z-na.amazon-adsystem.com/widgets/onejs?MarketPlace=US&adInstanceId=1f73a4d8-e2cd-4bbc-a758-192dfc2670f4"></script>
<script type="text/javascript" src="//s.skimresources.com/js/92217X1546135.skimlinks.js"></script>
<script>(function(w, d, s, id) {
  w.PUBX=w.PUBX || {pub: "towleroad", discover: false, lazy: true};
  var js, pjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id; js.async = true;
  js.src = "//main.pubexchange.com/loader.min.js";
  pjs.parentNode.insertBefore(js, pjs);
}(window, document, "script", "pubexchange-jssdk"));</script>

<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>

<script type="text/javascript">
_atrk_opts = { atrk_acct:"NCUJh1awVK000u", domain:"towleroad.com",dynamic: true};
(function() { var as = document.createElement('script'); as.type = 'text/javascript'; as.async = true; as.src = "https://d31qbv1cthcecs.cloudfront.net/atrk.js"; var s = document.getElementsByTagName('script')[0];s.parentNode.insertBefore(as, s); })();
</script>
<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=NCUJh1awVK000u" style="display:none" height="1" width="1" alt="" /></noscript>

<script type="text/javascript">
var _sf_async_config={uid:551,domain:"towleroad.com",useCanonical:true};
(function(){
  function loadChartbeat() {
    window._sf_endpt=(new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');
    document.body.appendChild(e);
  }
  var oldonload = window.onload;
  window.onload = (typeof window.onload != 'function') ?
     loadChartbeat : function() { oldonload(); loadChartbeat(); };
})();

</script>
<meta name="msvalidate.01" content="233723BF6DDA97CDD8B487EF0657781A" />
<meta name="msvalidate.01" content="FCF3E52D3E47C55EC9661F1B50A9557F" />
<meta name="google-site-verification" content="oOM2K_DOqZ7CNZU6fqonByIjTNFk-JRv-rQlZgGBlaA" />
<meta name="msvalidate.01" content="9D426546C559809C8860DDED269CEE3A" />
<meta name="bitly-verification" content="fd057f9c2ad2">
<meta name="alexaVerifyID" content="RRUWOIxb9cZKaMEDdLln6zK8xdU" />
<meta name="verify-v1" content="9qDJmIb796OPXiiNNY5APYXx8P6v/07WYg89axmuZBo=" />
<meta name="verify-v1" content="gXwx5P2qZhcu9i5SCsZOYaGHfhHW6xyiSAa2Mi1ZlpI=" />

<meta name='microid' content='mailto+http:sha1:474f91e314f134328298a9e9989d8d2916e1deed' />

<script>
!function(e,t,n,s,u,a){e.twq||(s=e.twq=function(){s.exe?s.exe.apply(s,arguments):s.queue.push(arguments);
},s.version='1.1',s.queue=[],u=t.createElement(n),u.async=!0,u.src='//static.ads-twitter.com/uwt.js',
a=t.getElementsByTagName(n)[0],a.parentNode.insertBefore(u,a))}(window,document,'script');
// Insert Twitter Pixel ID and Standard Event data below
twq('init','o4fuy');
twq('track','PageView');
</script>

<script defer src='https://static.cloudflareinsights.com/beacon.min.js' data-cf-beacon='{"token": "c84345d83bbb443197d16b284dcd3bdd"}'></script>
<script type='text/javascript' id='disqus_count-js-extra'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"towleroad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.21' id='disqus_count-js'></script>
<script type='text/javascript' id='disqus_embed-js-extra'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.21"},"disqusIdentifier":"453575 https:\/\/www.towleroad.com\/?p=453575","disqusShortname":"towleroad","disqusTitle":"Sen. Mitch McConnell Speaks Up. Wants   Fellow Republican Men Vaccinated","disqusUrl":"https:\/\/www.towleroad.com\/2021\/04\/mconnell-republican-men-vaccinated\/","postId":"453575"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.21' id='disqus_embed-js'></script>
<script type='text/javascript' id='pdf-viewer-block-scripts-js-before'>
var pdfViewerUrl = "https://www.towleroad.com/wp-content/plugins/pdf-viewer-block/inc/pdfjs/web/viewer.html";
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/pdf-viewer-block/public/js/pdf-viewer-block.js?ver=5.7' id='pdf-viewer-block-scripts-js'></script>
<script type='text/javascript' id='advanced-ads-layer-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_layer_settings = {"layer_class":"towlelayer","placements":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-layer/public/assets/js/layer.js?ver=1.7.2' id='advanced-ads-layer-footer-js-js'></script>
<script type='text/javascript' id='advanced-ads-sticky-footer-js-js-extra'>
/* <![CDATA[ */
var advanced_ads_sticky_settings = {"check_position_fixed":"","sticky_class":"towlesticky","placements":["stickyright-inner","side-sticky","sticky-below","stickybar"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-sticky-ads/public/assets/js/sticky.js?ver=1.8.1' id='advanced-ads-sticky-footer-js-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/genesis-blocks/dist/assets/js/dismiss.js?ver=1616110591' id='genesis-blocks-dismiss-js-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/comment-reply.min.js?ver=5.7' id='comment-reply-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/hoverIntent.min.js?ver=1.8.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/genesis/lib/js/menu/superfish.min.js?ver=1.7.10' id='superfish-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/genesis/lib/js/menu/superfish.args.min.js?ver=3.3.3' id='superfish-args-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/genesis/lib/js/skip-links.min.js?ver=3.3.3' id='skip-links-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/news-pro/js/jquery.matchHeight.min.js?ver=3.2.2' id='news-match-height-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/news-pro/js/global.js?ver=3.2.2' id='news-global-js-js'></script>
<script type='text/javascript' id='news-responsive-menus-js-extra'>
/* <![CDATA[ */
var genesis_responsive_menu = {"mainMenu":"Menu","subMenu":"Submenu","menuClasses":{"combine":[".nav-secondary",".nav-primary",".nav-header"]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/themes/news-pro/js/responsive-menus.min.js?ver=3.2.2' id='news-responsive-menus-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' id='q2w3_fixed_widget-js-extra'>
/* <![CDATA[ */
var q2w3_sidebar_options = [{"sidebar":"sidebar","margin_top":10,"margin_bottom":0,"stop_id":"","screen_max_width":0,"screen_max_height":0,"width_inherit":false,"refresh_interval":1500,"window_load_hook":false,"disable_mo_api":false,"widgets":["towlewidget-3"]}];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/q2w3-fixed-widget/js/q2w3-fixed-widget.min.js?ver=5.3.0' id='q2w3_fixed_widget-js'></script>
<script type='text/javascript' id='advadsTrackingScript-js-extra'>
/* <![CDATA[ */
var advadsTracking = {"impressionActionName":"aatrack-records","clickActionName":"aatrack-click","targetClass":"towletarget","blogId":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/tracking.min.js?ver=2.0.0' id='advadsTrackingScript-js'></script>
<script type='text/javascript' id='advadsTrackingGAFront-js-extra'>
/* <![CDATA[ */
var advadsGALocale = {"Impressions":"Impressions","Clicks":"Clicks"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/ga-tracking.min.js?ver=2.0.0' id='advadsTrackingGAFront-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/advanced-ads-tracking/public/assets/js/dist/delayed.min.js?ver=2.0.0' id='advadsTrackingDelayed-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://www.towleroad.com/wp-includes/js/wp-embed.min.js?ver=5.7' id='wp-embed-js'></script>
<script type='text/javascript' id='dpp-js-extra'>
/* <![CDATA[ */
var dpp_ajax = {"ajaxurl":"https:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.towleroad.com/wp-content/plugins/disqus-popular-posts/dpp.js?ver=5.7' id='dpp-js'></script>
<script type="text/javascript">jQuery(document).ready(function($) { $(".ui-tabs").tabs(); });</script>
<script>window.advads_has_ads = [["450675","ad",null],["449800","ad",null],["449824","ad",null],["449835","ad",null],["449827","ad",null],["449785","ad",null]];

( window.advanced_ads_ready || jQuery( document ).ready ).call( null, function() {if ( !window.advanced_ads_pro ) {console.log("Advanced Ads Pro: cache-busting can not be initialized");} });</script><script>var advads_tracking_ads = {"1":[450675,449800,449824,449835,449827,449785]};var advads_tracking_urls = {"1":"https:\/\/www.towleroad.com\/wp-admin\/admin-ajax.php"};var advads_tracking_methods = {"1":"ga"};var advads_tracking_parallel = {"1":false};var advads_tracking_linkbases = {"1":"https:\/\/www.towleroad.com\/linkout\/"};var advads_gatracking_uids = {"1":"UA-2831501-1"};var advads_gatracking_allads = {"1":{"450675":{"title":"header codes","target":"","impression":true,"click":true},"450674":{"title":"Rectangle4","target":"","impression":false,"click":false},"450673":{"title":"Rectangle3","target":"","impression":false,"click":false},"450672":{"title":"Rectangle2","target":"","impression":false,"click":false},"450671":{"title":"Rectangle1","target":"","impression":false,"click":false},"450670":{"title":"Banner1","target":"","impression":false,"click":false},"450669":{"title":"Banner2","target":"","impression":false,"click":false},"449835":{"title":"Rec4","target":"","impression":true,"click":true},"449826":{"title":"Adsense Native","target":"","impression":true,"click":true},"449827":{"title":"Rec3","target":"","impression":true,"click":true},"449825":{"title":"Rec2","target":"","impression":true,"click":true},"449824":{"title":"Rec1","target":"","impression":true,"click":true},"449800":{"title":"Leader1","target":"","impression":true,"click":true},"449788":{"title":"Header ad codes","target":"","impression":false,"click":false},"449785":{"title":"leader2","target":"","impression":true,"click":true}}};var advads_gatracking_anonym = false;var advads_gatracking_transmitpageqs = {};</script></body></html>
